aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-10-01 20:33:37 +0800
committerpav <pav@FreeBSD.org>2010-10-01 20:33:37 +0800
commite1ff50a18f5230702279f344d1f5d4b4ada42687 (patch)
treec77e7466ffa1e4d3556ea75c499a7c871f998b28
parent88d717a14f766f5bc89af02309d89510c7ca1602 (diff)
downloadfreebsd-ports-gnome-e1ff50a18f5230702279f344d1f5d4b4ada42687.tar.gz
freebsd-ports-gnome-e1ff50a18f5230702279f344d1f5d4b4ada42687.tar.zst
freebsd-ports-gnome-e1ff50a18f5230702279f344d1f5d4b4ada42687.zip
- Update to 3.2.0
PR: ports/150782 Submitted by: Pavel Pankov <pankov_p@mail.ru> (maintainer)
-rw-r--r--www/ziproxy/Makefile41
-rw-r--r--www/ziproxy/distinfo6
-rw-r--r--www/ziproxy/files/patch-ziproxy.conf37
-rw-r--r--www/ziproxy/pkg-descr6
-rw-r--r--www/ziproxy/pkg-plist4
5 files changed, 63 insertions, 31 deletions
diff --git a/www/ziproxy/Makefile b/www/ziproxy/Makefile
index 8e4cfa98b2fa..c53e9d58b3d0 100644
--- a/www/ziproxy/Makefile
+++ b/www/ziproxy/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= ziproxy
-PORTVERSION= 3.1.3
+PORTVERSION= 3.2.0
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -38,41 +38,43 @@ USE_RC_SUBR= ziproxy
SUB_FILES+= pkg-message
-OPTIONS+= JPEG2000 "Build with JPEG2000 support" on
+OPTIONS+= JPEG2000 "Build with JPEG2000 support" on \
+ SASL "Build with SASL auth support" on \
+ NAMESERVERS "Enable Nameservers config option" on
ERROR_FILES= 400.html 403.html 404.html 407.html 408.html 409.html \
500.html 503.html
SAMPLE_CONFIG_FILES= bo_exception.list change_tos.list deny.list http.passwd \
noprocess.list replace.list replace_ct.list \
- ziproxy.conf
+ ziproxy.conf sasl/ziproxy.conf
post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%DATADIR%%|${DATADIR}|g' \
${WRKSRC}/etc/ziproxy/ziproxy.conf
post-install:
- @${MKDIR} ${PREFIX}/etc/ziproxy
+ ${MKDIR} ${PREFIX}/etc/ziproxy/sasl
.for FILE in ${SAMPLE_CONFIG_FILES}
- @${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/${FILE} ${PREFIX}/etc/ziproxy/${FILE}.sample
+ ${INSTALL_DATA} ${WRKSRC}/etc/ziproxy/${FILE} ${PREFIX}/etc/ziproxy/${FILE}.sample
.endfor
- @if [ ! -f ${PREFIX}/etc/ziproxy/ziproxy.conf ]; then \
+ if [ ! -f ${PREFIX}/etc/ziproxy/ziproxy.conf ]; then \
${CP} -p ${WRKSRC}/etc/ziproxy/ziproxy.conf ${PREFIX}/etc/ziproxy/ziproxy.conf ; \
fi
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
.for FILE in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/${DOC}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/${FILE}
.endfor
.endif
- @${MKDIR} ${DATADIR}/error
+ ${MKDIR} ${DATADIR}/error
.for FILE in ${ERROR_FILES}
- @${INSTALL_DATA} ${WRKSRC}/var/ziproxy/error/${FILE} ${DATADIR}/error/${FILE}
+ ${INSTALL_DATA} ${WRKSRC}/var/ziproxy/error/${FILE} ${DATADIR}/error/${FILE}
.endfor
- @${INSTALL_SCRIPT} ${WRKSRC}/src/tools/ziproxy_genhtml_stats.sh ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/tools/ziproxy_genhtml_stats.sh ${PREFIX}/bin
@${CAT} ${PKGMESSAGE}
@@ -81,6 +83,21 @@ post-install:
.if !defined(WITHOUT_JPEG2000)
CONFIGURE_ARGS+= --with-jasper
LIB_DEPENDS+= jasper.4:${PORTSDIR}/graphics/jasper
+.else
+CONFIGURE_ARGS+= --without-jasper
+.endif
+
+.if !defined(WITHOUT_SASL)
+CONFIGURE_ARGS+= --with-sasl2
+LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
+.else
+CONFIGURE_ARGS+= --without-sasl2
+.endif
+
+.if !defined(WITHOUT_NAMESERVERS)
+CONFIGURE_ARGS+= --enable-nameservers
+.else
+CONFIGURE_ARGS+= --disable-nameservers
.endif
.include <bsd.port.post.mk>
diff --git a/www/ziproxy/distinfo b/www/ziproxy/distinfo
index 11b3ffb67e90..a342b6664497 100644
--- a/www/ziproxy/distinfo
+++ b/www/ziproxy/distinfo
@@ -1,3 +1,3 @@
-MD5 (ziproxy-3.1.3.tar.bz2) = dd09206461dc9b11833ff2823943ac9f
-SHA256 (ziproxy-3.1.3.tar.bz2) = d5cbb42de327c66c76b6332cb06ca294df8c5130481500c6e93788951211b7a2
-SIZE (ziproxy-3.1.3.tar.bz2) = 261227
+MD5 (ziproxy-3.2.0.tar.bz2) = fb5fd0ba0ddd8412cd3a767ac63075ff
+SHA256 (ziproxy-3.2.0.tar.bz2) = b2b67ec63169e24e523aac7bf7bd576b20786ae281f0f8b87ae518a093bde87e
+SIZE (ziproxy-3.2.0.tar.bz2) = 264466
diff --git a/www/ziproxy/files/patch-ziproxy.conf b/www/ziproxy/files/patch-ziproxy.conf
index 10253c5661e2..d4c2936545ae 100644
--- a/www/ziproxy/files/patch-ziproxy.conf
+++ b/www/ziproxy/files/patch-ziproxy.conf
@@ -1,5 +1,5 @@
---- etc/ziproxy/ziproxy.conf.orig 2010-03-08 12:23:20.000000000 +0300
-+++ etc/ziproxy/ziproxy.conf 2010-03-12 23:51:38.000000000 +0300
+--- etc/ziproxy/ziproxy.conf.orig 2010-09-04 06:06:15.000000000 +0400
++++ etc/ziproxy/ziproxy.conf 2010-09-10 00:52:13.000000000 +0400
@@ -12,12 +12,12 @@
## If you have more than one network interface,
## it's useful for restricting to which interface you want to bind to.
@@ -24,16 +24,25 @@
## This is the content-type list of data that should
## have their traffic "differentiated"
-@@ -261,7 +261,7 @@
- ## HTTP auth file
- ## Should contain user:pass pairs, lines no longer than 128 chars
- ## Password is unencrypted
--# PasswdFile="/etc/ziproxy/http.passwd"
-+# PasswdFile="%%PREFIX%%/etc/ziproxy/http.passwd"
+@@ -279,7 +279,7 @@
+ ##
+ ## Default: (undefined)
+ ## See also: AuthMode
+-# AuthPasswdFile = "/etc/ziproxy/http.passwd"
++# AuthPasswdFile = "%%PREFIX%%/etc/ziproxy/http.passwd"
+
+ ## Path to Ziproxy's SASL configuration file, where
+ ## a file named "ziproxy.conf" (not related to this one)
+@@ -288,7 +288,7 @@
+ ##
+ ## Default: (default SASL setting, OS-dependent, may be /etc/sasl2/)
+ ## See also: AuthMode
+-# AuthSASLConfPath = "/etc/ziproxy/sasl/"
++# AuthSASLConfPath = "%%PREFIX%%/etc/ziproxy/sasl/"
## Forward everything to another proxy server.
## Modifications/compression is still applied.
-@@ -299,7 +299,7 @@
+@@ -330,7 +330,7 @@
## This option has no effect if BindOutgoing is not used.
## Default: empty, no hosts are exempted.
## See also: BindOutgoingExAddr
@@ -42,7 +51,7 @@
## Defines a specific IP to be bound to for hosts specified in BindOutgoingExList.
## As with BindOutgoing, this IP must be a local IP from the server running Ziproxy.
-@@ -664,7 +664,7 @@
+@@ -702,7 +702,7 @@
## *** THIS IS NOT SUPPOSED TO BE A DEFINITIVE SOLUTION TO INCOMPATIBILITIES ***
##
## Default: empty (no file specified, inactive)
@@ -51,7 +60,7 @@
## This option specifies a file containing a list of URLs which its
## data should be intercepted and replaced by another.
-@@ -683,7 +683,7 @@
+@@ -721,7 +721,7 @@
##
## Default: empty (no file specified, inactive)
## See also: URLReplaceDataCT
@@ -60,7 +69,7 @@
## Same as URLReplaceData, except it will only replace the data
## from matching URLs if the content-type matches
-@@ -697,7 +697,7 @@
+@@ -735,7 +735,7 @@
##
## Default: empty (no file specified, inactive)
## See also: URLReplaceDataCTList, URLReplaceData
@@ -69,7 +78,7 @@
## List of content-types to use with the URLReplaceDataCT option.
## This option is required by URLReplaceDataCT.
-@@ -723,7 +723,7 @@
+@@ -761,7 +761,7 @@
## A "access denied" 403 error will be returned when trying to access
## one of those URLs.
## Default: empty (no file specified, inactive)
@@ -78,7 +87,7 @@
## Custom HTTP Error Messages
## Define here the full path to the HTML file which should be
-@@ -731,21 +731,21 @@
+@@ -769,21 +769,21 @@
## Note: The internal defaults give more precise error messages.
##
## 400 - Bad request (malformed URL, or unknown URL type)
diff --git a/www/ziproxy/pkg-descr b/www/ziproxy/pkg-descr
index a33b18194319..ba829fb5969c 100644
--- a/www/ziproxy/pkg-descr
+++ b/www/ziproxy/pkg-descr
@@ -2,6 +2,10 @@ Ziproxy is forwarding, non-caching, compressing HTTP proxy server.
Basically it squeezes images by converting them to lower quality JPEGs or
JPEG 2000 and compresses (gzip) HTML and other text-like data.
It also provides other features such as: HTML/JS/CSS optimization, preemptive
-hostname resolution, transparent proxying and more.
+hostname resolution, transparent proxying, IP ToS marking (QoS), Ad-Blocker,
+detailed logging and more.
+Ziproxy does not require a client software and provides acceleration for any
+web browser, any operational system.
+
WWW: http://ziproxy.sourceforge.net/
diff --git a/www/ziproxy/pkg-plist b/www/ziproxy/pkg-plist
index 42a5396974e5..1682bc646fe3 100644
--- a/www/ziproxy/pkg-plist
+++ b/www/ziproxy/pkg-plist
@@ -1,7 +1,7 @@
bin/ziproxy
bin/ziproxylogtool
bin/ziproxy_genhtml_stats.sh
-@exec mkdir -p %D/etc/ziproxy
+@exec mkdir -p %D/etc/ziproxy/sasl
etc/ziproxy/bo_exception.list.sample
etc/ziproxy/change_tos.list.sample
etc/ziproxy/deny.list.sample
@@ -12,6 +12,8 @@ etc/ziproxy/replace_ct.list.sample
@unexec if cmp -s %D/etc/ziproxy/ziproxy.conf.sample %D/etc/ziproxy/ziproxy.conf; then rm -f %D/etc/ziproxy/ziproxy.conf; fi
@exec if [ ! -f %D/etc/ziproxy/ziproxy.conf ] ; then cp -p %D/%F %B/ziproxy.conf; fi
etc/ziproxy/ziproxy.conf.sample
+etc/ziproxy/sasl/ziproxy.conf.sample
+@dirrmtry etc/ziproxy/sasl
@dirrmtry etc/ziproxy
%%DATADIR%%/error/400.html
%%DATADIR%%/error/403.html