aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2010-09-16 07:54:09 +0800
committerglarkin <glarkin@FreeBSD.org>2010-09-16 07:54:09 +0800
commite2d3384eddad8ce49e4deb7d89cead716163bcb1 (patch)
tree91e825f652d021880a6a5896ba3e3140a0306066
parent73236f68154fef9927197535cbed9c206d3b410f (diff)
downloadfreebsd-ports-gnome-e2d3384eddad8ce49e4deb7d89cead716163bcb1.tar.gz
freebsd-ports-gnome-e2d3384eddad8ce49e4deb7d89cead716163bcb1.tar.zst
freebsd-ports-gnome-e2d3384eddad8ce49e4deb7d89cead716163bcb1.zip
- Fix linker errors by adding Perl build dependency (needed for configure
script) and adding proper SASL library to CONFIGURE_ENV. If the libmemcached support option is selected in this port and the libmemcached library was built with SASL support, our library test in the configure script failed silently with a linker error. - Minor OPTION processing cleanups and whitespace fixes Reported by: pointhat
-rw-r--r--devel/gearmand/Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/devel/gearmand/Makefile b/devel/gearmand/Makefile
index 9bd252e70794..d11ad707eb0c 100644
--- a/devel/gearmand/Makefile
+++ b/devel/gearmand/Makefile
@@ -17,8 +17,8 @@ COMMENT= Gearman C Server and Library
LIB_DEPENDS= event:${PORTSDIR}/devel/libevent \
uuid:${PORTSDIR}/misc/e2fsprogs-libuuid
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
FETCH_ARGS= -pRr
+USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack
USE_LDCONFIG= yes
@@ -146,6 +146,16 @@ MAN8= gearmand.8
.include <bsd.port.pre.mk>
+# This hack is required for the test programs invoked by configure,
+# in the event that libmemcached was compiled with SASL support.
+.if exists(${LOCALBASE}/lib/libsasl.so)
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lsasl"
+.elif exists(${LOCALBASE}/lib/libsasl2.a)
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lsasl2"
+.else
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.ifdef(WITH_DRIZZLE)
CONFIGURE_ARGS+= --with-libdrizzle-prefix
LIB_DEPENDS+= drizzle:${PORTSDIR}/databases/libdrizzle
@@ -153,23 +163,23 @@ LIB_DEPENDS+= drizzle:${PORTSDIR}/databases/libdrizzle
CONFIGURE_ARGS+= --disable-libdrizzle
.endif
-.ifdef(WITHOUT_MEMCACHED)
-CONFIGURE_ARGS+= --disable-libmemcached
+.ifdef(WITH_MEMCACHED)
+CONFIGURE_ARGS+= --with-libmemcached-prefix
+LIB_DEPENDS+= memcached:${PORTSDIR}/databases/libmemcached
.else
-CONFIGURE_ARGS+= --with-libmemcached-prefix --without-memcached
-LIB_DEPENDS+= memcached:${PORTSDIR}/databases/libmemcached
+CONFIGURE_ARGS+= --disable-libmemcached
.endif
.ifdef(WITH_PQ)
CONFIGURE_ARGS+= --with-libpq-prefix
-USE_PGSQL= yes
+USE_PGSQL= yes
.else
CONFIGURE_ARGS+= --disable-libpq
.endif
.ifdef(WITH_SQLITE3)
CONFIGURE_ARGS+= --with-libsqlite3-prefix
-USE_SQLITE= yes
+USE_SQLITE= yes
.else
CONFIGURE_ARGS+= --disable-libsqlite3
.endif