aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2008-01-25 07:29:53 +0800
committerwxs <wxs@FreeBSD.org>2008-01-25 07:29:53 +0800
commite35f568c85218c4602528f2c2de62f74334510cd (patch)
tree713ae0e25fba5bb320b60c76b06517955c1f2162
parent58aaab6c2c43c1b48e6769100241408bfb3126fc (diff)
downloadfreebsd-ports-gnome-e35f568c85218c4602528f2c2de62f74334510cd.tar.gz
freebsd-ports-gnome-e35f568c85218c4602528f2c2de62f74334510cd.tar.zst
freebsd-ports-gnome-e35f568c85218c4602528f2c2de62f74334510cd.zip
Add an RC script.
PR: ports/119553 Submitted by: Oleg Pudeyev <oleg@bsdpower.com> Approved by: Mohacsi Janos (maintainer), garga (mentor)
-rw-r--r--www/bozohttpd/Makefile2
-rw-r--r--www/bozohttpd/files/bozohttpd.in30
2 files changed, 32 insertions, 0 deletions
diff --git a/www/bozohttpd/Makefile b/www/bozohttpd/Makefile
index 296c6c5e23c8..e4f45f2fac4b 100644
--- a/www/bozohttpd/Makefile
+++ b/www/bozohttpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bozohttpd
PORTVERSION= 20060517
+PORTREVISION= 1
CATEGORIES= www ipv6
MASTER_SITES= http://www.eterna.com.au/bozohttpd/ \
${MASTER_SITE_NETBSD}
@@ -15,6 +16,7 @@ MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= The bozotic HTTP server
USE_BZIP2= YES
+USE_RC_SUBR= bozohttpd
.if defined(WITH_HTPASSWD_SUPPORT)
CFLAGS+= -DDO_HTPASSWD
diff --git a/www/bozohttpd/files/bozohttpd.in b/www/bozohttpd/files/bozohttpd.in
new file mode 100644
index 000000000000..4a5be1fdcb2b
--- /dev/null
+++ b/www/bozohttpd/files/bozohttpd.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: bozohttpd
+# REQUIRE: DAEMON
+#
+#
+# Add the following lines to /etc/rc.conf to enable bozohttpd:
+#
+# bozohttpd_enable (bool): Set it to "YES" to enable bozohttpd.
+# Default is "NO".
+# bozohttpd_flags (str): Options to pass to bozohttpd.
+# Default is "-b -t /var/empty -U nobody /".
+# The last argument, slashdir, is required.
+#
+
+. %%RC_SUBR%%
+
+name="bozohttpd"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${bozohttpd_enable="NO"}
+: ${bozohttpd_flags="-b -t /var/empty -U nobody /"}
+
+command=%%PREFIX%%/libexec/${name}
+
+run_rc_command "$1"