aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-06-08 06:29:01 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-06-08 06:29:01 +0800
commite7613df55dd5efc7ad88a38fd8197b146424999f (patch)
treecc40da70afadc29f714c7e3641acd7e2a7a90866
parent4f910b051eb09c7cb339634eab6241372e1c6d35 (diff)
downloadfreebsd-ports-gnome-e7613df55dd5efc7ad88a38fd8197b146424999f.tar.gz
freebsd-ports-gnome-e7613df55dd5efc7ad88a38fd8197b146424999f.tar.zst
freebsd-ports-gnome-e7613df55dd5efc7ad88a38fd8197b146424999f.zip
Fix ports using GH_TAGNAME=master to depend on a known hash
instead of a branch that changes. With hat: portmgr
-rw-r--r--CHANGES8
-rw-r--r--archivers/nwreckdum/Makefile2
-rw-r--r--audio/libechonest/Makefile2
-rw-r--r--deskutils/growl-for-linux/Makefile2
-rw-r--r--devel/cocaine-core/Makefile2
-rw-r--r--devel/eblob/Makefile2
-rw-r--r--devel/jsmin/Makefile2
-rw-r--r--devel/libeio/Makefile2
-rw-r--r--devel/libslave/Makefile2
-rw-r--r--devel/smack/Makefile2
-rw-r--r--games/asteroid/Makefile2
-rw-r--r--games/bombherman/Makefile2
-rw-r--r--games/netwalk/Makefile2
-rw-r--r--ports-mgmt/prhistory/Makefile2
-rw-r--r--textproc/py-elib.intl/Makefile2
-rw-r--r--www/blastbeat/Makefile2
-rw-r--r--www/eaccelerator/Makefile2
17 files changed, 24 insertions, 16 deletions
diff --git a/CHANGES b/CHANGES
index 182c4244a12c..6f4d00c30a0b 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,14 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20130607:
+AUTHOR: bdrewery@FreeBSD.org
+
+ * Checks were added to block GH_TAGNAME=master as this is not a valid
+ setup. A known hash or tag should be used for GH_TAGNAME instead of
+ a branch name. As soon as a branch is updated, the known checksum
+ in the distinfo would then be invalid.
+
20130606:
AUTHOR: bdrewery@FreeBSD.org
diff --git a/archivers/nwreckdum/Makefile b/archivers/nwreckdum/Makefile
index e45eceb36f73..e9bec83f31d3 100644
--- a/archivers/nwreckdum/Makefile
+++ b/archivers/nwreckdum/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
USE_GITHUB= yes
GH_ACCOUNT= danfe
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 22cbc47
PLIST_FILES= bin/${PORTNAME}
diff --git a/audio/libechonest/Makefile b/audio/libechonest/Makefile
index ffc9bc573fd7..6e40cde9e4f8 100644
--- a/audio/libechonest/Makefile
+++ b/audio/libechonest/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= qjson:${PORTSDIR}/devel/qjson
GH_ACCOUNT= dschmidt
GH_PROJECT= ${PORTNAME}
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= f9a55d1
USES= cmake pkgconfig
diff --git a/deskutils/growl-for-linux/Makefile b/deskutils/growl-for-linux/Makefile
index bcffc8d8c8d3..877bc0b70e0a 100644
--- a/deskutils/growl-for-linux/Makefile
+++ b/deskutils/growl-for-linux/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
GH_ACCOUNT= mattn
GH_COMMIT= cab80f2
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
GNU_CONFIGURE= yes
diff --git a/devel/cocaine-core/Makefile b/devel/cocaine-core/Makefile
index 10a50054e980..2ec9c75a788c 100644
--- a/devel/cocaine-core/Makefile
+++ b/devel/cocaine-core/Makefile
@@ -25,7 +25,7 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= zloidemon
GH_COMMIT= 7d0f35c
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
MAKE_JOBS_SAFE= yes
diff --git a/devel/eblob/Makefile b/devel/eblob/Makefile
index c33dac936fd9..5334df04b8ab 100644
--- a/devel/eblob/Makefile
+++ b/devel/eblob/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost-libs
USE_GITHUB= yes
GH_ACCOUNT= zloidemon
GH_COMMIT= 0a75b89
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
USES= cmake
USE_LDCONFIG= yes
diff --git a/devel/jsmin/Makefile b/devel/jsmin/Makefile
index 008058eff9f9..da8d22c74d6c 100644
--- a/devel/jsmin/Makefile
+++ b/devel/jsmin/Makefile
@@ -11,7 +11,7 @@ COMMENT= The JavaScript Minifier
USE_GITHUB= yes
GH_ACCOUNT= douglascrockford
GH_PROJECT= JSMin
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 1bf6ce5
PLIST_FILES= bin/jsmin
diff --git a/devel/libeio/Makefile b/devel/libeio/Makefile
index 48e753e657a6..764e3c5ad4ec 100644
--- a/devel/libeio/Makefile
+++ b/devel/libeio/Makefile
@@ -10,7 +10,7 @@ COMMENT= Full-featured asynchronous I/O library for C
USE_GITHUB= yes
GH_ACCOUNT= scunningham
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= e1a62ab
USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
GNU_CONFIGURE= yes
diff --git a/devel/libslave/Makefile b/devel/libslave/Makefile
index 11d75b4df33c..0c5426cb868a 100644
--- a/devel/libslave/Makefile
+++ b/devel/libslave/Makefile
@@ -21,7 +21,7 @@ USE_MYSQL= client
USE_GITHUB= yes
GH_ACCOUNT= Begun
GH_COMMIT= 64d548b
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
PORTEXAMPLES= *
OPTIONS_DEFINE= STATIC TEST EXAMPLES
diff --git a/devel/smack/Makefile b/devel/smack/Makefile
index efea39dbc7a1..cbff4b557e73 100644
--- a/devel/smack/Makefile
+++ b/devel/smack/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost-libs \
USE_GITHUB= yes
GH_ACCOUNT= zloidemon
GH_COMMIT= 72c81bf
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
USES= cmake
USE_LDCONFIG= yes
diff --git a/games/asteroid/Makefile b/games/asteroid/Makefile
index 59db24b5f789..6f495699c412 100644
--- a/games/asteroid/Makefile
+++ b/games/asteroid/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv3
USE_GITHUB= yes
GH_ACCOUNT= chazomaticus
GH_PROJECT= asteroid
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 6d23595
USE_GL= glut
diff --git a/games/bombherman/Makefile b/games/bombherman/Makefile
index 542a8af0b88b..d7f6867c2620 100644
--- a/games/bombherman/Makefile
+++ b/games/bombherman/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
USE_GITHUB= yes
GH_ACCOUNT= Keruspe
GH_PROJECT= Bomb-her-man
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 8f5aa22
USE_SDL= sdl image mixer ttf
diff --git a/games/netwalk/Makefile b/games/netwalk/Makefile
index cd901fb965ee..9e0bc99a1583 100644
--- a/games/netwalk/Makefile
+++ b/games/netwalk/Makefile
@@ -19,7 +19,7 @@ LICENSE= GPLv3
USE_GITHUB= yes
GH_ACCOUNT= blynn
GH_PROJECT= ${PORTNAME}
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 634e7c9
USE_SDL= sdl ttf
diff --git a/ports-mgmt/prhistory/Makefile b/ports-mgmt/prhistory/Makefile
index fca202e0b112..0fb45c6484be 100644
--- a/ports-mgmt/prhistory/Makefile
+++ b/ports-mgmt/prhistory/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
USE_GITHUB= yes
GH_ACCOUNT= waitman
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 9113c59
MAN7= prhistory.7
diff --git a/textproc/py-elib.intl/Makefile b/textproc/py-elib.intl/Makefile
index b3737ff6956f..104667a9e8b4 100644
--- a/textproc/py-elib.intl/Makefile
+++ b/textproc/py-elib.intl/Makefile
@@ -12,7 +12,7 @@ COMMENT= Enhanced internationalization services for Python modules
LICENSE= LGPL3
GH_ACCOUNT= dieterv
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= d09997c
USE_GITHUB= yes
diff --git a/www/blastbeat/Makefile b/www/blastbeat/Makefile
index db7a2433847b..a88e99ad8733 100644
--- a/www/blastbeat/Makefile
+++ b/www/blastbeat/Makefile
@@ -23,7 +23,7 @@ USE_GMAKE= yes
USE_GITHUB= yes
GH_ACCOUNT= zloidemon
GH_COMMIT= cdac9a9
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
PORTEXAMPLES= *
CFLAGS+= -I${LOCALBASE}/include \
diff --git a/www/eaccelerator/Makefile b/www/eaccelerator/Makefile
index eedd4431fd15..b5f19c7c7261 100644
--- a/www/eaccelerator/Makefile
+++ b/www/eaccelerator/Makefile
@@ -14,7 +14,7 @@ DOCCOMM_DESC= Retain doc-comments in internal php structures
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}
-GH_TAGNAME= master
+GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 42067ac
OPTIONS_DEFINE= DOCCOMM