aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2000-12-07 00:57:04 +0800
committerdes <des@FreeBSD.org>2000-12-07 00:57:04 +0800
commite979be407f6991462a4460d811ab42d8a9bca802 (patch)
tree40771e4bbd72f996b29b2072a7046a531c72a931
parent16dc4751c0848a059d611dae447bf8b562f56f91 (diff)
downloadfreebsd-ports-gnome-e979be407f6991462a4460d811ab42d8a9bca802.tar.gz
freebsd-ports-gnome-e979be407f6991462a4460d811ab42d8a9bca802.tar.zst
freebsd-ports-gnome-e979be407f6991462a4460d811ab42d8a9bca802.zip
I forgot the sed magic for opera.sh.
Spotted by: jedgar
-rw-r--r--www/linux-opera-devel/Makefile6
-rw-r--r--www/linux-opera/Makefile6
-rw-r--r--www/linux-opera7/Makefile6
3 files changed, 15 insertions, 3 deletions
diff --git a/www/linux-opera-devel/Makefile b/www/linux-opera-devel/Makefile
index ab8f8eba275a..fbc80b97a964 100644
--- a/www/linux-opera-devel/Makefile
+++ b/www/linux-opera-devel/Makefile
@@ -17,9 +17,13 @@ RUN_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_base
NO_BUILD= yes
+do-configure:
+ ${SED} 's|%%PREFIX%%|${PREFIX}|; s|%%DISTNAME%%|${DISTNAME}|' \
+ <${FILESDIR}/opera.sh >${WRKDIR}/opera.sh
+
do-install:
(cd ${WRKDIR} && \
tar cf - ${DISTNAME} | tar --unlink -xpf - -C ${PREFIX})
- ${INSTALL_SCRIPT} ${FILESDIR}/opera.sh ${PREFIX}/bin/opera
+ ${INSTALL_SCRIPT} ${WRKDIR}/opera.sh ${PREFIX}/bin/opera
.include <bsd.port.mk>
diff --git a/www/linux-opera/Makefile b/www/linux-opera/Makefile
index ab8f8eba275a..fbc80b97a964 100644
--- a/www/linux-opera/Makefile
+++ b/www/linux-opera/Makefile
@@ -17,9 +17,13 @@ RUN_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_base
NO_BUILD= yes
+do-configure:
+ ${SED} 's|%%PREFIX%%|${PREFIX}|; s|%%DISTNAME%%|${DISTNAME}|' \
+ <${FILESDIR}/opera.sh >${WRKDIR}/opera.sh
+
do-install:
(cd ${WRKDIR} && \
tar cf - ${DISTNAME} | tar --unlink -xpf - -C ${PREFIX})
- ${INSTALL_SCRIPT} ${FILESDIR}/opera.sh ${PREFIX}/bin/opera
+ ${INSTALL_SCRIPT} ${WRKDIR}/opera.sh ${PREFIX}/bin/opera
.include <bsd.port.mk>
diff --git a/www/linux-opera7/Makefile b/www/linux-opera7/Makefile
index ab8f8eba275a..fbc80b97a964 100644
--- a/www/linux-opera7/Makefile
+++ b/www/linux-opera7/Makefile
@@ -17,9 +17,13 @@ RUN_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_base
NO_BUILD= yes
+do-configure:
+ ${SED} 's|%%PREFIX%%|${PREFIX}|; s|%%DISTNAME%%|${DISTNAME}|' \
+ <${FILESDIR}/opera.sh >${WRKDIR}/opera.sh
+
do-install:
(cd ${WRKDIR} && \
tar cf - ${DISTNAME} | tar --unlink -xpf - -C ${PREFIX})
- ${INSTALL_SCRIPT} ${FILESDIR}/opera.sh ${PREFIX}/bin/opera
+ ${INSTALL_SCRIPT} ${WRKDIR}/opera.sh ${PREFIX}/bin/opera
.include <bsd.port.mk>