aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2012-04-24 09:59:24 +0800
committerknu <knu@FreeBSD.org>2012-04-24 09:59:24 +0800
commitea95f60120716b4710efe58a5ad337bbe67ff304 (patch)
treeccd72610a3555cd7523bf368d139d9936cdf4866
parentd36fdddd0c96b8a56616bf7c3907db14cee0600f (diff)
downloadfreebsd-ports-gnome-ea95f60120716b4710efe58a5ad337bbe67ff304.tar.gz
freebsd-ports-gnome-ea95f60120716b4710efe58a5ad337bbe67ff304.tar.zst
freebsd-ports-gnome-ea95f60120716b4710efe58a5ad337bbe67ff304.zip
Update to 3.00k (patched).
-rw-r--r--shells/fd/Makefile3
-rw-r--r--shells/fd/distinfo4
-rw-r--r--shells/fd/files/patch-archive.c15
-rw-r--r--shells/fd/files/patch-dosdisk.c62
4 files changed, 18 insertions, 66 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index 1219b220e4ac..5add32354ad7 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fd
-PORTVERSION= 3.00j
-PORTREVISION= 1
+PORTVERSION= 3.00k
CATEGORIES= shells net
MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
ftp://ftp.unixusers.net/src/fdclone/
diff --git a/shells/fd/distinfo b/shells/fd/distinfo
index cbe01b76ffc5..89a4f7b209aa 100644
--- a/shells/fd/distinfo
+++ b/shells/fd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (FD-3.00j.tar.gz) = 43285bc4cdb0e37d52859972fe1b9030c187acbdf796920b085a364aa63f269e
-SIZE (FD-3.00j.tar.gz) = 925560
+SHA256 (FD-3.00k.tar.gz) = c818781e7b257e4f9c656d6d0d3d57c673ec08bd5f2b4bfad4d0ab18ac31e117
+SIZE (FD-3.00k.tar.gz) = 927192
diff --git a/shells/fd/files/patch-archive.c b/shells/fd/files/patch-archive.c
new file mode 100644
index 000000000000..ac6a86c8d5ec
--- /dev/null
+++ b/shells/fd/files/patch-archive.c
@@ -0,0 +1,15 @@
+Patch taken from [FDclone-users:00977].
+
+diff -ur ../old/FD-3.00k/archive.c ./archive.c
+--- ../old/FD-3.00k/archive.c Sat Apr 21 00:00:00 2012
++++ ./archive.c Sun Apr 22 19:33:51 2012
+@@ -969,8 +969,7 @@
+ poparchdupl();
+ return(-1);
+ }
+- maxfile = 0;
+- filepos = -1;
++ maxfile = filepos = 0;
+
+ return(1);
+ }
diff --git a/shells/fd/files/patch-dosdisk.c b/shells/fd/files/patch-dosdisk.c
deleted file mode 100644
index 55edfb9a39fa..000000000000
--- a/shells/fd/files/patch-dosdisk.c
+++ /dev/null
@@ -1,62 +0,0 @@
-This is a patch taken from [FDclone-users:00927].
-
-diff -u ../old/FD-3.00j/dosdisk.c ./dosdisk.c
---- ../old/FD-3.00j/dosdisk.c Sat Sep 25 00:00:00 2010
-+++ ./dosdisk.c Sun Sep 26 00:05:47 2010
-@@ -2269,7 +2269,7 @@
- {
- time_t mt;
- u_short date, time;
-- int isnow;
-+ int sec, isnow;
-
- mt = (time_t)0;
- isnow = 0;
-@@ -2277,9 +2277,12 @@
- t = Xtime(&mt);
- isnow++;
- }
-- getdostime(&date, &time, t);
-+ sec = getdostime(&date, &time, t);
-
-- if (!time && isnow) time = 0x0001;
-+ if (isnow) {
-+ if (!time) time = 0x0001;
-+ mt += (sec & 0x01) * 1000L;
-+ }
- buf[0] = time & 0xff;
- buf[1] = (time >> 8) & 0xff;
- buf[2] = date & 0xff;
-diff -u ../old/FD-3.00j/sysemu.c ./sysemu.c
---- ../old/FD-3.00j/sysemu.c Sat Sep 25 00:00:00 2010
-+++ ./sysemu.c Sun Sep 26 00:03:20 2010
-@@ -720,7 +720,7 @@
- return(attr);
- }
-
--VOID getdostime(dp, tp, t)
-+int getdostime(dp, tp, t)
- u_short *dp, *tp;
- time_t t;
- {
-@@ -733,6 +733,8 @@
- *tp = ((tm -> tm_hour & 0x1f) << 11)
- + ((tm -> tm_min & 0x3f) << 5)
- + ((tm -> tm_sec & 0x3e) >> 1);
-+
-+ return(tm -> tm_sec);
- }
- #endif /* DEP_DOSPATH */
-
-diff -u ../old/FD-3.00j/sysemu.h ./sysemu.h
---- ../old/FD-3.00j/sysemu.h Sat Sep 25 00:00:00 2010
-+++ ./sysemu.h Sat Sep 25 23:59:47 2010
-@@ -58,7 +58,7 @@
- extern u_int getunixmode __P_((u_int));
- extern time_t getunixtime __P_((u_int, u_int));
- extern u_short getdosmode __P_((u_int));
--extern VOID getdostime __P_((u_short *, u_short *, time_t));
-+extern int getdostime __P_((u_short *, u_short *, time_t));
- #endif
- #if defined (DEP_DIRENT)
- extern DIR *Xopendir __P_((CONST char *));