aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-07-31 23:47:19 +0800
committerlofi <lofi@FreeBSD.org>2004-07-31 23:47:19 +0800
commiteaa17c955f97d347dfd23f3a72472fcc2405e76d (patch)
tree5f28b4601d5d8c9edac9897240a1197ac28aa6d0
parent5c56aab12464a6f859e207bebd84d17c311ff4de (diff)
downloadfreebsd-ports-gnome-eaa17c955f97d347dfd23f3a72472fcc2405e76d.tar.gz
freebsd-ports-gnome-eaa17c955f97d347dfd23f3a72472fcc2405e76d.tar.zst
freebsd-ports-gnome-eaa17c955f97d347dfd23f3a72472fcc2405e76d.zip
Add calltree, a cache simulation and call tracing plugin for valgrind
PR: ports/69845 Submitted by: Simon Barner <barner@in.tum.de>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/callgrind/Makefile23
-rw-r--r--devel/callgrind/distinfo2
-rw-r--r--devel/callgrind/files/patch-src::Makefile.in11
-rw-r--r--devel/callgrind/files/patch-src::ct_main.c11
-rw-r--r--devel/callgrind/pkg-descr9
-rw-r--r--devel/callgrind/pkg-plist7
-rw-r--r--devel/calltree/Makefile23
-rw-r--r--devel/calltree/distinfo2
-rw-r--r--devel/calltree/files/patch-src::Makefile.in11
-rw-r--r--devel/calltree/files/patch-src::ct_main.c11
-rw-r--r--devel/calltree/pkg-descr9
-rw-r--r--devel/calltree/pkg-plist7
13 files changed, 127 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0f464fcc1d84..f1f1b0cf004f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -97,6 +97,7 @@
SUBDIR += c_c++_reference
SUBDIR += c_parser
SUBDIR += calibrator
+ SUBDIR += calltree
SUBDIR += cbrowser
SUBDIR += cc65
SUBDIR += ccache
diff --git a/devel/callgrind/Makefile b/devel/callgrind/Makefile
new file mode 100644
index 000000000000..9ad76ea879ab
--- /dev/null
+++ b/devel/callgrind/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: calltree
+# Date created: Jun 3 2004
+# Whom: Simon Barner <barner@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= calltree
+PORTVERSION= 0.9.7
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= kcachegrind
+
+MAINTAINER= barner@gmx.de
+COMMENT= Valgrind skin for cache simulation and call tracing
+
+RUN_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind
+BUILD_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/callgrind/distinfo b/devel/callgrind/distinfo
new file mode 100644
index 000000000000..fe9057e37270
--- /dev/null
+++ b/devel/callgrind/distinfo
@@ -0,0 +1,2 @@
+MD5 (calltree-0.9.7.tar.gz) = f1bb4e6446f26219cf5772849630b380
+SIZE (calltree-0.9.7.tar.gz) = 156812
diff --git a/devel/callgrind/files/patch-src::Makefile.in b/devel/callgrind/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..1b8f2bc36edb
--- /dev/null
+++ b/devel/callgrind/files/patch-src::Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Thu Jun 3 05:08:28 2004
++++ src/Makefile.in Thu Jun 3 05:08:54 2004
+@@ -116,7 +116,7 @@
+ SUBDIRS = .
+
+ AM_CFLAGS = $(WERROR) -DVG_LIBDIR="\"$(libdir)"\" \
+- -Winline -Wall -Wshadow -O -fomit-frame-pointer @PREFERRED_STACK_BOUNDARY@ -g
++ -fomit-frame-pointer @PREFERRED_STACK_BOUNDARY@
+
+
+ valdir = $(libdir)/valgrind
diff --git a/devel/callgrind/files/patch-src::ct_main.c b/devel/callgrind/files/patch-src::ct_main.c
new file mode 100644
index 000000000000..ea2d55da10fb
--- /dev/null
+++ b/devel/callgrind/files/patch-src::ct_main.c
@@ -0,0 +1,11 @@
+--- src/ct_main.c.orig Thu Jun 3 05:04:08 2004
++++ src/ct_main.c Thu Jun 3 05:05:51 2004
+@@ -5758,7 +5758,7 @@
+ /* Install own SIGILL handler */
+ sigill_new.ksa_handler = cpuid_SIGILL_handler;
+ sigill_new.ksa_flags = 0;
+- sigill_new.ksa_restorer = NULL;
++ // sigill_new.ksa_restorer = NULL;
+ res = VG_(ksigemptyset)( &sigill_new.ksa_mask );
+ CT_ASSERT(res == 0);
+
diff --git a/devel/callgrind/pkg-descr b/devel/callgrind/pkg-descr
new file mode 100644
index 000000000000..39591126455a
--- /dev/null
+++ b/devel/callgrind/pkg-descr
@@ -0,0 +1,9 @@
+Calltree uses runtime instrumentation via the Valgrind framework for its
+cache simulation and call tracing. This way, even shared libraries and
+dynamically opened plugins can be profiled. The data files generated by
+Calltree can be loaded into KCachegrind for browsing the performance results.
+
+But there is also a command line tool in the Calltree package to get ASCII
+reports from Calltree data files without the need to use KCachegrind.
+
+WWW: http://kcachegrind.sourceforge.net
diff --git a/devel/callgrind/pkg-plist b/devel/callgrind/pkg-plist
new file mode 100644
index 000000000000..8c807ea4e1f0
--- /dev/null
+++ b/devel/callgrind/pkg-plist
@@ -0,0 +1,7 @@
+bin/calltree
+bin/ct_annotate
+bin/ct_control
+include/valgrind/calltree.h
+lib/valgrind/vgskin_calltree.so
+share/doc/valgrind/ct_main.html
+share/doc/valgrind/ct_techdocs.html
diff --git a/devel/calltree/Makefile b/devel/calltree/Makefile
new file mode 100644
index 000000000000..9ad76ea879ab
--- /dev/null
+++ b/devel/calltree/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: calltree
+# Date created: Jun 3 2004
+# Whom: Simon Barner <barner@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= calltree
+PORTVERSION= 0.9.7
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= kcachegrind
+
+MAINTAINER= barner@gmx.de
+COMMENT= Valgrind skin for cache simulation and call tracing
+
+RUN_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind
+BUILD_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/calltree/distinfo b/devel/calltree/distinfo
new file mode 100644
index 000000000000..fe9057e37270
--- /dev/null
+++ b/devel/calltree/distinfo
@@ -0,0 +1,2 @@
+MD5 (calltree-0.9.7.tar.gz) = f1bb4e6446f26219cf5772849630b380
+SIZE (calltree-0.9.7.tar.gz) = 156812
diff --git a/devel/calltree/files/patch-src::Makefile.in b/devel/calltree/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..1b8f2bc36edb
--- /dev/null
+++ b/devel/calltree/files/patch-src::Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Thu Jun 3 05:08:28 2004
++++ src/Makefile.in Thu Jun 3 05:08:54 2004
+@@ -116,7 +116,7 @@
+ SUBDIRS = .
+
+ AM_CFLAGS = $(WERROR) -DVG_LIBDIR="\"$(libdir)"\" \
+- -Winline -Wall -Wshadow -O -fomit-frame-pointer @PREFERRED_STACK_BOUNDARY@ -g
++ -fomit-frame-pointer @PREFERRED_STACK_BOUNDARY@
+
+
+ valdir = $(libdir)/valgrind
diff --git a/devel/calltree/files/patch-src::ct_main.c b/devel/calltree/files/patch-src::ct_main.c
new file mode 100644
index 000000000000..ea2d55da10fb
--- /dev/null
+++ b/devel/calltree/files/patch-src::ct_main.c
@@ -0,0 +1,11 @@
+--- src/ct_main.c.orig Thu Jun 3 05:04:08 2004
++++ src/ct_main.c Thu Jun 3 05:05:51 2004
+@@ -5758,7 +5758,7 @@
+ /* Install own SIGILL handler */
+ sigill_new.ksa_handler = cpuid_SIGILL_handler;
+ sigill_new.ksa_flags = 0;
+- sigill_new.ksa_restorer = NULL;
++ // sigill_new.ksa_restorer = NULL;
+ res = VG_(ksigemptyset)( &sigill_new.ksa_mask );
+ CT_ASSERT(res == 0);
+
diff --git a/devel/calltree/pkg-descr b/devel/calltree/pkg-descr
new file mode 100644
index 000000000000..39591126455a
--- /dev/null
+++ b/devel/calltree/pkg-descr
@@ -0,0 +1,9 @@
+Calltree uses runtime instrumentation via the Valgrind framework for its
+cache simulation and call tracing. This way, even shared libraries and
+dynamically opened plugins can be profiled. The data files generated by
+Calltree can be loaded into KCachegrind for browsing the performance results.
+
+But there is also a command line tool in the Calltree package to get ASCII
+reports from Calltree data files without the need to use KCachegrind.
+
+WWW: http://kcachegrind.sourceforge.net
diff --git a/devel/calltree/pkg-plist b/devel/calltree/pkg-plist
new file mode 100644
index 000000000000..8c807ea4e1f0
--- /dev/null
+++ b/devel/calltree/pkg-plist
@@ -0,0 +1,7 @@
+bin/calltree
+bin/ct_annotate
+bin/ct_control
+include/valgrind/calltree.h
+lib/valgrind/vgskin_calltree.so
+share/doc/valgrind/ct_main.html
+share/doc/valgrind/ct_techdocs.html