aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-04-04 23:01:24 +0800
committerpav <pav@FreeBSD.org>2008-04-04 23:01:24 +0800
commiteaf34733adb118f7e4d3b2f07e945ee7a9c0cc4c (patch)
tree26a209b95b37d7b4c1fad4a43993b902498f63dd
parent4473a6b315b8f3fd24537f4c3f1d75c0dcb63700 (diff)
downloadfreebsd-ports-gnome-eaf34733adb118f7e4d3b2f07e945ee7a9c0cc4c.tar.gz
freebsd-ports-gnome-eaf34733adb118f7e4d3b2f07e945ee7a9c0cc4c.tar.zst
freebsd-ports-gnome-eaf34733adb118f7e4d3b2f07e945ee7a9c0cc4c.zip
qiv (graphics/qiv) is a great image viewer, but it does not use gtk2
but imlib for image handling. This is bad, because many distributions (well, at least gentoo) do not offer this library anymore as it's quite old and not maintained anymore. When the first release of pqiv was written, I used python, hence the name. I expected somebody else to write a c-rewrite of qiv, so I didn't really care about that. About one month later nothing had happened yet, so I did this on my own. Starting from 0.4 pqiv means "pretty quick image viewer", written in pure C, using gtk+-2.0. Features include: * Fullscreen * Slideshow * Rotate / Flip * (Automatic/manual) Zoom * Move by drag & drop in fullscreen * Keep preferences in a configuration file * Rather small executable (~36k), low ram consumtion, quick * Execute predefined commands, pipe images through them or display their output * Real transparency * Fade between images WWW: http://www.pberndt.com/Programme/Linux/pqiv/index.html PR: ports/122191 Submitted by: Martin Tournoij <carpetsmoker@xs4all.nl>
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pqiv/Makefile70
-rw-r--r--graphics/pqiv/distinfo3
-rw-r--r--graphics/pqiv/pkg-descr24
4 files changed, 98 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index aacaac484dd2..c8945cd252ff 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -602,6 +602,7 @@
SUBDIR += povray31
SUBDIR += ppmcaption
SUBDIR += ppminfo
+ SUBDIR += pqiv
SUBDIR += preview
SUBDIR += price
SUBDIR += proj
diff --git a/graphics/pqiv/Makefile b/graphics/pqiv/Makefile
new file mode 100644
index 000000000000..1110d9939978
--- /dev/null
+++ b/graphics/pqiv/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: graphics/pqiv
+# Date created: March 28 2008
+# Whom: Martin Tournoij <carpetsmoker@xs4all.nl>
+#
+# $Carpetsmoker: ports/graphics/pqiv/Makefile,v 1.1 2008/03/28 13:07:07 carpetsmoker Exp $
+# $FreeBSD$
+#
+
+PORTNAME= pqiv
+PORTVERSION= 0.7
+CATEGORIES= graphics
+MASTER_SITES= http://www.pberndt.com/raw//Programme/Linux/pqiv/_download/ \
+ http://www.carpetsmoker.net/distfiles/ \
+ http://www.xs4all.nl/~tournoij/distfiles/ \
+ http://www.rwxrwxrwx.net/distfiles/
+EXTRACT_SUFX= .tbz
+
+MAINTAINER= carpetsmoker@xs4all.nl
+COMMENT= Pretty Quick Image Viewer
+
+USE_BZIP2= yes
+USE_GNOME= gtk20 glib20 pango pkgconfig
+CFLAGS+= -DNO_INOTIFY
+PLIST_FILES= bin/pqiv
+PORTDOCS= README
+MAN1= pqiv.1
+MANCOMPRESSED= no
+
+OPTIONS= SORTING "Enable sorting of loaded files" on \
+ COMPOSITE "Enable support for transparent windows" on \
+ FADING "Enable support for fading images" on \
+ COMMANDS "Enable support for external command execution" on \
+ CONFIG "Enable support for a configuration file" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_SORTING)
+CFLAGS+= -DNO_SORTING
+SORTFILE= # Empty
+.else
+SORTFILE= ${WRKSRC}/lib/strnatcmp.c
+.endif
+.if defined(WITHOUT_COMPOSITE)
+CFLAGS+= -DNO_COMPOSITING
+.endif
+.if defined(WITHOUT_FADING)
+CFLAGS+= -DNO_FADING
+.endif
+.if defined(WITHOUT_COMMANDS)
+CFLAGS+= -DNO_COMMANDS
+.endif
+.if defined(WITHOUT_CONFIG)
+CFLAGS+= -DNO_CONFIG_FILE
+.endif
+
+do-build:
+ ${CC} ${CFLAGS} `${pkgconfig_DETECT} --libs --cflags gtk+-2.0 gthread-2.0 pango glib-2.0` \
+ ${SORTFILE} ${WRKSRC}/pqiv.c -o ${WRKSRC}/pqiv
+ @${REINPLACE_CMD} 's|$$PACKAGE_VERSION|${PORTVERSION}|' \
+ ${WRKSRC}/pqiv.1.template
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pqiv ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pqiv.1.template ${MAN1PREFIX}/man/man1/pqiv.1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/pqiv/distinfo b/graphics/pqiv/distinfo
new file mode 100644
index 000000000000..0713e1474198
--- /dev/null
+++ b/graphics/pqiv/distinfo
@@ -0,0 +1,3 @@
+MD5 (pqiv-0.7.tbz) = 0d5d77b9c25b94c015f7bbfb5c6d054b
+SHA256 (pqiv-0.7.tbz) = a52c27fa11e940526e16f9c8454ab7a6be1f59c186c2a382f03d2baa16c3eb3f
+SIZE (pqiv-0.7.tbz) = 30094
diff --git a/graphics/pqiv/pkg-descr b/graphics/pqiv/pkg-descr
new file mode 100644
index 000000000000..6aae92007e46
--- /dev/null
+++ b/graphics/pqiv/pkg-descr
@@ -0,0 +1,24 @@
+qiv (graphics/qiv) is a great image viewer, but it does not use gtk2
+but imlib for image handling. This is bad, because many distributions
+(well, at least gentoo) do not offer this library anymore as it's
+quite old and not maintained anymore.
+
+When the first release of pqiv was written, I used python, hence the
+name. I expected somebody else to write a c-rewrite of qiv, so I
+didn't really care about that. About one month later nothing had
+happened yet, so I did this on my own. Starting from 0.4 pqiv means
+"pretty quick image viewer", written in pure C, using gtk+-2.0.
+
+Features include:
+* Fullscreen
+* Slideshow
+* Rotate / Flip
+* (Automatic/manual) Zoom
+* Move by drag & drop in fullscreen
+* Keep preferences in a configuration file
+* Rather small executable (~36k), low ram consumtion, quick
+* Execute predefined commands, pipe images through them or display their output
+* Real transparency
+* Fade between images
+
+WWW: http://www.pberndt.com/Programme/Linux/pqiv/index.html