aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-07-09 20:34:11 +0800
committereik <eik@FreeBSD.org>2004-07-09 20:34:11 +0800
commiteb87e4187107af35d7bf95c3be76081d12d46414 (patch)
tree7bd02c6d68ad8beb64db18d1c32d02c625f5f39e
parentf9e1c45858fe50659781eb0446c3fbeb6385df5b (diff)
downloadfreebsd-ports-gnome-eb87e4187107af35d7bf95c3be76081d12d46414.tar.gz
freebsd-ports-gnome-eb87e4187107af35d7bf95c3be76081d12d46414.tar.zst
freebsd-ports-gnome-eb87e4187107af35d7bf95c3be76081d12d46414.zip
Add exslt, a community initiative to provide extensions to XSLT.
PR: 68821 Submitted by: Herve Quiroz <herve.quiroz@esil.univ-mrs.fr>
-rw-r--r--CVSROOT/modules1
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/exslt/Makefile38
-rw-r--r--textproc/exslt/distinfo2
-rw-r--r--textproc/exslt/pkg-descr19
5 files changed, 61 insertions, 0 deletions
diff --git a/CVSROOT/modules b/CVSROOT/modules
index 72e751576040..1e806a92a133 100644
--- a/CVSROOT/modules
+++ b/CVSROOT/modules
@@ -1779,6 +1779,7 @@ expat2 ports/textproc/expat2
expect ports/lang/expect
explosions ports/misc/explosions
expocity ports/x11-wm/expocity
+exslt ports/textproc/exslt
extace ports/audio/extace
extipl ports/sysutils/extipl
extract-xiso ports/emulators/extract-xiso
diff --git a/textproc/Makefile b/textproc/Makefile
index f0329b6d79ca..8faa5cc83682 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -93,6 +93,7 @@
SUBDIR += eruby
SUBDIR += es-aspell
SUBDIR += expat2
+ SUBDIR += exslt
SUBDIR += fdp-tools
SUBDIR += filepp
SUBDIR += fist
diff --git a/textproc/exslt/Makefile b/textproc/exslt/Makefile
new file mode 100644
index 000000000000..57a817f8a191
--- /dev/null
+++ b/textproc/exslt/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: exslt
+# Date created: 2004-07-08
+# Whom: Herve Quiroz <herve.quiroz@esil.univ-mrs.fr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= exslt
+PORTVERSION= 2003.10.24
+CATEGORIES= textproc
+MASTER_SITES= http://www.exslt.org/
+DISTNAME= all-${PORTNAME}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= herve.quiroz@esil.univ-mrs.fr
+COMMENT= Community initiative extensions to XSLT
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+DATAFILES= base.css date dyn exsl func howto.html index.html math random regexp set str
+
+do-install:
+ @${ECHO_MSG} ">> Installing stylesheets and documentation in ${DATADIR}"
+ @${MKDIR} ${DATADIR}
+ @cd ${WRKSRC} && \
+ ${FIND} ${DATAFILES} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
+ ${FIND} ${DATAFILES} ! -type d -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+
+post-install:
+ @${FIND} -s ${DATAFILES:S/^/${DATADIR}\//} ! -type d 2>/dev/null | \
+ ${SED} -ne 's,^${PREFIX}/,,p' >> ${TMPPLIST}
+ @${FIND} -s -d ${DATAFILES:S/^/${DATADIR}\//} -type d 2>/dev/null | \
+ ${SED} -ne 's,^${PREFIX}/,@dirrm ,p' >> ${TMPPLIST}
+ @${ECHO_CMD} '@dirrm ${DATADIR:S,^${PREFIX}/,,}' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/textproc/exslt/distinfo b/textproc/exslt/distinfo
new file mode 100644
index 000000000000..d7edc658b961
--- /dev/null
+++ b/textproc/exslt/distinfo
@@ -0,0 +1,2 @@
+MD5 (exslt-2003.10.24/all-exslt.zip) = 25cf4e5aae494405be3b4654c997db46
+SIZE (exslt-2003.10.24/all-exslt.zip) = 1152247
diff --git a/textproc/exslt/pkg-descr b/textproc/exslt/pkg-descr
new file mode 100644
index 000000000000..3582e950f5c8
--- /dev/null
+++ b/textproc/exslt/pkg-descr
@@ -0,0 +1,19 @@
+EXSLT is a community initiative to provide extensions to XSLT. The extensions
+are broken down into a number of modules, listed below. Implementers of XSLT
+processors are encouraged to use these extensions, so that your stylesheets can
+be more portable. If your XSLT processor doesn't support a particular
+extension, you will find packages that you can use to provide functions or
+templates for your stylesheets.
+
+- Common: common, basic extension elements and functions.
+- Math: facilities to do with maths.
+- Sets: facilities to do with set manipulation.
+- Functions: allow users to define their own functions for use in expressions
+ and patterns in XSLT.
+- Dates and Times: date and time-related extension elements and functions.
+- Strings: facilities to do with string manipulation.
+- Regular Expressions: facilities to do with regular expressions.
+- Dynamic: dynamic evaluation of strings containing XPath expressions.
+- Random: facilities to do with randomness.
+
+WWW: http://www.exslt.org/