aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-01-30 21:49:02 +0800
committerijliao <ijliao@FreeBSD.org>2002-01-30 21:49:02 +0800
commitebb3f687e97cddd35a4b00f5e490c6027e1b5e6c (patch)
treec829787d9f679f843e2868f94a650fdf08d0b4ba
parent99fcbde464eedb1beaae5801c11f0b8a74970f48 (diff)
downloadfreebsd-ports-gnome-ebb3f687e97cddd35a4b00f5e490c6027e1b5e6c.tar.gz
freebsd-ports-gnome-ebb3f687e97cddd35a4b00f5e490c6027e1b5e6c.tar.zst
freebsd-ports-gnome-ebb3f687e97cddd35a4b00f5e490c6027e1b5e6c.zip
add sonice 1.2
Sonice eases reencoding of .ogg files
-rw-r--r--audio/Makefile1
-rw-r--r--audio/sonice/Makefile30
-rw-r--r--audio/sonice/distinfo1
-rw-r--r--audio/sonice/pkg-comment1
-rw-r--r--audio/sonice/pkg-descr4
-rw-r--r--audio/sonice/pkg-plist3
6 files changed, 40 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index d9696fc237e2..7e0036fefe81 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -196,6 +196,7 @@
SUBDIR += snd
SUBDIR += snowstar
SUBDIR += songprint
+ SUBDIR += sonice
SUBDIR += soundtracker
SUBDIR += sox
SUBDIR += sphinx
diff --git a/audio/sonice/Makefile b/audio/sonice/Makefile
new file mode 100644
index 000000000000..2b6307ac7abc
--- /dev/null
+++ b/audio/sonice/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: sonice
+# Date created: Jan 30, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sonice
+PORTVERSION= 1.2
+CATEGORIES= audio
+MASTER_SITES= http://www.cyclooctane.com/sonice/release/
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= oggenc:${PORTSDIR}/audio/vorbis-tools \
+ flac:${PORTSDIR}/audio/flac
+
+USE_ZIP= yes
+USE_PYTHON= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sonice.py ${PREFIX}/bin/sonice
+.for file in commatoys ogg
+ ${INSTALL_SCRIPT} ${WRKSRC}/${file}.py ${PYTHON_SITELIBDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/audio/sonice/distinfo b/audio/sonice/distinfo
new file mode 100644
index 000000000000..64b3cb97e8ae
--- /dev/null
+++ b/audio/sonice/distinfo
@@ -0,0 +1 @@
+MD5 (sonice-1.2.zip) = 38ac53d2942fc547b4a744cae4dc2dab
diff --git a/audio/sonice/pkg-comment b/audio/sonice/pkg-comment
new file mode 100644
index 000000000000..8ca5653ec4f1
--- /dev/null
+++ b/audio/sonice/pkg-comment
@@ -0,0 +1 @@
+Sonice eases reencoding of .ogg files
diff --git a/audio/sonice/pkg-descr b/audio/sonice/pkg-descr
new file mode 100644
index 000000000000..14a4e2dce674
--- /dev/null
+++ b/audio/sonice/pkg-descr
@@ -0,0 +1,4 @@
+Sonice eases reencoding of .ogg files by storing everything you'd need to
+generate the files in question in lossless sources (.flac and .txt files).
+
+WWW: http://www.cyclooctane.com/sonice/
diff --git a/audio/sonice/pkg-plist b/audio/sonice/pkg-plist
new file mode 100644
index 000000000000..80a891202456
--- /dev/null
+++ b/audio/sonice/pkg-plist
@@ -0,0 +1,3 @@
+bin/sonice
+lib/%%PYTHON_VERSION%%/site-packages/comatoys.py
+lib/%%PYTHON_VERSION%%/site-packages/ogg.py