aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-04-13 05:55:33 +0800
committerthierry <thierry@FreeBSD.org>2004-04-13 05:55:33 +0800
commitef26d61afc5ddd6717560194a61b833b2c20a012 (patch)
tree837c06abbbf7e8e7d88349cc8cbabfe6894bc9b3
parent938971bdfbce3ffc4096ce3240b69be4e2a1f016 (diff)
downloadfreebsd-ports-gnome-ef26d61afc5ddd6717560194a61b833b2c20a012.tar.gz
freebsd-ports-gnome-ef26d61afc5ddd6717560194a61b833b2c20a012.tar.zst
freebsd-ports-gnome-ef26d61afc5ddd6717560194a61b833b2c20a012.zip
Add fpc-ibase 1.0.10, Free Pascal interface to interbase.
PR: 62620 Submitted by: John Merryweather Cooper Approved by: pav (mentor).
-rw-r--r--databases/Makefile1
-rw-r--r--databases/fpc-ibase/Makefile77
-rw-r--r--databases/fpc-ibase/distinfo2
-rw-r--r--databases/fpc-ibase/pkg-descr8
-rw-r--r--databases/fpc-ibase/pkg-plist10
5 files changed, 98 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 23c831121f25..0994e47c633a 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -33,6 +33,7 @@
SUBDIR += firebird
SUBDIR += firebird-devel
SUBDIR += fireprofile
+ SUBDIR += fpc-ibase
SUBDIR += fpc-odbc
SUBDIR += fpc-oracle
SUBDIR += fpc-postgres
diff --git a/databases/fpc-ibase/Makefile b/databases/fpc-ibase/Makefile
new file mode 100644
index 000000000000..f43b2725dfba
--- /dev/null
+++ b/databases/fpc-ibase/Makefile
@@ -0,0 +1,77 @@
+# New ports collection makefile for: Free Pascal ibase Unit
+# Date created: 9 February 2004
+# Whom: John Merryweather Cooper
+#
+# $FreeBSD$
+#
+
+PORTNAME= ibase
+PORTVERSION= 1.0.10
+CATEGORIES= databases lang
+MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ http://planetmirror.com/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.jp.freepascal.org/mirror/fpc/dist/FreeBSD/ \
+ ftp://freepascal.stack.nl/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.no.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.us.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= freepascal
+PKGNAMEPREFIX= fpc-
+DISTNAME= fpc-${PORTVERSION}.ELF
+EXTRACT_SUFX= .tar
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Free Pascal interface to interbase
+
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 470000
+EXTRACT_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
+TAR= ${LOCALBASE}/bin/gtar
+.endif
+USE_GMAKE= yes
+USE_REINPLACE= yes
+ONLY_FOR_ARCHS= i386
+
+PLIST_SUB+= INSTDIR=lib/fpc/${PORTVERSION}/units/freebsd/ibase \
+ PORTVERSION=${PORTVERSION}
+
+MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
+ FPC=${LOCALBASE}/bin/ppc386 \
+ INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
+ INSTALL_BINDIR=${PREFIX}/bin \
+ GCCLIBDIR=/usr/lib \
+ RELEASE=1
+
+do-extract:
+# unpack distribution
+ @${MKDIR} ${WRKSRC}
+ @${TAR} xf ${DISTDIR}/${DISTNAME}.tar --directory ${WRKSRC}
+# unpack sources distribution
+ @${MKDIR} ${WRKSRC}/sources
+ @${TAR} xf ${WRKSRC}/sources.tar --directory ${WRKSRC}/sources
+# further extract base sources
+#
+# interbase sources
+ @${TAR} zxf ${WRKSRC}/sources/unitsibasesrc.tar.gz \
+ --directory ${WRKSRC}
+
+post-patch:
+# change to alter amount of optimization
+ @${FIND} ${WRKSRC}/share/src/fpc-${PORTVERSION} -name \
+ "Makefile*" | ${XARGS} ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
+
+do-build:
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
+ ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/ibase \
+ all
+
+do-install:
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
+ ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/ibase \
+ install
+
+.include <bsd.port.post.mk>
diff --git a/databases/fpc-ibase/distinfo b/databases/fpc-ibase/distinfo
new file mode 100644
index 000000000000..54527a31654e
--- /dev/null
+++ b/databases/fpc-ibase/distinfo
@@ -0,0 +1,2 @@
+MD5 (fpc-1.0.10.ELF.tar) = 6ad56eb115152174683499da3ece7667
+SIZE (fpc-1.0.10.ELF.tar) = 17448960
diff --git a/databases/fpc-ibase/pkg-descr b/databases/fpc-ibase/pkg-descr
new file mode 100644
index 000000000000..b905fb33d2b7
--- /dev/null
+++ b/databases/fpc-ibase/pkg-descr
@@ -0,0 +1,8 @@
+Ibase is part of the base packages of Free Pascal, a 32-bit
+Turbo Pascal/Delphi compatible compiler. Ibase provides an
+interface to Interbase databases.
+
+WWW: http://www.freepascal.org/
+
+--
+John Merryweather Cooper <coop9211@uidaho.edu>
diff --git a/databases/fpc-ibase/pkg-plist b/databases/fpc-ibase/pkg-plist
new file mode 100644
index 000000000000..e5008a031872
--- /dev/null
+++ b/databases/fpc-ibase/pkg-plist
@@ -0,0 +1,10 @@
+%%INSTDIR%%/Package.fpc
+%%INSTDIR%%/ibase40.o
+%%INSTDIR%%/ibase40.ppu
+%%INSTDIR%%/ibase60.o
+%%INSTDIR%%/ibase60.ppu
+@dirrm %%INSTDIR%%
+@unexec rmdir %D/lib/fpc/%%PORTVERSION%%/units/freebsd 2>/dev/null || true
+@unexec rmdir %D/lib/fpc/%%PORTVERSION%%/units 2>/dev/null || true
+@unexec rmdir %D/lib/fpc/%%PORTVERSION%% 2>/dev/null || true
+@unexec rmdir %D/lib/fpc 2>/dev/null || true