aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-11-18 17:19:42 +0800
committerdanfe <danfe@FreeBSD.org>2015-11-18 17:19:42 +0800
commitf1bd757391bf65bba20aad26dcd863f84581edd4 (patch)
tree225d693e0f07400ea8d19fd04b887a0d4bcc72e0
parent70b7e58717578463c34aebded7aa762be15766b5 (diff)
downloadfreebsd-ports-gnome-f1bd757391bf65bba20aad26dcd863f84581edd4.tar.gz
freebsd-ports-gnome-f1bd757391bf65bba20aad26dcd863f84581edd4.tar.zst
freebsd-ports-gnome-f1bd757391bf65bba20aad26dcd863f84581edd4.zip
Currently, when bsd.port.mk outputs a message addressed to a user, it would
typically pipe it through ${FMT} 75 79 command to ensure that if it gets overly long, it would be wrapped nicely. Do the same when outputting IGNORE message which often gets very long. While here, add missing section number in sed(1) references in comments. Differential Revision: D4116 Approved by: portmgr (bapt)
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1ed4f64b6ed9..15bfb31aa717 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -565,7 +565,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR} "! -name *\.bak"
#
# Installs all directories and files from ${WRKSRC}/doc
-# to ${DOCSDIR} except sed backup files.
+# to ${DOCSDIR} except sed(1) backup files.
#
# MANPREFIX - The directory prefix for ${MAN<sect>} and ${MLINKS}.
# Default: ${PREFIX}
@@ -898,7 +898,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# PLIST_SUB - List of "variable=value" pair for substitution in ${PLIST}
# Default: see below
#
-# SUB_FILES - Files that should be passed through sed and redirected to
+# SUB_FILES - Files that should be passed through sed(1) and redirected to
# ${WRKDIR}.
# - For each file specified in SUB_FILES, there must be a
# corresponding file in ${FILESDIR} whose suffix is ".in". For
@@ -2815,7 +2815,7 @@ clean:
.if defined(IGNORE_SILENT)
IGNORECMD= ${DO_NADA}
.else
-IGNORECMD= ${ECHO_MSG} "===> ${PKGNAME} "${IGNORE:Q}.;exit 1
+IGNORECMD= ${ECHO_MSG} "===> ${PKGNAME} "${IGNORE:Q}. | ${FMT} 75 79 ; exit 1
.endif
_TARGETS= check-sanity fetch checksum extract patch configure all build \