aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2010-02-27 05:06:16 +0800
committerglarkin <glarkin@FreeBSD.org>2010-02-27 05:06:16 +0800
commitf51f41ac2c82b547905f4cb4ef929331f0021f0d (patch)
tree71cfd74e42ceafd0cc104e6fe972169cb66d205f
parent260d290285f81675880d1b4f365fd6e814761259 (diff)
downloadfreebsd-ports-gnome-f51f41ac2c82b547905f4cb4ef929331f0021f0d.tar.gz
freebsd-ports-gnome-f51f41ac2c82b547905f4cb4ef929331f0021f0d.tar.zst
freebsd-ports-gnome-f51f41ac2c82b547905f4cb4ef929331f0021f0d.zip
This Trac plugin adds burndown chart capabilities, a common part
of Scrum and other agile development methodologies. WWW: http://trac-hacks.org/wiki/ScrumBurndownPlugin Feature safe: yes
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-scrumburndown/Makefile32
-rw-r--r--www/trac-scrumburndown/distinfo3
-rw-r--r--www/trac-scrumburndown/pkg-descr4
-rw-r--r--www/trac-scrumburndown/pkg-message18
-rw-r--r--www/trac-scrumburndown/pkg-plist1
6 files changed, 59 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 1a20e7bcee19..74f26048a491 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1620,6 +1620,7 @@
SUBDIR += trac-remind
SUBDIR += trac-revtree
SUBDIR += trac-robotstxt
+ SUBDIR += trac-scrumburndown
SUBDIR += trac-simpleticket
SUBDIR += trac-spam-filter
SUBDIR += trac-tags
diff --git a/www/trac-scrumburndown/Makefile b/www/trac-scrumburndown/Makefile
new file mode 100644
index 000000000000..40ccda9cd3ad
--- /dev/null
+++ b/www/trac-scrumburndown/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: trac-scrumburndown
+# Date created: February 26 2010
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scrumburndown
+PORTVERSION= 1.9.2
+CATEGORIES= www devel python
+MASTER_SITES= http://www.sourcehosting.net/freebsd/distfiles/ \
+ LOCAL/glarkin
+PKGNAMEPREFIX= trac-
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= A plugin to enable Scrum burndown chart capabilities
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac \
+ trac-timingandestimation>=0:${PORTSDIR}/www/trac-timingandestimation
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+NO_BUILD= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION:S/.r/_r/} PYTHONVERSION=${_PYTHON_VERSION}
+PYDISTUTILS_NOEGGINFO= yes
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/trac-scrumburndown/distinfo b/www/trac-scrumburndown/distinfo
new file mode 100644
index 000000000000..82a3bb0eea8d
--- /dev/null
+++ b/www/trac-scrumburndown/distinfo
@@ -0,0 +1,3 @@
+MD5 (scrumburndown-1.9.2.tar.gz) = 78126633d1b2744f7387c24ba761edeb
+SHA256 (scrumburndown-1.9.2.tar.gz) = bcd7a685fdc191a590f0485991dd1f69063f9b1f29824beb4b5d775d85f06d95
+SIZE (scrumburndown-1.9.2.tar.gz) = 6194062
diff --git a/www/trac-scrumburndown/pkg-descr b/www/trac-scrumburndown/pkg-descr
new file mode 100644
index 000000000000..0a9d2615dcca
--- /dev/null
+++ b/www/trac-scrumburndown/pkg-descr
@@ -0,0 +1,4 @@
+This Trac plugin adds burndown chart capabilities, a common part
+of Scrum and other agile development methodologies.
+
+WWW: http://trac-hacks.org/wiki/ScrumBurndownPlugin
diff --git a/www/trac-scrumburndown/pkg-message b/www/trac-scrumburndown/pkg-message
new file mode 100644
index 000000000000..3d08569b3b37
--- /dev/null
+++ b/www/trac-scrumburndown/pkg-message
@@ -0,0 +1,18 @@
+**************************************************
+To complete the installation, please add:
+
+[components]
+timingandestimationplugin.* = enabled
+burndown.* = enabled
+
+to your trac.ini to enable the plugins.
+
+Next, upgrade your database with the command:
+
+ trac-admin /full/path/to/YourProjectName upgrade
+
+Finally, visit:
+http://trac-hacks.org/wiki/ScrumBurndownPlugin#Usingtheplugin
+
+for usage instructions.
+**************************************************
diff --git a/www/trac-scrumburndown/pkg-plist b/www/trac-scrumburndown/pkg-plist
new file mode 100644
index 000000000000..dbd923fc6226
--- /dev/null
+++ b/www/trac-scrumburndown/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/TracBurndown-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg