aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2008-01-28 07:10:45 +0800
committernivit <nivit@FreeBSD.org>2008-01-28 07:10:45 +0800
commitf5b199079acb833411bfa49e8beec1fccbc8d336 (patch)
tree721486966ff068429056c14e1c7b7c39f02c55f7
parent3b86685b7b7ba07bd507335db1843e04c72e9a90 (diff)
downloadfreebsd-ports-gnome-f5b199079acb833411bfa49e8beec1fccbc8d336.tar.gz
freebsd-ports-gnome-f5b199079acb833411bfa49e8beec1fccbc8d336.tar.zst
freebsd-ports-gnome-f5b199079acb833411bfa49e8beec1fccbc8d336.zip
Rhino is an open-source implementation of JavaScript written entirely
in Java. It is typically embedded into Java applications to provide scripting to end users. Rhino is an implementation of the core language only and doesn't contain objects or methods for manipulating HTML documents. Rhino contains * All the features of JavaScript 1.6 * Allows direct scripting of Java * A JavaScript shell for executing JavaScript scripts * A JavaScript compiler to transform JavaScript source files into Java class files * A JavaScript debugger for scripts executed with Rhino WWW: http://www.mozilla.org/rhino/
-rw-r--r--lang/Makefile1
-rw-r--r--lang/rhino/Makefile54
-rw-r--r--lang/rhino/distinfo9
-rw-r--r--lang/rhino/files/rhinoc.in6
-rw-r--r--lang/rhino/files/rhinodbg.in6
-rw-r--r--lang/rhino/files/rhinosh.in6
-rw-r--r--lang/rhino/pkg-descr17
-rw-r--r--lang/rhino/pkg-plist6
8 files changed, 105 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 918b8d345deb..fcea18f3e6af 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -260,6 +260,7 @@
SUBDIR += rexx-imc
SUBDIR += rexx-regina
SUBDIR += rexx-wrapper
+ SUBDIR += rhino
SUBDIR += rscheme
SUBDIR += ruby-doc-stdlib
SUBDIR += ruby-extensions
diff --git a/lang/rhino/Makefile b/lang/rhino/Makefile
new file mode 100644
index 000000000000..c461be908faa
--- /dev/null
+++ b/lang/rhino/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: rhino
+# Date created: 2008-01-26
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rhino
+DISTVERSION= 1_6R7
+#PORTREVISION= 0
+#PORTEPOCH= 0
+CATEGORIES= lang java
+MASTER_SITES= ftp://ftp.mozilla.org/pub/mozilla.org/js/:rhino \
+ http://java.sun.com/products/jfc/tsc/articles/treetable2/downloads/:swingex \
+ ${MASTER_SITE_APACHE}:xmlbeans
+MASTER_SITE_SUBDIR= xmlbeans/binaries/:xmlbeans
+DISTFILES= ${PORTNAME}${DISTVERSION}.zip:rhino \
+ src.zip:swingex \
+ xmlbeans-2.2.0.zip:xmlbeans
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= ${PORTNAME}${DISTVERSION}.zip
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= An implementation of JavaScript written in Java
+
+ALL_TARGET= jar
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+
+JAVA_VERSION= 1.4+
+
+MAKE_ARGS= -Dxmlbeans.url=file://${DISTDIR}/${DIST_SUBDIR}/xmlbeans-2.2.0.zip \
+ -Dswing-ex-url=file://${DISTDIR}/${DIST_SUBDIR}/src.zip
+
+RHINOJAR= ${DATADIR}/${PORTNAME}.jar
+
+SUB_FILES= rhinoc rhinodbg rhinosh
+SUB_LIST= RHINOJAR=${RHINOJAR}
+
+USE_ANT= yes
+USE_JAVA= yes
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}${DISTVERSION}
+
+do-install:
+ @${MKDIR} ${DATADIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/build/${PORTNAME}${DISTVERSION}/js.jar ${RHINOJAR}; \
+ RHINOSCRIPTS="${SUB_FILES}"; \
+ for RHINOSCRIPT in $${RHINOSCRIPTS}; do \
+ ${INSTALL_SCRIPT} ${WRKDIR}/$${RHINOSCRIPT} ${PREFIX}/bin/; \
+ done
+
+.include <bsd.port.mk>
diff --git a/lang/rhino/distinfo b/lang/rhino/distinfo
new file mode 100644
index 000000000000..283b55840bf4
--- /dev/null
+++ b/lang/rhino/distinfo
@@ -0,0 +1,9 @@
+MD5 (rhino/rhino1_6R7.zip) = 7be259ae496aae78feaafe7099e09897
+SHA256 (rhino/rhino1_6R7.zip) = c94c6de3a29b3acbc4eee732e688f75a5d94bd02c9878be4ceb4d3cd220f3866
+SIZE (rhino/rhino1_6R7.zip) = 1753170
+MD5 (rhino/src.zip) = ab016c8f81812bb930fc0f7a69e053c5
+SHA256 (rhino/src.zip) = 062837ddb18951ace41ba0050aec95a690c00190a6218e5c9591c381035dfa7d
+SIZE (rhino/src.zip) = 19708
+MD5 (rhino/xmlbeans-2.2.0.zip) = f279d25e2dccbb524e406543c38b4aae
+SHA256 (rhino/xmlbeans-2.2.0.zip) = 93632a33292340898015074156cfc2904794c26f310cc9cbe7a00524534360dd
+SIZE (rhino/xmlbeans-2.2.0.zip) = 3720924
diff --git a/lang/rhino/files/rhinoc.in b/lang/rhino/files/rhinoc.in
new file mode 100644
index 000000000000..ebbde1a376a1
--- /dev/null
+++ b/lang/rhino/files/rhinoc.in
@@ -0,0 +1,6 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Rhino compiler
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -cp "%%RHINOJAR%%" org.mozilla.javascript.tools.jsc.Main $@
diff --git a/lang/rhino/files/rhinodbg.in b/lang/rhino/files/rhinodbg.in
new file mode 100644
index 000000000000..faa68d569f19
--- /dev/null
+++ b/lang/rhino/files/rhinodbg.in
@@ -0,0 +1,6 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Rhino debugger
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -cp "%%RHINOJAR%%" org.mozilla.javascript.tools.debugger.Main $@
diff --git a/lang/rhino/files/rhinosh.in b/lang/rhino/files/rhinosh.in
new file mode 100644
index 000000000000..394ab74473e3
--- /dev/null
+++ b/lang/rhino/files/rhinosh.in
@@ -0,0 +1,6 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Rhino shell
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -cp "%%RHINOJAR%%" org.mozilla.javascript.tools.shell.Main $@
diff --git a/lang/rhino/pkg-descr b/lang/rhino/pkg-descr
new file mode 100644
index 000000000000..6310e14d3a64
--- /dev/null
+++ b/lang/rhino/pkg-descr
@@ -0,0 +1,17 @@
+Rhino is an open-source implementation of JavaScript written entirely
+in Java. It is typically embedded into Java applications to provide
+scripting to end users.
+
+Rhino is an implementation of the core language only and doesn't contain
+objects or methods for manipulating HTML documents.
+
+Rhino contains
+
+ * All the features of JavaScript 1.6
+ * Allows direct scripting of Java
+ * A JavaScript shell for executing JavaScript scripts
+ * A JavaScript compiler to transform JavaScript source files
+ into Java class files
+ * A JavaScript debugger for scripts executed with Rhino
+
+WWW: http://www.mozilla.org/rhino/
diff --git a/lang/rhino/pkg-plist b/lang/rhino/pkg-plist
new file mode 100644
index 000000000000..41b8d5e2849e
--- /dev/null
+++ b/lang/rhino/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+bin/rhinoc
+bin/rhinodbg
+bin/rhinosh
+%%DATADIR%%/rhino.jar
+@dirrm %%DATADIR%%