aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2013-04-19 15:40:04 +0800
committermartymac <martymac@FreeBSD.org>2013-04-19 15:40:04 +0800
commitf78c7a9d6184ce543ccf48760b0fc313c50fe319 (patch)
tree0e4b424f7c060456129dda1d09edd9b5267995b6
parent588a0a6d1fe22b36941e41f81b6d23d78758d8b7 (diff)
downloadfreebsd-ports-gnome-f78c7a9d6184ce543ccf48760b0fc313c50fe319.tar.gz
freebsd-ports-gnome-f78c7a9d6184ce543ccf48760b0fc313c50fe319.tar.zst
freebsd-ports-gnome-f78c7a9d6184ce543ccf48760b0fc313c50fe319.zip
- Update to svn rev. 84102
- Use new Makefile header format Feature safe: yes
-rw-r--r--emulators/pcsxr/Makefile10
-rw-r--r--emulators/pcsxr/distinfo4
-rw-r--r--emulators/pcsxr/files/patch-gui-Makefile.am6
-rw-r--r--emulators/pcsxr/files/patch-plugins-bladesio1-Makefile.am4
-rw-r--r--emulators/pcsxr/files/patch-plugins-dfcdrom-Makefile.am4
-rw-r--r--emulators/pcsxr/files/patch-plugins-dfinput-Makefile.am4
-rw-r--r--emulators/pcsxr/files/patch-plugins-dfinput-pad.c15
-rw-r--r--emulators/pcsxr/files/patch-plugins-dfnet-Makefile.am4
-rw-r--r--emulators/pcsxr/files/patch-plugins-dfsound-Makefile.am4
-rw-r--r--emulators/pcsxr/files/patch-plugins-dfxvideo-Makefile.am4
-rw-r--r--emulators/pcsxr/files/patch-plugins-peopsxgl-Makefile.am4
-rw-r--r--emulators/pcsxr/pkg-plist6
12 files changed, 26 insertions, 43 deletions
diff --git a/emulators/pcsxr/Makefile b/emulators/pcsxr/Makefile
index 0665d8562bf0..e09802e7960b 100644
--- a/emulators/pcsxr/Makefile
+++ b/emulators/pcsxr/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: pcsxr
-# Date created: 11 June 2010
-# Whom: Ganael Laplanche <ganael.laplanche@martymac.org>
-#
+# Created by: Ganael Laplanche <ganael.laplanche@martymac.org>
# $FreeBSD$
-#
PORTNAME= pcsxr
-PORTVERSION= 1.9.92.r81088
+PORTVERSION= 1.9.92.r84102
CATEGORIES= emulators
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
LOCAL/martymac
@@ -35,7 +31,7 @@ USE_LDCONFIG= yes
USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*\.(c|h|cpp|hpp|am)
-USE_GNOME= gtk20 desktopfileutils glib20
+USE_GNOME= gtk30 desktopfileutils glib20
USE_ICONV= yes
USE_XORG= x11 xv xext xxf86vm xtst
USE_SDL= sdl
diff --git a/emulators/pcsxr/distinfo b/emulators/pcsxr/distinfo
index ef4f1d0c7512..fe57ede6a2f5 100644
--- a/emulators/pcsxr/distinfo
+++ b/emulators/pcsxr/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pcsxr-1.9.92.r81088.tar.bz2) = d514fd045f0dd4fe9c7f8d67afbe031412f38f039b3a53c0007c267366e9595d
-SIZE (pcsxr-1.9.92.r81088.tar.bz2) = 1435621
+SHA256 (pcsxr-1.9.92.r84102.tar.bz2) = 88c86c5221f16b2d9d3c88191b7e5e08f4f62c71e17c084188497abb0e6c3295
+SIZE (pcsxr-1.9.92.r84102.tar.bz2) = 1451311
diff --git a/emulators/pcsxr/files/patch-gui-Makefile.am b/emulators/pcsxr/files/patch-gui-Makefile.am
index f91db9f81a1d..ca090a9ec210 100644
--- a/emulators/pcsxr/files/patch-gui-Makefile.am
+++ b/emulators/pcsxr/files/patch-gui-Makefile.am
@@ -2,7 +2,7 @@
+++ gui/Makefile.am 2011-06-30 11:43:02.263535649 +0200
@@ -3,8 +3,8 @@
-DLOCALE_DIR=\"${datadir}/locale/\" \
- $(GTK2_CFLAGS) $(GLADE2_CFLAGS) \
+ $(GTK3_CFLAGS) $(GLADE2_CFLAGS) \
-I$(top_srcdir)/libpcsxcore -I$(top_srcdir)/include \
- -DPSEMU_DATA_DIR=\"${datadir}/psemu\" \
- -DDEF_PLUGIN_DIR=\"${libdir}/games/psemu\"
@@ -15,6 +15,6 @@
pcsxr_LDADD = \
../libpcsxcore/libpcsxcore.a \
-- $(GTK2_LIBS) $(GLADE2_LIBS) -lpthread -lz -lm -lXext -lXtst
-+ $(GTK2_LIBS) $(GLADE2_LIBS) -lz -lm -lXext -lXtst -lGL
+- $(GTK3_LIBS) $(GLADE2_LIBS) -lpthread -lz -lm -lXext -lXtst
++ $(GTK3_LIBS) $(GLADE2_LIBS) -lz -lm -lXext -lXtst -lGL
+pcsxr_LDFLAGS = -pthread
diff --git a/emulators/pcsxr/files/patch-plugins-bladesio1-Makefile.am b/emulators/pcsxr/files/patch-plugins-bladesio1-Makefile.am
index 5419051e7050..64c95cb3807d 100644
--- a/emulators/pcsxr/files/patch-plugins-bladesio1-Makefile.am
+++ b/emulators/pcsxr/files/patch-plugins-bladesio1-Makefile.am
@@ -14,11 +14,11 @@
AM_CPPFLAGS = -DLOCALE_DIR=\"${datadir}/locale/\" \
- -DDATADIR=\"${datadir}/psemu/\" \
+ -DDATADIR=\"${datadir}/pcsxr/\" \
- $(GTK2_CFLAGS) \
+ $(GTK3_CFLAGS) \
-I../../libpcsxcore -I../../include
@@ -16,5 +16,5 @@
- cfgBladeSio1_LDADD = $(GTK2_LIBS)
+ cfgBladeSio1_LDADD = $(GTK3_LIBS)
glade_DATA = sio1.ui
-gladedir = $(datadir)/psemu/
diff --git a/emulators/pcsxr/files/patch-plugins-dfcdrom-Makefile.am b/emulators/pcsxr/files/patch-plugins-dfcdrom-Makefile.am
index 7257a326dff1..e37d9cdcc092 100644
--- a/emulators/pcsxr/files/patch-plugins-dfcdrom-Makefile.am
+++ b/emulators/pcsxr/files/patch-plugins-dfcdrom-Makefile.am
@@ -25,11 +25,11 @@
AM_CPPFLAGS = -DLOCALE_DIR=\"${datadir}/locale/\" \
- -DDATADIR=\"${datadir}/psemu/\" \
+ -DDATADIR=\"${datadir}/pcsxr/\" \
- $(GTK2_CFLAGS) \
+ $(GTK3_CFLAGS) \
-I../../libpcsxcore -I../../include
@@ -31,5 +31,5 @@
- cfgDFCdrom_LDADD = $(GTK2_LIBS)
+ cfgDFCdrom_LDADD = $(GTK3_LIBS)
glade_DATA = cdrcfg-0.1df/dfcdrom.ui
-gladedir = $(datadir)/psemu/
diff --git a/emulators/pcsxr/files/patch-plugins-dfinput-Makefile.am b/emulators/pcsxr/files/patch-plugins-dfinput-Makefile.am
index 109ef7ae55e5..65cf0df11f1f 100644
--- a/emulators/pcsxr/files/patch-plugins-dfinput-Makefile.am
+++ b/emulators/pcsxr/files/patch-plugins-dfinput-Makefile.am
@@ -17,11 +17,11 @@
AM_CPPFLAGS = -DLOCALE_DIR=\"${datadir}/locale/\" \
- -DDATADIR=\"${datadir}/psemu/\" \
+ -DDATADIR=\"${datadir}/pcsxr/\" \
- $(GTK2_CFLAGS) \
+ $(GTK3_CFLAGS) \
-I../../include -I../../libpcsxcore $(SDL_CFLAGS)
@@ -17,5 +17,5 @@
- cfgDFInput_LDADD = $(GTK2_LIBS) $(SDL_LIBS) -lX11
+ cfgDFInput_LDADD = $(GTK3_LIBS) $(SDL_LIBS) -lX11
glade_DATA = dfinput.ui
-gladedir = $(datadir)/psemu/
diff --git a/emulators/pcsxr/files/patch-plugins-dfinput-pad.c b/emulators/pcsxr/files/patch-plugins-dfinput-pad.c
index 138462295414..982a83007cc7 100644
--- a/emulators/pcsxr/files/patch-plugins-dfinput-pad.c
+++ b/emulators/pcsxr/files/patch-plugins-dfinput-pad.c
@@ -1,15 +1,6 @@
---- plugins/dfinput/pad.c.orig 2012-11-08 06:07:00.000000000 +0100
-+++ plugins/dfinput/pad.c 2012-11-08 06:09:26.000000000 +0100
-@@ -676,8 +676,6 @@
- } else if (pid > 0) {
- waitpid(pid, NULL, 0);
- }
--
-- return PSE_PAD_ERR_SUCCESS;
- }
-
- #endif
-@@ -685,3 +683,6 @@
+--- plugins/dfinput/pad.c.orig 2013-04-17 16:44:04.000000000 +0200
++++ plugins/dfinput/pad.c 2013-04-17 16:46:50.000000000 +0200
+@@ -683,3 +683,6 @@
long PADtest(void) {
return PSE_PAD_ERR_SUCCESS;
}
diff --git a/emulators/pcsxr/files/patch-plugins-dfnet-Makefile.am b/emulators/pcsxr/files/patch-plugins-dfnet-Makefile.am
index 958297e56b19..807490e5fbfa 100644
--- a/emulators/pcsxr/files/patch-plugins-dfnet-Makefile.am
+++ b/emulators/pcsxr/files/patch-plugins-dfnet-Makefile.am
@@ -14,11 +14,11 @@
AM_CPPFLAGS = -DLOCALE_DIR=\"${datadir}/locale/\" \
- -DDATADIR=\"${datadir}/psemu/\" \
+ -DDATADIR=\"${datadir}/pcsxr/\" \
- $(GTK2_CFLAGS) \
+ $(GTK3_CFLAGS) \
-I../../libpcsxcore -I../../include
@@ -16,5 +16,5 @@
- cfgDFNet_LDADD = $(GTK2_LIBS)
+ cfgDFNet_LDADD = $(GTK3_LIBS)
glade_DATA = dfnet.ui
-gladedir = $(datadir)/psemu/
diff --git a/emulators/pcsxr/files/patch-plugins-dfsound-Makefile.am b/emulators/pcsxr/files/patch-plugins-dfsound-Makefile.am
index 38551197b1b6..fb9d3c71fef8 100644
--- a/emulators/pcsxr/files/patch-plugins-dfsound-Makefile.am
+++ b/emulators/pcsxr/files/patch-plugins-dfsound-Makefile.am
@@ -26,9 +26,9 @@
cfgDFSound_CPPFLAGS = -DLOCALE_DIR=\"${datadir}/locale/\" \
- -DDATADIR=\"${datadir}/psemu/\" \
+ -DDATADIR=\"${datadir}/pcsxr/\" \
- $(GTK2_CFLAGS) $(AM_CPPFLAGS)
+ $(GTK3_CFLAGS) $(AM_CPPFLAGS)
cfgDFSound_SOURCES = spucfg-0.1df/main.c
- cfgDFSound_LDADD = $(GTK2_LIBS)
+ cfgDFSound_LDADD = $(GTK3_LIBS)
glade_DATA = spucfg-0.1df/dfsound.ui
-gladedir = $(datadir)/psemu/
diff --git a/emulators/pcsxr/files/patch-plugins-dfxvideo-Makefile.am b/emulators/pcsxr/files/patch-plugins-dfxvideo-Makefile.am
index ca79539170b9..3061c89d6a61 100644
--- a/emulators/pcsxr/files/patch-plugins-dfxvideo-Makefile.am
+++ b/emulators/pcsxr/files/patch-plugins-dfxvideo-Makefile.am
@@ -6,7 +6,7 @@
AM_CPPFLAGS = -DLOCALE_DIR=\"${datadir}/locale/\" \
- -DDATADIR=\"${datadir}/psemu/\" \
+ -DDATADIR=\"${datadir}/pcsxr/\" \
- $(GTK2_CFLAGS)\
+ $(GTK3_CFLAGS)\
-I../../libpcsxcore \
-I../../include
@@ -18,7 +18,7 @@
lib_LTLIBRARIES = libDFXVideo.la
@@ -30,5 +30,5 @@
- cfgDFXVideo_LDADD = $(GTK2_LIBS) -lXext
+ cfgDFXVideo_LDADD = $(GTK3_LIBS) -lXext
glade_DATA = gpucfg-0.1df/dfxvideo.ui
-gladedir = $(datadir)/psemu/
diff --git a/emulators/pcsxr/files/patch-plugins-peopsxgl-Makefile.am b/emulators/pcsxr/files/patch-plugins-peopsxgl-Makefile.am
index df78277005c1..be8616f12b94 100644
--- a/emulators/pcsxr/files/patch-plugins-peopsxgl-Makefile.am
+++ b/emulators/pcsxr/files/patch-plugins-peopsxgl-Makefile.am
@@ -5,7 +5,7 @@
-DLOCALE_DIR=\"${datadir}/locale/\" \
- -DDATADIR=\"${datadir}/psemu/\" \
+ -DDATADIR=\"${datadir}/pcsxr/\" \
- $(GTK2_CFLAGS) \
+ $(GTK3_CFLAGS) \
-I../../libpcsxcore -I../../include
-bindir = @libdir@/games/psemu/
@@ -16,7 +16,7 @@
lib_LTLIBRARIES = libpeopsxgl.la
@@ -19,5 +19,5 @@
- cfgpeopsxgl_LDADD = $(GTK2_LIBS)
+ cfgpeopsxgl_LDADD = $(GTK3_LIBS)
glade_DATA = gpucfg/peopsxgl.ui
-gladedir = $(datadir)/psemu/
diff --git a/emulators/pcsxr/pkg-plist b/emulators/pcsxr/pkg-plist
index 695f5b4b255d..b9df25fdde01 100644
--- a/emulators/pcsxr/pkg-plist
+++ b/emulators/pcsxr/pkg-plist
@@ -15,10 +15,10 @@ share/pcsxr/dfinput.ui
share/pcsxr/dfnet.ui
share/pcsxr/dfxvideo.ui
share/pcsxr/dfcdrom.ui
-share/pcsxr/sio1.ui
share/pcsxr/gpu.png
share/pcsxr/dfsound.ui
share/pcsxr/spu.png
+share/pcsxr/sio1.png
share/pcsxr/cd.png
share/pcsxr/iso-reopen.png
share/pcsxr/cdr.png
@@ -38,7 +38,6 @@ lib/pcsxr/cfgDFInput
lib/pcsxr/cfgDFCdrom
lib/pcsxr/cfgDFSound
lib/pcsxr/cfgDFNet
-lib/pcsxr/cfgBladeSio1
lib/pcsxr/libDFXVideo.a
lib/pcsxr/libDFXVideo.la
lib/pcsxr/libDFXVideo.so
@@ -57,9 +56,6 @@ lib/pcsxr/libDFCdrom.so
lib/pcsxr/libDFNet.a
lib/pcsxr/libDFNet.la
lib/pcsxr/libDFNet.so
-lib/pcsxr/libBladeSio1.a
-lib/pcsxr/libBladeSio1.la
-lib/pcsxr/libBladeSio1.so
@dirrm lib/pcsxr
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true