aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-08-21 17:09:04 +0800
committerdanfe <danfe@FreeBSD.org>2015-08-21 17:09:04 +0800
commitf8fc9b1bdc8ef97e04c6d42481f598a83a849426 (patch)
treec2ba4110226b1272f196edae63fc3da965e731e9
parent1e0aa436373996d0ae1100669f0d8ea95a7431d3 (diff)
downloadfreebsd-ports-gnome-f8fc9b1bdc8ef97e04c6d42481f598a83a849426.tar.gz
freebsd-ports-gnome-f8fc9b1bdc8ef97e04c6d42481f598a83a849426.tar.zst
freebsd-ports-gnome-f8fc9b1bdc8ef97e04c6d42481f598a83a849426.zip
Try to fix installation on amd64 by removing stupid `64' suffix that was
appended to the library path in this case. Reported by: pkg-fallout
-rw-r--r--graphics/luxrender/files/patch-CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/graphics/luxrender/files/patch-CMakeLists.txt b/graphics/luxrender/files/patch-CMakeLists.txt
index 1fba01bbd1cf..5cd7bca61653 100644
--- a/graphics/luxrender/files/patch-CMakeLists.txt
+++ b/graphics/luxrender/files/patch-CMakeLists.txt
@@ -1,6 +1,14 @@
--- CMakeLists.txt.orig
+++ CMakeLists.txt
-@@ -298,7 +298,7 @@ ELSEIF(MSVC)
+@@ -210,7 +210,6 @@ IF(NOT APPLE AND NOT WIN32)
+ STRING(REGEX MATCH "(x86_64-*)|(X86_64-*)|(AMD64-*)|(amd64-*)" _mach_x86_64 ${MACHINE})
+ IF (_mach_x86_64)
+ SET(ARCH_X86_64 1)
+- SET(LIB_SUFFIX 64)
+ #jromang - Hack to avoid boost bug on x64 Ubuntu 8.10 and Fedora 10 (http://www.luxrender.net/mantis/view.php?id=433)
+ ADD_DEFINITIONS(-DBOOST_NO_INTRINSIC_INT64_T)
+ ENDIF (_mach_x86_64)
+@@ -402,7 +401,7 @@ ELSEIF(MSVC)
ELSE(APPLE)
# Dade - default compiler options
# Removed "-O3" from definitions in order to have CMake Release/Debug options to work