aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2010-06-04 08:21:31 +0800
committerglarkin <glarkin@FreeBSD.org>2010-06-04 08:21:31 +0800
commitf9654f4422f721ef16b5933ce752910cb94e46ec (patch)
treeb049d4c0a1e1d63e8097a8a147747dd9b0c2b14e
parent069644ce6e7f4ccc178db6129b08e015e8e38fa5 (diff)
downloadfreebsd-ports-gnome-f9654f4422f721ef16b5933ce752910cb94e46ec.tar.gz
freebsd-ports-gnome-f9654f4422f721ef16b5933ce752910cb94e46ec.tar.zst
freebsd-ports-gnome-f9654f4422f721ef16b5933ce752910cb94e46ec.zip
- Add OPTION to explicitly build the documentation set and the doxygen
dependency. This option will be off by default so the databases/drizzle build can avoid building doxygen and its deps when it builds the libdrizzle dep. databases/drizzle also has the same option, defaulted to "off".
-rw-r--r--databases/libdrizzle/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/databases/libdrizzle/Makefile b/databases/libdrizzle/Makefile
index fdbcbff859ad..70fbf6c81006 100644
--- a/databases/libdrizzle/Makefile
+++ b/databases/libdrizzle/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libdrizzle
PORTVERSION= 0.8
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://launchpadlibrarian.net/41155299/ \
LOCAL/glarkin
@@ -16,6 +17,8 @@ COMMENT= Client and protocol library for the Drizzle database
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
+OPTIONS= DOCS "Build documentation with doxygen" Off
+
USE_GCC= 4.2+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-libsqlite3
@@ -28,12 +31,17 @@ SAMPLE_PROGS= client pipe_query proxy server simple \
.include <bsd.port.pre.mk>
.if !defined(NOPORTDOCS)
+.if defined(WITH_DOCS)
BUILD_DEPENDS+= doxygen>=0:${PORTSDIR}/devel/doxygen
ALL_TARGET= all doxygen
+PLIST_SUB+= PORTDOCS=""
post-install::
@${INSTALL} -d ${DOCSDIR}
@cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
+.else
+PLIST_SUB+= PORTDOCS="@comment "
+.endif
.endif
.if !defined(NOPORTEXAMPLES)