aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2012-09-19 21:35:41 +0800
committerbsam <bsam@FreeBSD.org>2012-09-19 21:35:41 +0800
commitf9a4b9a141035c7e890de17e90d8824e1489da02 (patch)
tree86e78c249a2fb7049a7186e641c2ead0e72dc902
parent72ca63b49aa11a8f5af72911bbc1ddc479f4b5a4 (diff)
downloadfreebsd-ports-gnome-f9a4b9a141035c7e890de17e90d8824e1489da02.tar.gz
freebsd-ports-gnome-f9a4b9a141035c7e890de17e90d8824e1489da02.tar.zst
freebsd-ports-gnome-f9a4b9a141035c7e890de17e90d8824e1489da02.zip
Add trytond_stock_product_location 2.4.0, tryton Application Platform
(Stock Product Location Module). PR: ports/171439 Submitted by: matthias@petermann.it
-rw-r--r--finance/Makefile1
-rw-r--r--finance/trytond_stock_product_location/Makefile21
-rw-r--r--finance/trytond_stock_product_location/distinfo2
-rw-r--r--finance/trytond_stock_product_location/pkg-descr4
-rw-r--r--finance/trytond_stock_product_location/pkg-plist44
5 files changed, 72 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 8f01bee3ae99..81af2b3f3267 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -141,6 +141,7 @@
SUBDIR += trytond_stock_inventory_location
SUBDIR += trytond_stock_location_sequence
SUBDIR += trytond_stock_lot
+ SUBDIR += trytond_stock_product_location
SUBDIR += trytond_stock_supply
SUBDIR += trytond_timesheet
SUBDIR += venice
diff --git a/finance/trytond_stock_product_location/Makefile b/finance/trytond_stock_product_location/Makefile
new file mode 100644
index 000000000000..5e0e5249c681
--- /dev/null
+++ b/finance/trytond_stock_product_location/Makefile
@@ -0,0 +1,21 @@
+# Created by: Matthias Petermann<matthias@petermann.it>
+# $FreeBSD$
+
+PORTNAME= trytond_stock_product_location
+PORTVERSION= 2.4.0
+CATEGORIES= finance python
+MASTER_SITES= http://downloads2.tryton.org/${PORTVERSION:R}/
+
+MAINTAINER= matthias@petermann.it
+COMMENT= Tryton Application Platform (Stock Product Location Module)
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= trytond>=2.4.0:${PORTSDIR}/finance/trytond \
+ trytond_product>=2.4.0:${PORTSDIR}/finance/trytond_product \
+ trytond_stock>=2.4.0:${PORTSDIR}/finance/trytond_stock
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+
+.include <bsd.port.mk>
diff --git a/finance/trytond_stock_product_location/distinfo b/finance/trytond_stock_product_location/distinfo
new file mode 100644
index 000000000000..4fa875718603
--- /dev/null
+++ b/finance/trytond_stock_product_location/distinfo
@@ -0,0 +1,2 @@
+SHA256 (trytond_stock_product_location-2.4.0.tar.gz) = de97b40fc06ef03450fe4d2729983e02563fa9d9f0aee911394d646f29b23858
+SIZE (trytond_stock_product_location-2.4.0.tar.gz) = 20506
diff --git a/finance/trytond_stock_product_location/pkg-descr b/finance/trytond_stock_product_location/pkg-descr
new file mode 100644
index 000000000000..cf1460088bb8
--- /dev/null
+++ b/finance/trytond_stock_product_location/pkg-descr
@@ -0,0 +1,4 @@
+This port adds the Stock Product Location Module to the Tryton Application
+Platform.
+
+WWW: http://www.tryton.org/
diff --git a/finance/trytond_stock_product_location/pkg-plist b/finance/trytond_stock_product_location/pkg-plist
new file mode 100644
index 000000000000..c39d45b491be
--- /dev/null
+++ b/finance/trytond_stock_product_location/pkg-plist
@@ -0,0 +1,44 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/entry_points.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/__tryton__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/__tryton__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/__tryton__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/locale/bg_BG.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/locale/ca_ES.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/locale/cs_CZ.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/locale/de_DE.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/locale/es_AR.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/locale/es_CO.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/locale/es_ES.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/locale/fr_FR.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/locale/nl_NL.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/locale/ru_RU.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/location.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/location.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/location.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/location.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/product.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/product.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/product.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/product.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/tests/test_stock_product_location.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/tests/test_stock_product_location.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/tests/test_stock_product_location.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/tests
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location/locale
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/stock_product_location
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%