aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-04-01 18:25:19 +0800
committerijliao <ijliao@FreeBSD.org>2003-04-01 18:25:19 +0800
commitfb24e943bb71c2b7c040f2f47ce9d7afb5a823ac (patch)
treec0766e1b8d6382ba3ed3bc70769336a8481ea1c0
parent238784159e2511311e29ac406e22ec988dc02478 (diff)
downloadfreebsd-ports-gnome-fb24e943bb71c2b7c040f2f47ce9d7afb5a823ac.tar.gz
freebsd-ports-gnome-fb24e943bb71c2b7c040f2f47ce9d7afb5a823ac.tar.zst
freebsd-ports-gnome-fb24e943bb71c2b7c040f2f47ce9d7afb5a823ac.zip
add xmlindent 0.2.4
A XML stream reformatter
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/xmlindent/Makefile23
-rw-r--r--textproc/xmlindent/distinfo1
-rw-r--r--textproc/xmlindent/pkg-descr3
-rw-r--r--textproc/xmlindent/pkg-plist1
5 files changed, 29 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e3733ead948f..4158e691e9f5 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -430,6 +430,7 @@
SUBDIR += xmlada
SUBDIR += xmlcharent
SUBDIR += xmlenc
+ SUBDIR += xmlindent
SUBDIR += xmlpp
SUBDIR += xmlppm
SUBDIR += xmlwrapp
diff --git a/textproc/xmlindent/Makefile b/textproc/xmlindent/Makefile
new file mode 100644
index 000000000000..22e92ce7f364
--- /dev/null
+++ b/textproc/xmlindent/Makefile
@@ -0,0 +1,23 @@
+# ex:ts=8
+# Ports collection makefile for: xmlindent
+# Date created: Apr 1, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlindent
+PORTVERSION= 0.2.4
+CATEGORIES= textproc
+MASTER_SITES= http://www.cs.helsinki.fi/u/penberg/xmlindent/src/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A XML stream reformatter
+
+MAN1= xmlindent.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xmlindent ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xmlindent.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/textproc/xmlindent/distinfo b/textproc/xmlindent/distinfo
new file mode 100644
index 000000000000..2e8e0588be5e
--- /dev/null
+++ b/textproc/xmlindent/distinfo
@@ -0,0 +1 @@
+MD5 (xmlindent-0.2.4.tar.gz) = 68477420d35d681a9217972e7bfecedf
diff --git a/textproc/xmlindent/pkg-descr b/textproc/xmlindent/pkg-descr
new file mode 100644
index 000000000000..6f6b4446e50f
--- /dev/null
+++ b/textproc/xmlindent/pkg-descr
@@ -0,0 +1,3 @@
+XML Indent is a XML stream reformatter written in ANSI C.
+
+WWW: http://www.cs.helsinki.fi/u/penberg/xmlindent/
diff --git a/textproc/xmlindent/pkg-plist b/textproc/xmlindent/pkg-plist
new file mode 100644
index 000000000000..11198e5bdb51
--- /dev/null
+++ b/textproc/xmlindent/pkg-plist
@@ -0,0 +1 @@
+bin/xmlindent