aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2011-10-06 21:43:24 +0800
committerfjoe <fjoe@FreeBSD.org>2011-10-06 21:43:24 +0800
commitfb329c7c4fd784b8f1f51a04f737b5a0e740bcf0 (patch)
treed10c6ff478ec82090d11038947b541eeb352cd9c
parent5720e46f715af9573f397dcc08b5d6cb6daef52b (diff)
downloadfreebsd-ports-gnome-fb329c7c4fd784b8f1f51a04f737b5a0e740bcf0.tar.gz
freebsd-ports-gnome-fb329c7c4fd784b8f1f51a04f737b5a0e740bcf0.tar.zst
freebsd-ports-gnome-fb329c7c4fd784b8f1f51a04f737b5a0e740bcf0.zip
Update to 4.7.5.5
PR: 161083 (partially) Submitted by: Maxim Samsonov
-rw-r--r--misc/mc/Makefile7
-rw-r--r--misc/mc/distinfo4
-rw-r--r--misc/mc/files/patch-src-editor-edit.c38
-rw-r--r--misc/mc/files/patch-without-nls25
-rw-r--r--misc/mc/pkg-plist14
5 files changed, 17 insertions, 71 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index 24245cf37ef7..35184f7a3050 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= mc
-PORTVERSION= 4.7.5
-PORTREVISION= 1
+PORTVERSION= 4.7.5.5
+PORTREVISION= 0
CATEGORIES= misc shells
MASTER_SITES= http://www.midnight-commander.org/downloads/ \
${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= utils/file/managers/mc
-EXTRACT_SUFX= .tar.lzma
PATCH_SITES= ${MASTER_SITES}
@@ -29,7 +28,7 @@ USE_PERL5= yes
USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ZIP=${LOCALBASE}/bin/zip UNZIP=${LOCALBASE}/bin/unzip
-USE_AUTOTOOLS= autoconf automake
+USE_AUTOTOOLS= libtool
OPTIONS= SLANG "Build with SLang library" on \
ICONV "Build with iconv recoding" on \
diff --git a/misc/mc/distinfo b/misc/mc/distinfo
index c04b5ce3915b..e6f30ff758b9 100644
--- a/misc/mc/distinfo
+++ b/misc/mc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mc-4.7.5.tar.lzma) = 5e5893e9484e4854a29fa422834e79c9ef007c1672136331ef28bdddbfc1c457
-SIZE (mc-4.7.5.tar.lzma) = 1922463
+SHA256 (mc-4.7.5.5.tar.xz) = 1ec5e711e7de01d9317a444061ab0d3c91bb84d8898dbbc99c7c472d6afbe2ea
+SIZE (mc-4.7.5.5.tar.xz) = 1991540
diff --git a/misc/mc/files/patch-src-editor-edit.c b/misc/mc/files/patch-src-editor-edit.c
deleted file mode 100644
index c2e4eb7b748f..000000000000
--- a/misc/mc/files/patch-src-editor-edit.c
+++ /dev/null
@@ -1,38 +0,0 @@
-Index: src/editor/edit.c
-===================================================================
---- src/editor/edit.c (revision bd3025e7a9ec490bc6adabc34cd0392e93ecd050)
-+++ src/editor/edit.c (revision 4f4876abb4acb812747d1050c4b3be01da87780a)
-@@ -2840,8 +2840,5 @@
- {
- int c, orig_c;
-- int utf_ch = 0;
--#ifdef HAVE_CHARSET
-- int cw = 1;
--#endif
-+
- if (cols != -10)
- {
-@@ -2851,8 +2848,13 @@
- return p - 1;
- }
-+
- orig_c = c = edit_get_byte (edit, p);
-+
- #ifdef HAVE_CHARSET
- if (edit->utf8)
- {
-+ int utf_ch;
-+ int cw = 1;
-+
- utf_ch = edit_get_utf (edit, p, &cw);
- if (utf8_display)
-@@ -2866,6 +2868,8 @@
- col -= cw - 1;
- }
-+
-+ c = convert_to_display_c (c);
- #endif
-- c = convert_to_display_c (c);
-+
- if (c == '\t')
- col += TAB_SIZE - col % TAB_SIZE;
diff --git a/misc/mc/files/patch-without-nls b/misc/mc/files/patch-without-nls
deleted file mode 100644
index 4e37f9b1ea2e..000000000000
--- a/misc/mc/files/patch-without-nls
+++ /dev/null
@@ -1,25 +0,0 @@
---- doc/hints/Makefile.am.orig 2011-03-22 00:02:49.000000000 +0600
-+++ doc/hints/Makefile.am 2011-03-22 00:03:11.000000000 +0600
-@@ -1,7 +1,11 @@
- HINTFILES = \
-- mc.hint mc.hint.cs mc.hint.es mc.hint.hu mc.hint.it \
-+ mc.hint
-+if USE_NLS
-+HINTFILES += \
-+ mc.hint.cs mc.hint.es mc.hint.hu mc.hint.it \
- mc.hint.nl mc.hint.pl mc.hint.ru mc.hint.sr mc.hint.uk \
- mc.hint.zh
-+endif
-
- hintdir = $(pkgdatadir)/hints
- hint_DATA = $(HINTFILES)
---- configure.ac.orig 2011-03-21 23:58:52.000000000 +0600
-+++ configure.ac 2011-03-22 00:01:04.000000000 +0600
-@@ -504,6 +504,7 @@
- AM_CONDITIONAL(USE_SCREEN_SLANG, [test x"$with_screen" = xslang])
- AM_CONDITIONAL(USE_EDIT, [test -n "$use_edit"])
- AM_CONDITIONAL(USE_DIFF, [test -n "$use_diff"])
-+AM_CONDITIONAL(USE_NLS, [test x"$USE_NLS" = xyes])
- AM_CONDITIONAL(CHARSET, [test -n "$have_charset"])
- AM_CONDITIONAL(CONS_SAVER, [test -n "$cons_saver"])
-
diff --git a/misc/mc/pkg-plist b/misc/mc/pkg-plist
index 4650f8d1194b..88475610467b 100644
--- a/misc/mc/pkg-plist
+++ b/misc/mc/pkg-plist
@@ -72,6 +72,7 @@ libexec/mc/mc.sh
%%NLS%%share/locale/da/LC_MESSAGES/mc.mo
%%NLS%%share/locale/de/LC_MESSAGES/mc.mo
%%NLS%%share/locale/el/LC_MESSAGES/mc.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/mc.mo
%%NLS%%share/locale/es/LC_MESSAGES/mc.mo
%%NLS%%share/locale/eu/LC_MESSAGES/mc.mo
%%NLS%%share/locale/fi/LC_MESSAGES/mc.mo
@@ -79,8 +80,10 @@ libexec/mc/mc.sh
%%NLS%%share/locale/fr/LC_MESSAGES/mc.mo
%%NLS%%share/locale/gl/LC_MESSAGES/mc.mo
%%NLS%%share/locale/hu/LC_MESSAGES/mc.mo
+%%NLS%%share/locale/ia/LC_MESSAGES/mc.mo
%%NLS%%share/locale/id/LC_MESSAGES/mc.mo
%%NLS%%share/locale/it/LC_MESSAGES/mc.mo
+%%NLS%%share/locale/it_IT/LC_MESSAGES/mc.mo
%%NLS%%share/locale/ja/LC_MESSAGES/mc.mo
%%NLS%%share/locale/ka/LC_MESSAGES/mc.mo
%%NLS%%share/locale/ko/LC_MESSAGES/mc.mo
@@ -98,6 +101,7 @@ libexec/mc/mc.sh
%%NLS%%share/locale/sl/LC_MESSAGES/mc.mo
%%NLS%%share/locale/sr/LC_MESSAGES/mc.mo
%%NLS%%share/locale/sv/LC_MESSAGES/mc.mo
+%%NLS%%share/locale/sv_SE/LC_MESSAGES/mc.mo
%%NLS%%share/locale/ta/LC_MESSAGES/mc.mo
%%NLS%%share/locale/tr/LC_MESSAGES/mc.mo
%%NLS%%share/locale/uk/LC_MESSAGES/mc.mo
@@ -125,11 +129,13 @@ libexec/mc/mc.sh
%%NLS%%%%DATADIR%%/hints/mc.hint.zh
%%CHARSETS%%%%DATADIR%%/mc.charsets
%%DATADIR%%/mc.lib
+%%DATADIR%%/skins/dark.ini
%%DATADIR%%/skins/darkfar.ini
%%DATADIR%%/skins/default.ini
%%DATADIR%%/skins/double-lines.ini
%%DATADIR%%/skins/featured.ini
%%DATADIR%%/skins/gotar.ini
+%%DATADIR%%/skins/mc46.ini
%%DATADIR%%/skins/nicedark.ini
%%EDITOR%%%%DATADIR%%/syntax/PKGBUILD.syntax
%%EDITOR%%%%DATADIR%%/syntax/Syntax
@@ -207,8 +213,12 @@ libexec/mc/mc.sh
@dirrm %%DATADIR%%/hints
@dirrm %%DATADIR%%/help
@dirrm %%DATADIR%%
-%%NLS%%@dirrm share/locale/fi_FI/LC_MESSAGES
-%%NLS%%@dirrm share/locale/fi_FI
+%%NLS%%@dirrmtry share/locale/sv_SE/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/sv_SE
+%%NLS%%@dirrmtry share/locale/it_IT/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/it_IT
+%%NLS%%@dirrmtry share/locale/fi_FI/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fi_FI
@dirrm libexec/mc/fish
@dirrm libexec/mc/extfs.d
@dirrm libexec/mc