aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-13 22:50:53 +0800
committerbapt <bapt@FreeBSD.org>2013-09-13 22:50:53 +0800
commitfd09183ee91bb5a90a45647b87274679215d5b4a (patch)
tree5650a8062e0a2eb8555c5db30140e9744c146de1
parent5cfeb0dd2e411588d0edb72216a220cd990e30b2 (diff)
downloadfreebsd-ports-gnome-fd09183ee91bb5a90a45647b87274679215d5b4a.tar.gz
freebsd-ports-gnome-fd09183ee91bb5a90a45647b87274679215d5b4a.tar.zst
freebsd-ports-gnome-fd09183ee91bb5a90a45647b87274679215d5b4a.zip
Add an explicit dependency on pkgconf
-rw-r--r--devel/seed3/Makefile3
-rw-r--r--graphics/gimp-focusblur-plugin/Makefile2
-rw-r--r--graphics/zbar/Makefile3
-rw-r--r--net-im/pidgin-rhythmbox/Makefile8
4 files changed, 5 insertions, 11 deletions
diff --git a/devel/seed3/Makefile b/devel/seed3/Makefile
index aba7dfb1c217..02e7cefcc4ac 100644
--- a/devel/seed3/Makefile
+++ b/devel/seed3/Makefile
@@ -25,12 +25,11 @@ CONFLICTS= seed-2.[0-9]*
LATEST_LINK= seed3
USE_XZ= yes
GNU_CONFIGURE= yes
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= gtk30 intltool libxml2
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
USE_SQLITE= yes
-USE_GMAKE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=--enable-gtk-doc=no --with-webkit=3.0
diff --git a/graphics/gimp-focusblur-plugin/Makefile b/graphics/gimp-focusblur-plugin/Makefile
index d3b5b5e9bb29..e9f6c88ce8f8 100644
--- a/graphics/gimp-focusblur-plugin/Makefile
+++ b/graphics/gimp-focusblur-plugin/Makefile
@@ -18,9 +18,9 @@ LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= gtk20
PLUGIN_DIR?= libexec/gimp/2.2/plug-ins
diff --git a/graphics/zbar/Makefile b/graphics/zbar/Makefile
index c196dfcba76f..9e11df9ca0f2 100644
--- a/graphics/zbar/Makefile
+++ b/graphics/zbar/Makefile
@@ -13,9 +13,8 @@ COMMENT= ZBar barcode reader
LICENSE= LGPL21
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
-USES= iconv
+USES= iconv gmake pkgconfig
OPTIONS_DEFINE= X11 IMAGEMAGICK V4L PYTHON GTK2 QT4
OPTIONS_DEFAULT= X11 IMAGEMAGICK
diff --git a/net-im/pidgin-rhythmbox/Makefile b/net-im/pidgin-rhythmbox/Makefile
index f51526f067b5..2c19d24f477f 100644
--- a/net-im/pidgin-rhythmbox/Makefile
+++ b/net-im/pidgin-rhythmbox/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pidgin-rhythmbox
-# Date created: 2007-06-28
-# Whom: Yuri Pankov <yuri@darklight.org.ru>
-#
+# Created by: Yuri Pankov <yuri@darklight.org.ru>
# $FreeBSD$
-#
PORTNAME= pidgin-rhythmbox
PORTVERSION= 2.0
@@ -19,7 +15,7 @@ LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin \
rhythmbox:${PORTSDIR}/audio/rhythmbox
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes