aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2002-05-13 13:58:06 +0800
committerdirk <dirk@FreeBSD.org>2002-05-13 13:58:06 +0800
commitfdb9a9efdd261e5ef6ba8f71fb4db58c75ebb787 (patch)
tree7b1a54c5f193a1c7b579c256a57b352231d7d0cc
parentea9bb9432d39d2d511bf632d25ff5fbec3e20848 (diff)
downloadfreebsd-ports-gnome-fdb9a9efdd261e5ef6ba8f71fb4db58c75ebb787.tar.gz
freebsd-ports-gnome-fdb9a9efdd261e5ef6ba8f71fb4db58c75ebb787.tar.zst
freebsd-ports-gnome-fdb9a9efdd261e5ef6ba8f71fb4db58c75ebb787.zip
Fix mkdir() bug.
PR: ports/37825 Submitted by: Jason Taylor <jason@jase.org>
-rw-r--r--lang/php4/Makefile2
-rw-r--r--lang/php5/Makefile2
-rw-r--r--lang/php53/Makefile2
-rw-r--r--www/mod_php4/Makefile2
-rw-r--r--www/mod_php4/files/patch-ext_standard_file.c20
-rw-r--r--www/mod_php5/Makefile2
-rw-r--r--www/mod_php5/files/patch-ext_standard_file.c20
7 files changed, 45 insertions, 5 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index c7eba8f875ed..e6142fd31fad 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= php4
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= lang
MASTERDIR= ${.CURDIR}/../../www/mod_php4
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index c7eba8f875ed..e6142fd31fad 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= php4
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= lang
MASTERDIR= ${.CURDIR}/../../www/mod_php4
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index c7eba8f875ed..e6142fd31fad 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= php4
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= lang
MASTERDIR= ${.CURDIR}/../../www/mod_php4
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index bae9bf9669da..874a0cb40806 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mod_php4
PORTVERSION= 4.2.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= www
MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php.he.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php4/files/patch-ext_standard_file.c b/www/mod_php4/files/patch-ext_standard_file.c
new file mode 100644
index 000000000000..7077adc68f47
--- /dev/null
+++ b/www/mod_php4/files/patch-ext_standard_file.c
@@ -0,0 +1,20 @@
+--- ext/standard/file.c.orig Thu Feb 28 09:26:44 2002
++++ ext/standard/file.c Tue May 7 13:57:19 2002
+@@ -1453,7 +1453,7 @@
+ PHP_FUNCTION(mkdir)
+ {
+ int dir_len, ret;
+- mode_t mode = 0777;
++ long mode = 0777;
+ char *dir;
+
+ if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "s|l", &dir, &dir_len, &mode) == FAILURE) {
+@@ -1468,7 +1468,7 @@
+ RETURN_FALSE;
+ }
+
+- ret = VCWD_MKDIR(dir, mode);
++ ret = VCWD_MKDIR(dir, (mode_t)mode);
+ if (ret < 0) {
+ php_error(E_WARNING, "mkdir() failed (%s)", strerror(errno));
+ RETURN_FALSE;
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index bae9bf9669da..874a0cb40806 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mod_php4
PORTVERSION= 4.2.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= www
MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php.he.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php5/files/patch-ext_standard_file.c b/www/mod_php5/files/patch-ext_standard_file.c
new file mode 100644
index 000000000000..7077adc68f47
--- /dev/null
+++ b/www/mod_php5/files/patch-ext_standard_file.c
@@ -0,0 +1,20 @@
+--- ext/standard/file.c.orig Thu Feb 28 09:26:44 2002
++++ ext/standard/file.c Tue May 7 13:57:19 2002
+@@ -1453,7 +1453,7 @@
+ PHP_FUNCTION(mkdir)
+ {
+ int dir_len, ret;
+- mode_t mode = 0777;
++ long mode = 0777;
+ char *dir;
+
+ if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "s|l", &dir, &dir_len, &mode) == FAILURE) {
+@@ -1468,7 +1468,7 @@
+ RETURN_FALSE;
+ }
+
+- ret = VCWD_MKDIR(dir, mode);
++ ret = VCWD_MKDIR(dir, (mode_t)mode);
+ if (ret < 0) {
+ php_error(E_WARNING, "mkdir() failed (%s)", strerror(errno));
+ RETURN_FALSE;