aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-11-03 01:33:16 +0800
committercrees <crees@FreeBSD.org>2011-11-03 01:33:16 +0800
commitff6c7f54a43e6233a17d039335e1e8f4901eb953 (patch)
tree951839304662ee67b2f024bb82e75233c11d8edc
parent1f4b0891f71389190325055cb8eca169e620de97 (diff)
downloadfreebsd-ports-gnome-ff6c7f54a43e6233a17d039335e1e8f4901eb953.tar.gz
freebsd-ports-gnome-ff6c7f54a43e6233a17d039335e1e8f4901eb953.tar.zst
freebsd-ports-gnome-ff6c7f54a43e6233a17d039335e1e8f4901eb953.zip
- Rename gstat to gnustat; otherwise it collides with base gstat (for geom) [1]
- Correct REINPLACE for permissions; \+ is a special character in a BRE PR: ports/160060 Submitted by: Veniamin Gvozdikov <g.veniamin@googlemail.com> Reviewed by: Jason Hellenthal, wxs, eadler Approved by: Jason Harris <jharris@widomaker.com> (maintainer)
-rw-r--r--sysutils/coreutils/Makefile9
-rw-r--r--sysutils/coreutils/pkg-plist2
2 files changed, 7 insertions, 4 deletions
diff --git a/sysutils/coreutils/Makefile b/sysutils/coreutils/Makefile
index ba4289ab8584..c78fc3e463df 100644
--- a/sysutils/coreutils/Makefile
+++ b/sysutils/coreutils/Makefile
@@ -18,7 +18,10 @@ CONFLICTS= id-utils-[0-9]* linux-gid-[0-9]*
SIG_FILES= ${DISTNAME}${EXTRACT_SUFX}.sig
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-prefix=g
+# A rather nasty hack to stop gnustat from conflicting with base gstat
+# bugs.freebsd.org/160060
+CONFIGURE_ARGS= --program-prefix=g \
+ --program-transform-name=s/stat/nustat/
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= "-I${LOCALBASE}/include"
@@ -41,7 +44,7 @@ MAN1= gbasename.1 gcat.1 gchcon.1 gchgrp.1 gchmod.1 gchown.1 gchroot.1 \
gmv.1 gnice.1 gnl.1 gnohup.1 god.1 gpaste.1 gpathchk.1 gpinky.1 \
gpr.1 gprintenv.1 gprintf.1 gptx.1 gpwd.1 greadlink.1 grm.1 \
grmdir.1 gruncon.1 gseq.1 gsha1sum.1 gshred.1 gsleep.1 gsort.1 \
- gsplit.1 gstdbuf.1 gstat.1 gstty.1 gsum.1 gsync.1 gtac.1 \
+ gsplit.1 gstdbuf.1 gnustat.1 gstty.1 gsum.1 gsync.1 gtac.1 \
gtail.1 gtee.1 gtest.1 gtimeout.1 gtouch.1 gtr.1 gtrue.1 gtruncate.1 \
gtsort.1 gtty.1 guname.1 gunexpand.1 guniq.1 gunlink.1 guptime.1 \
gusers.1 gvdir.1 gwc.1 gwho.1 gwhoami.1 gyes.1 gbase64.1 gsha224sum.1 \
@@ -73,7 +76,7 @@ EXTRA_PATCHES= ${PATCHDIR}/extra-patch-stty.c
post-patch:
.if !defined(WITH_SUID)
- @${REINPLACE_CMD} -e "s/u\+s/u\+w/g" ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e "s/u+s/u+w/g" ${WRKSRC}/src/Makefile.in
.endif
post-build:
diff --git a/sysutils/coreutils/pkg-plist b/sysutils/coreutils/pkg-plist
index cb6c94fea3a2..002666dde8c9 100644
--- a/sysutils/coreutils/pkg-plist
+++ b/sysutils/coreutils/pkg-plist
@@ -72,7 +72,7 @@ bin/gshuf
bin/gsleep
bin/gsort
bin/gsplit
-bin/gstat
+bin/gnustat
bin/gstdbuf
bin/gstty
bin/gsum