aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-02-23 22:18:10 +0800
committerpawel <pawel@FreeBSD.org>2013-02-23 22:18:10 +0800
commit37400284774fbeb99662fde08e1027006ec7fd44 (patch)
tree5546eca61e3a018e2a7e146e195e499cf9ccd724
parent11bb1b8c7436662b7f34e9c36302a700ea67bd08 (diff)
downloadfreebsd-ports-gnome-37400284774fbeb99662fde08e1027006ec7fd44.tar.gz
freebsd-ports-gnome-37400284774fbeb99662fde08e1027006ec7fd44.tar.zst
freebsd-ports-gnome-37400284774fbeb99662fde08e1027006ec7fd44.zip
- Fix build when MOZILLA=on
- Convert to OptionsNG PR: ports/175937 Submitted by: myself Approved by: maintainer timeout
-rw-r--r--x11-toolkits/swt-devel/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/x11-toolkits/swt-devel/Makefile b/x11-toolkits/swt-devel/Makefile
index 26ee8292a2ef..4ed0910a2be0 100644
--- a/x11-toolkits/swt-devel/Makefile
+++ b/x11-toolkits/swt-devel/Makefile
@@ -39,26 +39,28 @@ PLIST_FILES= %%JAVAJARDIR%%/${OUTPUT_JAR} \
NO_WRKSUBDIR= yes
-OPTIONS= CAIRO "Cairo Support" on \
- GNOMEVFS "Gnome VFS Support" on \
- MOZILLA "Gecko Browser Support" off
+OPTIONS_DEFINE= CAIRO GNOMEVFS MOZILLA
+GNOMEVFS_DESC= Gnome VFS support
+MOZILLA_DESC= Gecko browser support
-.include <bsd.port.pre.mk>
+OPTIONS_DEFAULT=CAIRO GNOMEVFS
+
+.include <bsd.port.options.mk>
-.if defined(WITH_CAIRO)
-LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
+.if ${PORT_OPTIONS:MCAIRO}
+LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo
PLIST_FILES+= lib/libswt-cairo-gtk-%%BUILD%%.so
MAKE_CAIRO= make_cairo
.endif
-.if defined(WITH_GNOMEVFS)
+.if ${PORT_OPTIONS:MGNOMEVFS}
USE_GNOME+= gnomevfs2 libgnome libgnomeui
PLIST_FILES+= lib/libswt-gnome-gtk-%%BUILD%%.so
MAKE_GNOME= make_gnome
.endif
-.if defined(WITH_MOZILLA)
-USE_MOZILLA= libxul
+.if ${PORT_OPTIONS:MMOZILLA}
+USE_GECKO= libxul19
PLIST_FILES+= lib/libswt-xulrunner-gtk-%%BUILD%%.so
MAKE_MOZILLA= make_xulrunner
.endif
@@ -76,6 +78,8 @@ DIST_EXT= gtk-linux-ppc64
DIST_EXT= gtk-linux-x86
.endif
+.include <bsd.port.pre.mk>
+
post-extract:
.if ${OSVERSION} > 900044
@(cd ${WRKSRC} && /usr/bin/unzip -qo *.zip)