aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2016-03-30 17:43:57 +0800
committerohauer <ohauer@FreeBSD.org>2016-03-30 17:43:57 +0800
commit4dd9751459679ebdc69520270ce26858cc20dd44 (patch)
tree0e48cbd6d2a12707eeb2f4b64c2583da1b38418d
parenta8310ecec18bf2706034652884f175f65049282f (diff)
downloadfreebsd-ports-gnome-4dd9751459679ebdc69520270ce26858cc20dd44.tar.gz
freebsd-ports-gnome-4dd9751459679ebdc69520270ce26858cc20dd44.tar.zst
freebsd-ports-gnome-4dd9751459679ebdc69520270ce26858cc20dd44.zip
- remove ${PORTSDIR} from dependency
-rw-r--r--devel/cvs2svn/Makefile10
-rw-r--r--devel/viewvc/Makefile14
-rw-r--r--mail/postfix/Makefile14
-rw-r--r--mail/postfix211/Makefile14
-rw-r--r--security/nmap/Makefile2
-rw-r--r--security/pulledpork/Makefile8
6 files changed, 31 insertions, 31 deletions
diff --git a/devel/cvs2svn/Makefile b/devel/cvs2svn/Makefile
index 18cf6044dc5d..1c9e975f3e9a 100644
--- a/devel/cvs2svn/Makefile
+++ b/devel/cvs2svn/Makefile
@@ -14,7 +14,7 @@ PATCH_SITES= LOCAL/ohauer
MAINTAINER= ohauer@FreeBSD.org
COMMENT= CVS to Subversion Repository Converter
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gdbm>0:${PORTSDIR}/databases/py-gdbm
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gdbm>0:databases/py-gdbm
RUN_DEPENDS:= ${BUILD_DEPENDS}
# 2.4.0 -> svn r5392
@@ -35,14 +35,14 @@ SUBVERSION_DESC= Build with subversion support
GIT_DESC= Build with git support
BAZAAR_DESC= Build with Bazaar support
-SUBVERSION_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}subversion>=0:${PORTSDIR}/devel/py-subversion
-GIT_RUN_DEPENDS= ${LOCALBASE}/bin/git:${PORTSDIR}/devel/git
-BAZAAR_RUN_DEPENDS= ${LOCALBASE}/bin/bzr:${PORTSDIR}/devel/bzr
+SUBVERSION_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}subversion>=0:devel/py-subversion
+GIT_RUN_DEPENDS= ${LOCALBASE}/bin/git:devel/git
+BAZAAR_RUN_DEPENDS= ${LOCALBASE}/bin/bzr:devel/bzr
.include <bsd.port.options.mk>
.if ${OSVERSION} > 1000000
-RUN_DEPENDS+= cvs:${PORTSDIR}/devel/cvs
+RUN_DEPENDS+= cvs:devel/cvs
.endif
# documents from ${WRKSRC}/doc
diff --git a/devel/viewvc/Makefile b/devel/viewvc/Makefile
index e6b48d8deb32..65b100bb0bbd 100644
--- a/devel/viewvc/Makefile
+++ b/devel/viewvc/Makefile
@@ -30,12 +30,12 @@ MODPYTHON35_DESC= Enable mod_python35 support
MYSQL_DESC= Bonsai-like repository query facilities
APACHE_USE= APACHE_RUN=22+
-LIGHTTPD_RUN_DEPENDS= lighttpd:${PORTSDIR}/www/lighttpd
-MODPYTHON33_RUN_DEPENDS=${APACHE_PKGNAMEPREFIX}mod_python33>=3.3:${PORTSDIR}/www/mod_python33
-MODPYTHON35_RUN_DEPENDS=${APACHE_PKGNAMEPREFIX}mod_python35>=3.5:${PORTSDIR}/www/mod_python35
-MODWSGI_RUN_DEPENDS= ${APACHE_PKGNAMEPREFIX}mod_wsgi4>=4.4.13:${PORTSDIR}/www/mod_wsgi4
-SVN_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}subversion>=0:${PORTSDIR}/devel/py-subversion
-MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
+LIGHTTPD_RUN_DEPENDS= lighttpd:www/lighttpd
+MODPYTHON33_RUN_DEPENDS=${APACHE_PKGNAMEPREFIX}mod_python33>=3.3:www/mod_python33
+MODPYTHON35_RUN_DEPENDS=${APACHE_PKGNAMEPREFIX}mod_python35>=3.5:www/mod_python35
+MODWSGI_RUN_DEPENDS= ${APACHE_PKGNAMEPREFIX}mod_wsgi4>=4.4.13:www/mod_wsgi4
+SVN_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}subversion>=0:devel/py-subversion
+MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:databases/py-MySQLdb
.include <bsd.port.options.mk>
@@ -47,7 +47,7 @@ SUB_LIST= PYTHON_CMD=${PYTHON_CMD} \
ECHO=${ECHO} EGREP=${EGREP} TOUCH=${TOUCH} \
CHOWN=${CHOWN} RM=${RM:Q}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:${PORTSDIR}/textproc/py-pygments
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:textproc/py-pygments
pre-everything::
.if ${PORT_OPTIONS:MAPMOD} && !${PORT_OPTIONS:MAPACHE}
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 8e514f568943..5949708201dc 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -22,7 +22,7 @@ LICENSE_NAME= IBM PUBLIC LICENSE VERSION 1.0
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-LIB_DEPENDS= libicuuc.so:${PORTSDIR}/devel/icu
+LIB_DEPENDS= libicuuc.so:devel/icu
PORTSCOUT= limit:^3\.1\.
@@ -48,14 +48,14 @@ OPTIONS_RADIO_RG1= SASLKRB5 SASLKMIT
OPTIONS_DEFAULT= PCRE TLS
BDB_USE= BDB=yes
-CDB_LIB_DEPENDS= libcdb.so:${PORTSDIR}/databases/tinycdb
+CDB_LIB_DEPENDS= libcdb.so:databases/tinycdb
LDAP_USE= OPENLDAP=yes
-LMDB_LIB_DEPENDS= liblmdb.so:${PORTSDIR}/databases/lmdb
+LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
MYSQL_USE= MYSQL=yes
-PCRE_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
PGSQL_USES= pgsql
-SASLKMIT_LIB_DEPENDS= libkrb5.so:${PORTSDIR}/security/krb5
-SASL_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+SASLKMIT_LIB_DEPENDS= libkrb5.so:security/krb5
+SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
SQLITE_USES= sqlite
TLS_USE= OPENSSL=yes
@@ -220,7 +220,7 @@ POSTFIX_DYN_AUXLIBS+= "AUXLIBS_LDAP=-L${LOCALBASE}/lib -lldap -L${LOCALBASE}/lib
_REQUIRE+= slapd
. if ${PORT_OPTIONS:MLDAP_SASL}
. if ! ${PORT_OPTIONS:MSASL}
-LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:security/cyrus-sasl2
. endif
WANT_OPENLDAP_SASL= yes
POSTFIX_CCARGS+= -I${LOCALBASE}/include/sasl -DUSE_LDAP_SASL
diff --git a/mail/postfix211/Makefile b/mail/postfix211/Makefile
index 756ecea6b137..ec3b85f18dab 100644
--- a/mail/postfix211/Makefile
+++ b/mail/postfix211/Makefile
@@ -49,15 +49,15 @@ OPTIONS_RADIO_RG1= SASLKRB5 SASLKMIT
OPTIONS_DEFAULT= PCRE TLS
BDB_USE= BDB=yes
-CDB_LIB_DEPENDS= libcdb.so:${PORTSDIR}/databases/tinycdb
+CDB_LIB_DEPENDS= libcdb.so:databases/tinycdb
LDAP_USE= OPENLDAP=yes
-LMDB_LIB_DEPENDS= liblmdb.so:${PORTSDIR}/databases/lmdb
+LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
MYSQL_USE= MYSQL=yes
-PCRE_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
PGSQL_USES= pgsql
-SASLKMIT_LIB_DEPENDS= libkrb5.so:${PORTSDIR}/security/krb5
-SASL_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
-SPF_LIB_DEPENDS= libspf2.so:${PORTSDIR}/mail/libspf2
+SASLKMIT_LIB_DEPENDS= libkrb5.so:security/krb5
+SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
+SPF_LIB_DEPENDS= libspf2.so:mail/libspf2
SQLITE_USES= sqlite
TLS_USE= OPENSSL=yes
@@ -222,7 +222,7 @@ POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lldap -llber
_REQUIRE+= slapd
. if ${PORT_OPTIONS:MLDAP_SASL}
. if ! ${PORT_OPTIONS:MSASL}
-LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:security/cyrus-sasl2
. endif
WANT_OPENLDAP_SASL= yes
POSTFIX_CCARGS+= -I${LOCALBASE}/include/sasl -DUSE_LDAP_SASL
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index b6f5eed88747..54b55d9d5162 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -17,7 +17,7 @@ COMMENT= Port scanning utility for large networks
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:devel/pcre
USES= tar:bzip2 gmake cpe
GNU_CONFIGURE= yes
diff --git a/security/pulledpork/Makefile b/security/pulledpork/Makefile
index 778f47ed1485..39d8cd0d4f84 100644
--- a/security/pulledpork/Makefile
+++ b/security/pulledpork/Makefile
@@ -12,10 +12,10 @@ COMMENT= Script to update snort-2.8+ rules
LICENSE= GPLv2
-RUN_DEPENDS= p5-Crypt-SSLeay>=0.57:${PORTSDIR}/security/p5-Crypt-SSLeay \
- p5-LWP-Protocol-https>=6.00:${PORTSDIR}/www/p5-LWP-Protocol-https \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
- ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+RUN_DEPENDS= p5-Crypt-SSLeay>=0.57:security/p5-Crypt-SSLeay \
+ p5-LWP-Protocol-https>=6.00:www/p5-LWP-Protocol-https \
+ p5-libwww>=0:www/p5-libwww \
+ ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
NO_BUILD= yes
USES= perl5 shebangfix