aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2016-04-01 11:31:43 +0800
committertj <tj@FreeBSD.org>2016-04-01 11:31:43 +0800
commit4e0bc6526a2e960d99ed6ee811fac6a9789b98a0 (patch)
treef5519beedb871ab9f608f0164fcac4278af4e75d
parentac2a922f229c56924f495e6a59c89e4e738e4ae5 (diff)
downloadfreebsd-ports-gnome-4e0bc6526a2e960d99ed6ee811fac6a9789b98a0.tar.gz
freebsd-ports-gnome-4e0bc6526a2e960d99ed6ee811fac6a9789b98a0.tar.zst
freebsd-ports-gnome-4e0bc6526a2e960d99ed6ee811fac6a9789b98a0.zip
New port www/py-django-configurations 1.0
django-configurations eases Django project configuration by relying on the composability of Python classes. It extends the notion of Django's module based settings loading with well established object oriented programming patterns. WWW: https://github.com/jazzband/django-configurations
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-configurations/Makefile22
-rw-r--r--www/py-django-configurations/distinfo2
-rw-r--r--www/py-django-configurations/pkg-descr5
4 files changed, 30 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 609fead1db6a..8426b92d7f2f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1531,6 +1531,7 @@
SUBDIR += py-django-caching-app-plugins
SUBDIR += py-django-classy-tags
SUBDIR += py-django-cms
+ SUBDIR += py-django-configurations
SUBDIR += py-django-contact-form
SUBDIR += py-django-contrib-comments
SUBDIR += py-django-countries
diff --git a/www/py-django-configurations/Makefile b/www/py-django-configurations/Makefile
new file mode 100644
index 000000000000..4f0d374c9ccc
--- /dev/null
+++ b/www/py-django-configurations/Makefile
@@ -0,0 +1,22 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= configurations
+PORTVERSION= 1.0
+CATEGORIES= www python
+MASTER_SITES= GH
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}django-
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Django project configuration using the composability of Python classes
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django18>=0:${PORTSDIR}/www/py-django18
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+USE_GITHUB= yes
+GH_ACCOUNT= jazzband
+GH_PROJECT= django-configurations
+
+.include <bsd.port.mk>
diff --git a/www/py-django-configurations/distinfo b/www/py-django-configurations/distinfo
new file mode 100644
index 000000000000..4a54047a15d9
--- /dev/null
+++ b/www/py-django-configurations/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jazzband-django-configurations-1.0_GH0.tar.gz) = 345564cf1481a0101a59026a2ec0ec8fae51e8a25fe4083c1b2ca6beb911aed9
+SIZE (jazzband-django-configurations-1.0_GH0.tar.gz) = 39308
diff --git a/www/py-django-configurations/pkg-descr b/www/py-django-configurations/pkg-descr
new file mode 100644
index 000000000000..8aa6cf6f76ae
--- /dev/null
+++ b/www/py-django-configurations/pkg-descr
@@ -0,0 +1,5 @@
+django-configurations eases Django project configuration by relying on the
+composability of Python classes. It extends the notion of Django's module based
+settings loading with well established object oriented programming patterns.
+
+WWW: https://github.com/jazzband/django-configurations