aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-11-04 07:58:45 +0800
committerjbeich <jbeich@FreeBSD.org>2017-11-04 07:58:45 +0800
commit5174833eebe0bd2288f67e2d577b619c7fa96f4f (patch)
tree369df38c2cb122c2c028f63ea3a9b9709e6ff607
parent37cfb2bb9a354d4bd413901c2830ceb0df91809d (diff)
downloadfreebsd-ports-gnome-5174833eebe0bd2288f67e2d577b619c7fa96f4f.tar.gz
freebsd-ports-gnome-5174833eebe0bd2288f67e2d577b619c7fa96f4f.tar.zst
freebsd-ports-gnome-5174833eebe0bd2288f67e2d577b619c7fa96f4f.zip
gecko: speed up HTML5 video scaling on i386
MFH: 2017Q4
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--mail/thunderbird/files/patch-bug141444072
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/files/patch-bug141444072
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-bug141444094
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--www/seamonkey/files/patch-bug141444072
8 files changed, 314 insertions, 4 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 9f88ed3ccac3..50e06ec0b716 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,7 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 52.4.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build3/source
diff --git a/mail/thunderbird/files/patch-bug1414440 b/mail/thunderbird/files/patch-bug1414440
new file mode 100644
index 000000000000..c3192c306d40
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug1414440
@@ -0,0 +1,72 @@
+Build libyuv with SIMD optimizations on Linux x86.
+
+diff --git media/libyuv/include/libyuv/compare_row.h media/libyuv/include/libyuv/compare_row.h
+index 7abc2d4aef8f..161c12fa1b83 100644
+--- mozilla/media/libyuv/include/libyuv/compare_row.h
++++ mozilla/media/libyuv/include/libyuv/compare_row.h
+@@ -18,8 +18,7 @@ namespace libyuv {
+ extern "C" {
+ #endif
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/include/libyuv/planar_functions.h media/libyuv/include/libyuv/planar_functions.h
+index 040839c211b1..0d672dec96d6 100644
+--- mozilla/media/libyuv/include/libyuv/planar_functions.h
++++ mozilla/media/libyuv/include/libyuv/planar_functions.h
+@@ -719,8 +719,7 @@ int I420Interpolate(const uint8* src0_y,
+ int height,
+ int interpolation);
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/include/libyuv/rotate_row.h media/libyuv/include/libyuv/rotate_row.h
+index 2c51584eee8b..73bbe8ef7ad4 100644
+--- mozilla/media/libyuv/include/libyuv/rotate_row.h
++++ mozilla/media/libyuv/include/libyuv/rotate_row.h
+@@ -18,8 +18,7 @@ namespace libyuv {
+ extern "C" {
+ #endif
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/include/libyuv/row.h media/libyuv/include/libyuv/row.h
+index f74bd9f7d17a..3bdfb75fc160 100644
+--- mozilla/media/libyuv/include/libyuv/row.h
++++ mozilla/media/libyuv/include/libyuv/row.h
+@@ -30,8 +30,7 @@ extern "C" {
+ free(var##_mem); \
+ var = 0
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/include/libyuv/scale_row.h media/libyuv/include/libyuv/scale_row.h
+index edb46cc8c647..fe78a80f81bd 100644
+--- mozilla/media/libyuv/include/libyuv/scale_row.h
++++ mozilla/media/libyuv/include/libyuv/scale_row.h
+@@ -19,8 +19,7 @@ namespace libyuv {
+ extern "C" {
+ #endif
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 19964e31e3af..a078c4cd6ddd 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 52.4.1
DISTVERSIONSUFFIX=esr.source
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/files/patch-bug1414440 b/www/firefox-esr/files/patch-bug1414440
new file mode 100644
index 000000000000..3a8c7b758ac9
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1414440
@@ -0,0 +1,72 @@
+Build libyuv with SIMD optimizations on Linux x86.
+
+diff --git media/libyuv/include/libyuv/compare_row.h media/libyuv/include/libyuv/compare_row.h
+index 7abc2d4aef8f..161c12fa1b83 100644
+--- media/libyuv/include/libyuv/compare_row.h
++++ media/libyuv/include/libyuv/compare_row.h
+@@ -18,8 +18,7 @@ namespace libyuv {
+ extern "C" {
+ #endif
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/include/libyuv/planar_functions.h media/libyuv/include/libyuv/planar_functions.h
+index 040839c211b1..0d672dec96d6 100644
+--- media/libyuv/include/libyuv/planar_functions.h
++++ media/libyuv/include/libyuv/planar_functions.h
+@@ -719,8 +719,7 @@ int I420Interpolate(const uint8* src0_y,
+ int height,
+ int interpolation);
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/include/libyuv/rotate_row.h media/libyuv/include/libyuv/rotate_row.h
+index 2c51584eee8b..73bbe8ef7ad4 100644
+--- media/libyuv/include/libyuv/rotate_row.h
++++ media/libyuv/include/libyuv/rotate_row.h
+@@ -18,8 +18,7 @@ namespace libyuv {
+ extern "C" {
+ #endif
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/include/libyuv/row.h media/libyuv/include/libyuv/row.h
+index f74bd9f7d17a..3bdfb75fc160 100644
+--- media/libyuv/include/libyuv/row.h
++++ media/libyuv/include/libyuv/row.h
+@@ -30,8 +30,7 @@ extern "C" {
+ free(var##_mem); \
+ var = 0
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/include/libyuv/scale_row.h media/libyuv/include/libyuv/scale_row.h
+index edb46cc8c647..fe78a80f81bd 100644
+--- media/libyuv/include/libyuv/scale_row.h
++++ media/libyuv/include/libyuv/scale_row.h
+@@ -19,8 +19,7 @@ namespace libyuv {
+ extern "C" {
+ #endif
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 5c19cd951bf7..0ef49ccf408d 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 56.0.2
DISTVERSIONSUFFIX=.source
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/files/patch-bug1414440 b/www/firefox/files/patch-bug1414440
new file mode 100644
index 000000000000..13808477368b
--- /dev/null
+++ b/www/firefox/files/patch-bug1414440
@@ -0,0 +1,94 @@
+Build libyuv with SIMD optimizations on Linux x86.
+
+diff --git media/libyuv/libyuv/include/libyuv/compare_row.h media/libyuv/libyuv/include/libyuv/compare_row.h
+index 7abc2d4aef8f..161c12fa1b83 100644
+--- media/libyuv/libyuv/include/libyuv/compare_row.h
++++ media/libyuv/libyuv/include/libyuv/compare_row.h
+@@ -18,8 +18,7 @@ namespace libyuv {
+ extern "C" {
+ #endif
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/libyuv/include/libyuv/planar_functions.h media/libyuv/libyuv/include/libyuv/planar_functions.h
+index 040839c211b1..0d672dec96d6 100644
+--- media/libyuv/libyuv/include/libyuv/planar_functions.h
++++ media/libyuv/libyuv/include/libyuv/planar_functions.h
+@@ -719,8 +719,7 @@ int I420Interpolate(const uint8* src0_y,
+ int height,
+ int interpolation);
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/libyuv/include/libyuv/rotate_row.h media/libyuv/libyuv/include/libyuv/rotate_row.h
+index 2c51584eee8b..73bbe8ef7ad4 100644
+--- media/libyuv/libyuv/include/libyuv/rotate_row.h
++++ media/libyuv/libyuv/include/libyuv/rotate_row.h
+@@ -18,8 +18,7 @@ namespace libyuv {
+ extern "C" {
+ #endif
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/libyuv/include/libyuv/row.h media/libyuv/libyuv/include/libyuv/row.h
+index f74bd9f7d17a..3bdfb75fc160 100644
+--- media/libyuv/libyuv/include/libyuv/row.h
++++ media/libyuv/libyuv/include/libyuv/row.h
+@@ -30,8 +30,7 @@ extern "C" {
+ free(var##_mem); \
+ var = 0
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+@@ -103,7 +102,10 @@ extern "C" {
+ #define HAS_COPYROW_ERMS
+ #define HAS_COPYROW_SSE2
+ #define HAS_H422TOARGBROW_SSSE3
++#ifdef __SSE2__
++// source/row_gcc.cc:5457:5: error: couldn't allocate input reg for constraint 'x'
+ #define HAS_HALFFLOATROW_SSE2
++#endif
+ #define HAS_I400TOARGBROW_SSE2
+ #define HAS_I422TOARGB1555ROW_SSSE3
+ #define HAS_I422TOARGB4444ROW_SSSE3
+@@ -202,7 +204,10 @@ extern "C" {
+ #define HAS_ARGBTOYROW_AVX2
+ #define HAS_COPYROW_AVX
+ #define HAS_H422TOARGBROW_AVX2
++#ifdef __SSE2__
++// source/row_gcc.cc:5492:5: error: couldn't allocate input reg for constraint 'x'
+ #define HAS_HALFFLOATROW_AVX2
++#endif
+ // #define HAS_HALFFLOATROW_F16C // Enable to test halffloat cast
+ #define HAS_I400TOARGBROW_AVX2
+ #define HAS_I422TOARGB1555ROW_AVX2
+diff --git media/libyuv/libyuv/include/libyuv/scale_row.h media/libyuv/libyuv/include/libyuv/scale_row.h
+index edb46cc8c647..fe78a80f81bd 100644
+--- media/libyuv/libyuv/include/libyuv/scale_row.h
++++ media/libyuv/libyuv/include/libyuv/scale_row.h
+@@ -19,8 +19,7 @@ namespace libyuv {
+ extern "C" {
+ #endif
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 641667e2e81c..b4baae52bc79 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -3,7 +3,7 @@
PORTNAME= seamonkey
DISTVERSION= 2.49.1
-PORTREVISION= 3
+PORTREVISION= 4
MOZILLA_VER= 52 # above + 3
CATEGORIES?= www mail news editors irc ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/seamonkey/files/patch-bug1414440 b/www/seamonkey/files/patch-bug1414440
new file mode 100644
index 000000000000..c3192c306d40
--- /dev/null
+++ b/www/seamonkey/files/patch-bug1414440
@@ -0,0 +1,72 @@
+Build libyuv with SIMD optimizations on Linux x86.
+
+diff --git media/libyuv/include/libyuv/compare_row.h media/libyuv/include/libyuv/compare_row.h
+index 7abc2d4aef8f..161c12fa1b83 100644
+--- mozilla/media/libyuv/include/libyuv/compare_row.h
++++ mozilla/media/libyuv/include/libyuv/compare_row.h
+@@ -18,8 +18,7 @@ namespace libyuv {
+ extern "C" {
+ #endif
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/include/libyuv/planar_functions.h media/libyuv/include/libyuv/planar_functions.h
+index 040839c211b1..0d672dec96d6 100644
+--- mozilla/media/libyuv/include/libyuv/planar_functions.h
++++ mozilla/media/libyuv/include/libyuv/planar_functions.h
+@@ -719,8 +719,7 @@ int I420Interpolate(const uint8* src0_y,
+ int height,
+ int interpolation);
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/include/libyuv/rotate_row.h media/libyuv/include/libyuv/rotate_row.h
+index 2c51584eee8b..73bbe8ef7ad4 100644
+--- mozilla/media/libyuv/include/libyuv/rotate_row.h
++++ mozilla/media/libyuv/include/libyuv/rotate_row.h
+@@ -18,8 +18,7 @@ namespace libyuv {
+ extern "C" {
+ #endif
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/include/libyuv/row.h media/libyuv/include/libyuv/row.h
+index f74bd9f7d17a..3bdfb75fc160 100644
+--- mozilla/media/libyuv/include/libyuv/row.h
++++ mozilla/media/libyuv/include/libyuv/row.h
+@@ -30,8 +30,7 @@ extern "C" {
+ free(var##_mem); \
+ var = 0
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505
+diff --git media/libyuv/include/libyuv/scale_row.h media/libyuv/include/libyuv/scale_row.h
+index edb46cc8c647..fe78a80f81bd 100644
+--- mozilla/media/libyuv/include/libyuv/scale_row.h
++++ mozilla/media/libyuv/include/libyuv/scale_row.h
+@@ -19,8 +19,7 @@ namespace libyuv {
+ extern "C" {
+ #endif
+
+-#if defined(__pnacl__) || defined(__CLR_VER) || \
+- (defined(__i386__) && !defined(__SSE2__))
++#if defined(__pnacl__) || defined(__CLR_VER)
+ #define LIBYUV_DISABLE_X86
+ #endif
+ // MemorySanitizer does not support assembly code yet. http://crbug.com/344505