aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-09-24 19:14:24 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-09-24 19:14:24 +0800
commit56c20cd9edc8a421c58c7158cfdfeec0a6812b0d (patch)
tree9dda585dcd2abfad9ae737d3d1c470239c2f1ffb
parenta5d40e7069a4069462b4f9bc90bfa67375fd7021 (diff)
downloadfreebsd-ports-gnome-56c20cd9edc8a421c58c7158cfdfeec0a6812b0d.tar.gz
freebsd-ports-gnome-56c20cd9edc8a421c58c7158cfdfeec0a6812b0d.tar.zst
freebsd-ports-gnome-56c20cd9edc8a421c58c7158cfdfeec0a6812b0d.zip
Change from MPICH2 to MPICH option
- Bump PORTREVISION for dependency and package change PR: 231634 Submitted by: yuri
-rw-r--r--science/pnetcdf/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/science/pnetcdf/Makefile b/science/pnetcdf/Makefile
index c2f0f406769c..e6331e78e80c 100644
--- a/science/pnetcdf/Makefile
+++ b/science/pnetcdf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pnetcdf
PORTVERSION= 1.8.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= science parallel
MASTER_SITES= http://cucis.ece.northwestern.edu/projects/PnetCDF/Release/ \
LOCAL/sunpoet
@@ -14,7 +14,7 @@ COMMENT= Library providing high-performance I/O
OPTIONS_DEFINE= DOCS
OPTIONS_SINGLE= MPI
-OPTIONS_SINGLE_MPI= OPENMPI OPENMPI2 OPENMPI3 MPICH2
+OPTIONS_SINGLE_MPI= OPENMPI OPENMPI2 OPENMPI3 MPICH
OPTIONS_DEFAULT=OPENMPI3
OPENMPI_DESC= Parallel processing support via Open MPI 1.x
OPENMPI2_DESC= Parallel processing support via Open MPI 2.x
@@ -31,8 +31,8 @@ USES= fortran gmake pathfix perl5 tar:bzip2
PORTDOCS= COPYRIGHT INSTALL README
-MPICH2_CONFIGURE_ON= --with-mpi=${LOCALBASE}
-MPICH2_LIB_DEPENDS= libmpich.so:net/mpich2
+MPICH_CONFIGURE_ON= --with-mpi=${LOCALBASE}
+MPICH_LIB_DEPENDS= libmpich.so:net/mpich
OPENMPI_CONFIGURE_ON= --with-mpi=${LOCALBASE}/mpi/openmpi
OPENMPI_LIB_DEPENDS= libmpi.so:net/openmpi
OPENMPI2_CONFIGURE_ON= --with-mpi=${LOCALBASE}/mpi/openmpi2