aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2014-03-11 20:44:06 +0800
committermatthew <matthew@FreeBSD.org>2014-03-11 20:44:06 +0800
commit57a3bc3803f32f41f8e76e710e8b92491ebe6c58 (patch)
tree12fe8d66ac0d4c4b5bc014f1590b531c4fee9f1e
parente5d39c71c9bb5b06baa3376789b05c574ec1e8e5 (diff)
downloadfreebsd-ports-gnome-57a3bc3803f32f41f8e76e710e8b92491ebe6c58.tar.gz
freebsd-ports-gnome-57a3bc3803f32f41f8e76e710e8b92491ebe6c58.tar.zst
freebsd-ports-gnome-57a3bc3803f32f41f8e76e710e8b92491ebe6c58.zip
lighttpd+mod_fastcgi and spawn-fcgi web deployment methods both incur
a dependency on p5-FCGI, not just apache+mod_fastcgi
-rw-r--r--www/rt42/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/www/rt42/Makefile b/www/rt42/Makefile
index 8755caafefd0..92ddc02e3ec3 100644
--- a/www/rt42/Makefile
+++ b/www/rt42/Makefile
@@ -2,6 +2,7 @@
PORTNAME= rt
DISTVERSION= 4.2.3
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/
PKGNAMESUFFIX= 42
@@ -71,10 +72,12 @@ AP_MODFASTCGI_RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDI
${FASTCGI_DEPS}
LIGHTTPD_DESC= Deploy with lighttpd and mod_fastcgi
-LIGHTTPD_RUN_DEPENDS= ${LOCALBASE}/sbin/lighttpd:${PORTSDIR}/www/lighttpd
+LIGHTTPD_RUN_DEPENDS= ${LOCALBASE}/sbin/lighttpd:${PORTSDIR}/www/lighttpd \
+ ${FASTCGI_DEPS}
SPAWN_FCGI_DESC= Deploy with spawn_fcgi
-SPAWN_FCGI_RUN_DEPENDS= ${LOCALBASE}/bin/spawn-fcgi:${PORTSDIR}/www/spawn-fcgi
+SPAWN_FCGI_RUN_DEPENDS= ${LOCALBASE}/bin/spawn-fcgi:${PORTSDIR}/www/spawn-fcgi \
+ ${FASTCGI_DEPS}
MYSQL_USE= MYSQL=yes
MYSQL_RUN_DEPENDS= ${MYSQL_DEPS}