aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2016-10-08 23:15:31 +0800
committerbrnrd <brnrd@FreeBSD.org>2016-10-08 23:15:31 +0800
commitc36436fa2bc04525edd3f5523ead498997ce1d22 (patch)
tree22efa0cd647378084666d61bab8d6b0531811f0d
parentcc4578be65f3cb581ca484566dbabf00c81902b4 (diff)
downloadfreebsd-ports-gnome-c36436fa2bc04525edd3f5523ead498997ce1d22.tar.gz
freebsd-ports-gnome-c36436fa2bc04525edd3f5523ead498997ce1d22.tar.zst
freebsd-ports-gnome-c36436fa2bc04525edd3f5523ead498997ce1d22.zip
security/acme-client: Add STATIC option
- Allow static linking - Forego SSL runtime dependency - Add warning about deinstall libressl after build - Add extra patch for static option PR: 212980 Submitted by: Christian Schwarz <me@cschwarz.com>
-rw-r--r--security/acme-client/Makefile13
-rw-r--r--security/acme-client/files/extra-patch-GNUmakefile11
2 files changed, 22 insertions, 2 deletions
diff --git a/security/acme-client/Makefile b/security/acme-client/Makefile
index db308e1880aa..d95104f40a75 100644
--- a/security/acme-client/Makefile
+++ b/security/acme-client/Makefile
@@ -13,7 +13,14 @@ COMMENT= Native C client for Let's Encrypt, designed for security
LICENSE= ISCL
-USES= gmake ssl tar:tgz
+USES= gmake tar:tgz
+
+OPTIONS_DEFINE= STATIC_ACMECLIENT
+STATIC_ACMECLIENT_DESC= Link statically with security/libressl
+
+STATIC_ACMECLIENT_USES_OFF= ssl
+STATIC_ACMECLIENT_BUILD_DEPENDS= ${LOCALBASE}/lib/libtls.a:security/libressl
+STATIC_ACMECLIENT_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-GNUmakefile
MAKEFILE= GNUmakefile
MAKE_ENV= PREFIX=${STAGEDIR}/${PREFIX}
@@ -46,9 +53,11 @@ post-install:
.include <bsd.port.pre.mk>
-.if empty(SSL_DEFAULT:M*libressl*)
+.if ${PORT_OPTIONS:MSTATIC_ACMECLIENT} == "" && empty(SSL_DEFAULT:M*libressl*)
IGNORE= needs LibreSSL to build. set DEFAULT_VERSIONS+=ssl=libressl \
and rebuild all ports that depend on openssl
+.else
+WARNING= "Remember to deinstall libressl after building acme-client"
.endif
.include <bsd.port.post.mk>
diff --git a/security/acme-client/files/extra-patch-GNUmakefile b/security/acme-client/files/extra-patch-GNUmakefile
new file mode 100644
index 000000000000..f1e3113c0ea0
--- /dev/null
+++ b/security/acme-client/files/extra-patch-GNUmakefile
@@ -0,0 +1,11 @@
+--- GNUmakefile.orig 2016-09-01 05:48:04 UTC
++++ GNUmakefile
+@@ -71,7 +71,7 @@ endif
+ all: acme-client
+
+ acme-client: $(OBJS)
+- $(CC) -o $@ $(OBJS) $(LDFLAGS) -ltls -lssl -lcrypto $(LIBBSD)
++ $(CC) -o $@ $(OBJS) $(LDFLAGS) ${PREFIX}/lib/libtls.a ${PREFIX}/lib/libssl.a ${PREFIX}/lib/libcrypto.a $(LIBBSD)
+
+ # This is for synchronising from -portable to the master.
+ rmerge: