aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2017-05-23 01:39:26 +0800
committerbdrewery <bdrewery@FreeBSD.org>2017-05-23 01:39:26 +0800
commitc4667a181bbdfe45550a19557dcc08fed920be9d (patch)
tree6c049c90557e8028dee25c350e2f692655b581b4
parenta0e52755712ca883b0faa10231d08133cecf1c22 (diff)
downloadfreebsd-ports-gnome-c4667a181bbdfe45550a19557dcc08fed920be9d.tar.gz
freebsd-ports-gnome-c4667a181bbdfe45550a19557dcc08fed920be9d.tar.zst
freebsd-ports-gnome-c4667a181bbdfe45550a19557dcc08fed920be9d.zip
Fix build when LOCALBASE is not /usr/local.
Reviewed by: brooks Sponsored by: Dell EMC Isilon Differential Revision: https://reviews.freebsd.org/D10859
-rw-r--r--devel/llvm-cheri/Makefile2
-rw-r--r--devel/llvm-devel/Makefile2
-rw-r--r--devel/llvm33/Makefile2
-rw-r--r--devel/llvm34/Makefile2
-rw-r--r--devel/llvm35/Makefile2
-rw-r--r--devel/llvm38/Makefile2
-rw-r--r--devel/llvm39/Makefile2
-rw-r--r--devel/llvm40/Makefile2
8 files changed, 16 insertions, 0 deletions
diff --git a/devel/llvm-cheri/Makefile b/devel/llvm-cheri/Makefile
index ca4701d7c6d4..4f938d9814c6 100644
--- a/devel/llvm-cheri/Makefile
+++ b/devel/llvm-cheri/Makefile
@@ -158,6 +158,8 @@ post-patch:
-e 's|from lit|from lit${LLVM_SUFFIX}|' \
-e 's|lit\.|lit${LLVM_SUFFIX}.|' \
${WRKSRC}/utils/lit/lit.py ${WRKSRC}/utils/lit/lit/*.py
+ ${REINPLACE_CMD} -e 's,/usr/local/,${LOCALBASE}/,' \
+ ${WRKSRC}/CMakeLists.txt
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/llvm-wrapper.sh \
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 80468f7ddb8f..b4f45a423154 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -314,6 +314,8 @@ post-patch:
-e 's|from lit|from lit${LLVM_SUFFIX}|' \
-e 's|lit\.|lit${LLVM_SUFFIX}.|' \
${WRKSRC}/utils/lit/lit.py ${WRKSRC}/utils/lit/lit/*.py
+ ${REINPLACE_CMD} -e 's,/usr/local/,${LOCALBASE}/,' \
+ ${WRKSRC}/CMakeLists.txt
post-build-COMPILER_RT-on:
${MKDIR} ${WRKDIR}/compiler-rt-build
diff --git a/devel/llvm33/Makefile b/devel/llvm33/Makefile
index a14725a8cfcf..58955b7eec6d 100644
--- a/devel/llvm33/Makefile
+++ b/devel/llvm33/Makefile
@@ -163,6 +163,8 @@ post-patch:
-e 's|from lit|from lit${LLVM_SUFFIX}|' \
-e 's|lit\.|lit${LLVM_SUFFIX}.|' \
${WRKSRC}/utils/lit/lit.py ${WRKSRC}/utils/lit/lit/*.py
+ ${REINPLACE_CMD} -e 's,/usr/local/,${LOCALBASE}/,' \
+ ${WRKSRC}/CMakeLists.txt
.if ${PORT_OPTIONS:MCMAKE}
post-configure:
diff --git a/devel/llvm34/Makefile b/devel/llvm34/Makefile
index ed12000ca551..e61b2e0b032c 100644
--- a/devel/llvm34/Makefile
+++ b/devel/llvm34/Makefile
@@ -168,6 +168,8 @@ post-patch:
-e 's|lit\.|lit${LLVM_SUFFIX}.|' \
${WRKSRC}/utils/lit/lit.py ${WRKSRC}/utils/lit/lit/*.py \
${WRKSRC}/utils/lit/lit/formats/*.py
+ ${REINPLACE_CMD} -e 's,/usr/local/,${LOCALBASE}/,' \
+ ${WRKSRC}/CMakeLists.txt
.if ${PORT_OPTIONS:MCMAKE}
post-configure:
diff --git a/devel/llvm35/Makefile b/devel/llvm35/Makefile
index ceb769dea9d3..c07ead8c3906 100644
--- a/devel/llvm35/Makefile
+++ b/devel/llvm35/Makefile
@@ -166,6 +166,8 @@ post-patch:
-e 's|lit\.|lit${LLVM_SUFFIX}.|' \
${WRKSRC}/utils/lit/lit.py ${WRKSRC}/utils/lit/lit/*.py \
${WRKSRC}/utils/lit/lit/formats/*.py
+ ${REINPLACE_CMD} -e 's,/usr/local/,${LOCALBASE}/,' \
+ ${WRKSRC}/CMakeLists.txt
.if ${PORT_OPTIONS:MCMAKE}
post-configure:
diff --git a/devel/llvm38/Makefile b/devel/llvm38/Makefile
index 3b6386ef968e..fe24c0ef0663 100644
--- a/devel/llvm38/Makefile
+++ b/devel/llvm38/Makefile
@@ -299,6 +299,8 @@ post-patch:
-e 's|from lit|from lit${LLVM_SUFFIX}|' \
-e 's|lit\.|lit${LLVM_SUFFIX}.|' \
${WRKSRC}/utils/lit/lit.py ${WRKSRC}/utils/lit/lit/*.py
+ ${REINPLACE_CMD} -e 's,/usr/local/,${LOCALBASE}/,' \
+ ${WRKSRC}/CMakeLists.txt
post-patch-COMPILER_RT-on:
cd ${WRKSRC_compiler_rt} && patch < ${PATCHDIR}/compiler-rt-patch-svn-261229
diff --git a/devel/llvm39/Makefile b/devel/llvm39/Makefile
index b95746dc61d3..b1ca63f4047a 100644
--- a/devel/llvm39/Makefile
+++ b/devel/llvm39/Makefile
@@ -332,6 +332,8 @@ post-patch:
-e 's|lit\.|lit${LLVM_SUFFIX}.|' \
${WRKSRC}/utils/lit/lit.py ${WRKSRC}/utils/lit/lit/*.py \
${WRKSRC}/utils/lit/lit/formats/*.py
+ ${REINPLACE_CMD} -e 's,/usr/local/,${LOCALBASE}/,' \
+ ${WRKSRC}/CMakeLists.txt
post-patch-CLANG-on:
${REINPLACE_CMD} -e 's|%%LLVM_PREFIX%%|${LLVM_PREFIX}|' \
diff --git a/devel/llvm40/Makefile b/devel/llvm40/Makefile
index c545468c5921..caa9749ea0bf 100644
--- a/devel/llvm40/Makefile
+++ b/devel/llvm40/Makefile
@@ -345,6 +345,8 @@ post-patch:
-e 's|lit\.|lit${LLVM_SUFFIX}.|' \
${WRKSRC}/utils/lit/lit.py ${WRKSRC}/utils/lit/lit/*.py \
${WRKSRC}/utils/lit/lit/formats/*.py
+ ${REINPLACE_CMD} -e 's,/usr/local/,${LOCALBASE}/,' \
+ ${WRKSRC}/CMakeLists.txt
post-patch-CLANG-on:
${REINPLACE_CMD} -e 's|%%LLVM_PREFIX%%|${LLVM_PREFIX}|' \