aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2016-12-02 03:03:50 +0800
committerjhale <jhale@FreeBSD.org>2016-12-02 03:03:50 +0800
commitc9b77dc055c9189f9654d4a6126490c216ffeb68 (patch)
treeaa0bfa43b2db4203e9a3534f90c03ac29c9ca1d9
parent4a6da4bc81fdc5925b60850a1c90361c1ac2fb88 (diff)
downloadfreebsd-ports-gnome-c9b77dc055c9189f9654d4a6126490c216ffeb68.tar.gz
freebsd-ports-gnome-c9b77dc055c9189f9654d4a6126490c216ffeb68.tar.zst
freebsd-ports-gnome-c9b77dc055c9189f9654d4a6126490c216ffeb68.zip
Update graphics/libopenraw to 0.1.0
Take maintainership Chase shared library bump and fix build with graphics/gegl
-rw-r--r--graphics/gegl/Makefile4
-rw-r--r--graphics/gegl/files/patch-operations_external_openraw.c13
-rw-r--r--graphics/libopenraw/Makefile31
-rw-r--r--graphics/libopenraw/distinfo5
-rw-r--r--graphics/libopenraw/files/patch-demo_ppmload.c11
-rw-r--r--graphics/libopenraw/files/patch-gnome_include_libopenraw-gnome_Makefile.in (renamed from graphics/libopenraw/files/patch-gnomeincludes)8
-rw-r--r--graphics/libopenraw/pkg-descr4
-rw-r--r--graphics/libopenraw/pkg-plist41
8 files changed, 71 insertions, 46 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index 80aba41de0ab..91934db422c9 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gegl
PORTVERSION= 0.2.0
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= graphics
MASTER_SITES= GIMP
@@ -216,7 +216,7 @@ post-patch:
${REINPLACE_CMD} -e 's|tools examples|tools|g' \
${WRKSRC}/Makefile.in
.endif
- ${REINPLACE_CMD} -e 's|\(lua\)\(5\.1\)|\1-\2|g ; s|x86_64|amd64|g' \
+ ${REINPLACE_CMD} -e 's|\(lua\)\(5\.1\)|\1-\2|g ; s|x86_64|amd64|g ; s|libopenraw-1.0|libopenraw-0.1|g' \
${WRKSRC}/configure
.if ${PORT_OPTIONS:MDOCS}
diff --git a/graphics/gegl/files/patch-operations_external_openraw.c b/graphics/gegl/files/patch-operations_external_openraw.c
new file mode 100644
index 000000000000..8cd62e3c9ad3
--- /dev/null
+++ b/graphics/gegl/files/patch-operations_external_openraw.c
@@ -0,0 +1,13 @@
+OR_DATA_TYPE_CFA was replaced by OR_DATA_TYPE_RAW in libopenraw-0.1.0
+
+--- operations/external/openraw.c.orig 2016-12-01 05:57:23 UTC
++++ operations/external/openraw.c
+@@ -116,7 +116,7 @@ load_buffer (GeglOperation *operation)
+ goto clean_file;
+ }
+
+- if(or_rawdata_format (rawdata) != OR_DATA_TYPE_CFA)
++ if(or_rawdata_format (rawdata) != OR_DATA_TYPE_RAW)
+ {
+ goto clean_file;
+ }
diff --git a/graphics/libopenraw/Makefile b/graphics/libopenraw/Makefile
index 1bb8330c3740..c9e3595fe2bd 100644
--- a/graphics/libopenraw/Makefile
+++ b/graphics/libopenraw/Makefile
@@ -2,42 +2,39 @@
# $FreeBSD$
PORTNAME= libopenraw
-PORTVERSION= 0.0.9
-PORTREVISION= 4
+PORTVERSION= 0.1.0
CATEGORIES= graphics
MASTER_SITES= http://libopenraw.freedesktop.org/download/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jhale@FreeBSD.org
COMMENT= Library for camera RAW files decoding
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
-LIB_DEPENDS= libboost_thread.so:devel/boost-libs
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/variant.hpp:devel/boost-libs
-USES= compiler:c++11-lang jpeg libtool localbase pkgconfig tar:bzip2
+USES= compiler:c++11-lib jpeg libtool localbase pkgconfig tar:bz2
USE_GNOME= libxml2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-boost=${LOCALBASE}/include
-MAKE_ENV= V=1
+CONFIGURE_ARGS= --with-boost=${LOCALBASE}/include \
+ --disable-silent-rules
+INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= GNOME
+# Unhide SEEK_SET to fix build with GCC 4.9 (ports/193528).
+CXXFLAGS+= -D_GLIBCXX_USE_C99
+
+OPTIONS_DEFINE= GNOME
OPTIONS_DEFAULT= GNOME
+OPTIONS_SUB= yes
-OPTIONS_SUB= yes
GNOME_CONFIGURE_ENABLE= gnome
-GNOME_USE= GNOME=glib20,gdkpixbuf2
+GNOME_USES= gettext-runtime
+GNOME_USE= GNOME=glib20,gdkpixbuf2
post-patch:
@${REINPLACE_CMD} -e 's|{libdir}/pkgconfig|{prefix}/libdata/pkgconfig|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|testsuite ||' ${WRKSRC}/Makefile.in
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libopenraw.so
-
-post-install-GNOME-on:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libopenrawgnome.so
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gdk-pixbuf-2.0/${GTK2_VERSION}/loaders/libopenraw_pixbuf.so
-
.include <bsd.port.mk>
diff --git a/graphics/libopenraw/distinfo b/graphics/libopenraw/distinfo
index 2bba4accd1ae..443db7e654b2 100644
--- a/graphics/libopenraw/distinfo
+++ b/graphics/libopenraw/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libopenraw-0.0.9.tar.bz2) = 49fd1adf0a0228c7a17a79bf98d8d03664195feae1e50f4ddd1b20162626e18f
-SIZE (libopenraw-0.0.9.tar.bz2) = 478687
+TIMESTAMP = 1480563957
+SHA256 (libopenraw-0.1.0.tar.bz2) = 4dede1db9b85c9c22a1ddaf37839f2713746a00b81a6d4623d66556000cb76cf
+SIZE (libopenraw-0.1.0.tar.bz2) = 525449
diff --git a/graphics/libopenraw/files/patch-demo_ppmload.c b/graphics/libopenraw/files/patch-demo_ppmload.c
new file mode 100644
index 000000000000..03b33f4aa355
--- /dev/null
+++ b/graphics/libopenraw/files/patch-demo_ppmload.c
@@ -0,0 +1,11 @@
+--- demo/ppmload.c.orig 2016-01-24 18:35:23 UTC
++++ demo/ppmload.c
+@@ -30,6 +30,8 @@
+ # include <machine/endian.h>
+ # include <libkern/OSByteOrder.h>
+ # define htobe16(x) OSSwapHostToBigInt16(x)
++#elif defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__DragonFly__)
++# include <sys/endian.h>
+ #else
+ # include <endian.h>
+ #endif
diff --git a/graphics/libopenraw/files/patch-gnomeincludes b/graphics/libopenraw/files/patch-gnome_include_libopenraw-gnome_Makefile.in
index 090acf8694fd..54b17d96c699 100644
--- a/graphics/libopenraw/files/patch-gnomeincludes
+++ b/graphics/libopenraw/files/patch-gnome_include_libopenraw-gnome_Makefile.in
@@ -1,6 +1,6 @@
---- gnome/include/libopenraw-gnome/Makefile.in.orig Tue Jan 9 00:28:06 2007
-+++ gnome/include/libopenraw-gnome/Makefile.in Wed Mar 21 14:51:32 2007
-@@ -371,7 +371,8 @@
+--- gnome/include/libopenraw-gnome/Makefile.in.orig 2016-11-27 01:53:40 UTC
++++ gnome/include/libopenraw-gnome/Makefile.in
+@@ -529,7 +529,8 @@ info: info-am
info-am:
@@ -8,5 +8,5 @@
+@BUILD_GNOME_SUPPORT_TRUE@install-data-am: install-libopenrawgnomeHEADERS
+@BUILD_GNOME_SUPPORT_FALSE@install-data-am:
- install-exec-am:
+ install-dvi: install-dvi-am
diff --git a/graphics/libopenraw/pkg-descr b/graphics/libopenraw/pkg-descr
index 225b1a3300ad..c6113f20bd71 100644
--- a/graphics/libopenraw/pkg-descr
+++ b/graphics/libopenraw/pkg-descr
@@ -1,6 +1,6 @@
libopenraw is an ongoing project to provide a free software implementation for
-camera RAW files decoding. One of the main reason is that dcraw is not suited
+camera RAW files decoding. One of the main reasons is that dcraw is not suited
for easy integration into applications, and there is a need for an easy to use
-API to build free software digital image processing application.
+API to build free software digital image processing applications.
WWW: http://libopenraw.freedesktop.org/
diff --git a/graphics/libopenraw/pkg-plist b/graphics/libopenraw/pkg-plist
index bd9d0fe8283e..3e391379ed11 100644
--- a/graphics/libopenraw/pkg-plist
+++ b/graphics/libopenraw/pkg-plist
@@ -1,25 +1,28 @@
-include/libopenraw-1.0/libopenraw/bitmapdata.h
-include/libopenraw-1.0/libopenraw/consts.h
-include/libopenraw-1.0/libopenraw/debug.h
-include/libopenraw-1.0/libopenraw/demosaic.h
-include/libopenraw-1.0/libopenraw/exif.h
-include/libopenraw-1.0/libopenraw/io.h
-include/libopenraw-1.0/libopenraw/libopenraw.h
-include/libopenraw-1.0/libopenraw/metadata.h
-include/libopenraw-1.0/libopenraw/rawdata.h
-include/libopenraw-1.0/libopenraw/rawfile.h
-include/libopenraw-1.0/libopenraw/thumbnails.h
-include/libopenraw-1.0/libopenraw/types.h
-%%GNOME%%include/libopenraw-1.0/libopenraw-gnome/gdkpixbuf.h
+%%GNOME%%include/libopenraw-0.1/libopenraw-gnome/gdkpixbuf.h
+include/libopenraw-0.1/libopenraw/bitmapdata.h
+include/libopenraw-0.1/libopenraw/cameraids.h
+include/libopenraw-0.1/libopenraw/cfapattern.h
+include/libopenraw-0.1/libopenraw/consts.h
+include/libopenraw-0.1/libopenraw/debug.h
+include/libopenraw-0.1/libopenraw/demosaic.h
+include/libopenraw-0.1/libopenraw/exif.h
+include/libopenraw-0.1/libopenraw/io.h
+include/libopenraw-0.1/libopenraw/libopenraw.h
+include/libopenraw-0.1/libopenraw/metadata.h
+include/libopenraw-0.1/libopenraw/prefix.h
+include/libopenraw-0.1/libopenraw/rawdata.h
+include/libopenraw-0.1/libopenraw/rawfile.h
+include/libopenraw-0.1/libopenraw/thumbnails.h
+include/libopenraw-0.1/libopenraw/types.h
%%GNOME%%lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%/loaders/libopenraw_pixbuf.a
%%GNOME%%lib/gdk-pixbuf-2.0/%%GTK2_VERSION%%/loaders/libopenraw_pixbuf.so
lib/libopenraw.a
lib/libopenraw.so
-lib/libopenraw.so.1
-lib/libopenraw.so.1.6.0
+lib/libopenraw.so.7
+lib/libopenraw.so.7.0.0
%%GNOME%%lib/libopenrawgnome.a
%%GNOME%%lib/libopenrawgnome.so
-%%GNOME%%lib/libopenrawgnome.so.1
-%%GNOME%%lib/libopenrawgnome.so.1.6.0
-libdata/pkgconfig/libopenraw-1.0.pc
-%%GNOME%%libdata/pkgconfig/libopenraw-gnome-1.0.pc
+%%GNOME%%lib/libopenrawgnome.so.7
+%%GNOME%%lib/libopenrawgnome.so.7.0.0
+libdata/pkgconfig/libopenraw-0.1.pc
+%%GNOME%%libdata/pkgconfig/libopenraw-gnome-0.1.pc