aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-07-10 14:58:16 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-07-10 14:58:16 +0800
commitcb0741665b5d230686ff94d805978b857e166954 (patch)
treef2016fc8f24ba2f141152cf89319de92a547ebd5
parentc3c9ace5e1b18e5f9c4326adaafaa44f25aa036f (diff)
downloadfreebsd-ports-gnome-cb0741665b5d230686ff94d805978b857e166954.tar.gz
freebsd-ports-gnome-cb0741665b5d230686ff94d805978b857e166954.tar.zst
freebsd-ports-gnome-cb0741665b5d230686ff94d805978b857e166954.zip
- Add p5-Astro-Flux 0.01
Astro::Flux provides a class for handling astronomical flux quantities. This class does not currently support conversions from one flux type to another (say, from magnitudes to Janskies) but may in the future. WWW: http://search.cpan.org/dist/Astro-Flux/
-rw-r--r--astro/Makefile1
-rw-r--r--astro/p5-Astro-Flux/Makefile29
-rw-r--r--astro/p5-Astro-Flux/distinfo2
-rw-r--r--astro/p5-Astro-Flux/pkg-descr5
-rw-r--r--astro/p5-Astro-Flux/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 035f6d20afa8..0c6933056f16 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -56,6 +56,7 @@
SUBDIR += p5-Astro-DSS
SUBDIR += p5-Astro-FITS-CFITSIO
SUBDIR += p5-Astro-FITS-Header
+ SUBDIR += p5-Astro-Flux
SUBDIR += p5-Astro-Hipparcos
SUBDIR += p5-Astro-MoonPhase
SUBDIR += p5-Astro-SIMBAD
diff --git a/astro/p5-Astro-Flux/Makefile b/astro/p5-Astro-Flux/Makefile
new file mode 100644
index 000000000000..3ed8dfe12231
--- /dev/null
+++ b/astro/p5-Astro-Flux/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Astro-Flux
+# Date created: 2012-07-01
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Astro-Flux
+PORTVERSION= 0.01
+CATEGORIES= astro perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Class for handling astronomical flux quantities
+
+BUILD_DEPENDS= p5-Astro-WaveBand>=0:${PORTSDIR}/astro/p5-Astro-WaveBand \
+ p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-Misc-Quality>=0:${PORTSDIR}/astro/p5-Misc-Quality \
+ p5-Number-Uncertainty>=0:${PORTSDIR}/math/p5-Number-Uncertainty
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Astro::Flux.3 \
+ Astro::FluxColor.3 \
+ Astro::Fluxes.3
+
+.include <bsd.port.mk>
diff --git a/astro/p5-Astro-Flux/distinfo b/astro/p5-Astro-Flux/distinfo
new file mode 100644
index 000000000000..30493b4221a4
--- /dev/null
+++ b/astro/p5-Astro-Flux/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Astro-Flux-0.01.tar.gz) = 33654b89299a1d250a792075126c648420e36ca003f5171d6f59ed4ceb03881b
+SIZE (Astro-Flux-0.01.tar.gz) = 9714
diff --git a/astro/p5-Astro-Flux/pkg-descr b/astro/p5-Astro-Flux/pkg-descr
new file mode 100644
index 000000000000..f7dbf361527d
--- /dev/null
+++ b/astro/p5-Astro-Flux/pkg-descr
@@ -0,0 +1,5 @@
+Astro::Flux provides a class for handling astronomical flux quantities. This
+class does not currently support conversions from one flux type to another (say,
+from magnitudes to Janskies) but may in the future.
+
+WWW: http://search.cpan.org/dist/Astro-Flux/
diff --git a/astro/p5-Astro-Flux/pkg-plist b/astro/p5-Astro-Flux/pkg-plist
new file mode 100644
index 000000000000..03ccce6b804b
--- /dev/null
+++ b/astro/p5-Astro-Flux/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Astro/Flux.pm
+%%SITE_PERL%%/Astro/FluxColor.pm
+%%SITE_PERL%%/Astro/Fluxes.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/Flux/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/Flux
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro
+@dirrmtry %%SITE_PERL%%/Astro