aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2018-09-24 21:45:55 +0800
committerwen <wen@FreeBSD.org>2018-09-24 21:45:55 +0800
commitd186b4bce9aa28b86027e5da1b3dc0b604d4e293 (patch)
tree5d9a90c42e845430b8d0cdb1b73b064010f93c68
parent7fdbdfa3c1cce00741e0d3948652ba647a56aeb4 (diff)
downloadfreebsd-ports-gnome-d186b4bce9aa28b86027e5da1b3dc0b604d4e293.tar.gz
freebsd-ports-gnome-d186b4bce9aa28b86027e5da1b3dc0b604d4e293.tar.zst
freebsd-ports-gnome-d186b4bce9aa28b86027e5da1b3dc0b604d4e293.zip
- Update to 2018.3.2
- Fix the py3 loader issue PR: 231609 Submitted by: christer.edwards@gmail.com(maintainer)
-rw-r--r--sysutils/py-salt/Makefile3
-rw-r--r--sysutils/py-salt/distinfo6
-rw-r--r--sysutils/py-salt/files/patch-salt_loader.py11
3 files changed, 15 insertions, 5 deletions
diff --git a/sysutils/py-salt/Makefile b/sysutils/py-salt/Makefile
index ada3db8bed17..aa995f126e5c 100644
--- a/sysutils/py-salt/Makefile
+++ b/sysutils/py-salt/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= salt
-PORTVERSION= 2018.3.1
-PORTREVISION= 0
+PORTVERSION= 2018.3.2
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/sysutils/py-salt/distinfo b/sysutils/py-salt/distinfo
index 6b52bc1f244e..d36ae888daac 100644
--- a/sysutils/py-salt/distinfo
+++ b/sysutils/py-salt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1528982610
-SHA256 (salt-2018.3.1.tar.gz) = 7b1d59067b8eb61a23884078e0b8afc02ed8800c5c00f09405ae9e03491ed3db
-SIZE (salt-2018.3.1.tar.gz) = 12939682
+TIMESTAMP = 1534903119
+SHA256 (salt-2018.3.2.tar.gz) = d86eeea2e5387f4a64bbf0a11d103bfc8aac1122e19d39cc0945d33efdc797bd
+SIZE (salt-2018.3.2.tar.gz) = 12996445
diff --git a/sysutils/py-salt/files/patch-salt_loader.py b/sysutils/py-salt/files/patch-salt_loader.py
new file mode 100644
index 000000000000..1578e73b9df7
--- /dev/null
+++ b/sysutils/py-salt/files/patch-salt_loader.py
@@ -0,0 +1,11 @@
+--- salt/loader.py
++++ salt/loader.py
+@@ -1240,7 +1240,7 @@
+ try:
+ pycache_files = [
+ os.path.join('__pycache__', x) for x in
+- sorted(os.listdir(os.path.join(mod_dir, '__pycache__')))
++ sorted(os.listdir(os.path.join(mod_dir, '__pycache__'))) if not x.endswith('opt-1.pyc') and not x.endswith('opt-2.pyc')
+ ]
+ except OSError:
+ pass