aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-14 14:33:57 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-14 14:33:57 +0800
commitedb0277ace7f452963190c515dc65b015828b794 (patch)
treefb041e70c75a6427d72125889df0096b1c3e36bd
parent4133c2f460fb278c41bfc012f0b46cfa1c536ee1 (diff)
downloadfreebsd-ports-gnome-edb0277ace7f452963190c515dc65b015828b794.tar.gz
freebsd-ports-gnome-edb0277ace7f452963190c515dc65b015828b794.tar.zst
freebsd-ports-gnome-edb0277ace7f452963190c515dc65b015828b794.zip
Mark some ports failing on various tier-2 archs. In cases where the
error message was a stub, provide a real one. While here, pet portlint. This is a catchup commit from various earlier commits. Approved by: portmgr (tier-2 blanket)
-rw-r--r--comms/telldus-core/Makefile2
-rw-r--r--games/netradiant/Makefile1
-rw-r--r--games/stockfish/Makefile1
-rw-r--r--net/mpich2/Makefile2
-rw-r--r--sysutils/showbeastie/Makefile3
5 files changed, 8 insertions, 1 deletions
diff --git a/comms/telldus-core/Makefile b/comms/telldus-core/Makefile
index 299c20bca7bf..1984a6f9dfec 100644
--- a/comms/telldus-core/Makefile
+++ b/comms/telldus-core/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libftdi.so:devel/libftdi \
libargp.so:devel/argp-standalone
BROKEN_powerpc64= Does not build: error: strlen was not declared in this scope
-BROKEN_sparc64= Does not build
+BROKEN_sparc64= Does not build: error: strlen was not declared in this scope
USES= cmake compiler:c++11-lang iconv:wchar_t
diff --git a/games/netradiant/Makefile b/games/netradiant/Makefile
index 1155c3c83fae..d68058cb341f 100644
--- a/games/netradiant/Makefile
+++ b/games/netradiant/Makefile
@@ -33,6 +33,7 @@ SUB_LIST= ARCH=${ARCH}
PLIST_SUB:= ${SUB_LIST}
BROKEN_aarch64= Fails to link: ldd: install/modules/archivepak.so: not a FreeBSD ELF shared object
+BROKEN_armv6= Fails to build: h2data.armv6: No such file or directory
post-patch:
# Add missing checks for __FreeBSD__
diff --git a/games/stockfish/Makefile b/games/stockfish/Makefile
index 3b972c86a741..b39647f80c76 100644
--- a/games/stockfish/Makefile
+++ b/games/stockfish/Makefile
@@ -18,6 +18,7 @@ LICENSE= GPLv3
NOT_FOR_ARCHS= sparc64
BROKEN_aarch64= Fails to build: cannot detect architecture
+BROKEN_armv6= Fails to configure: config-sanity: Error 1
BROKEN_mips64= Fails to build: cannot detect architecture
USES= compiler gmake zip
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index 009a720f43e0..32c20c6c91e2 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -28,6 +28,8 @@ USE_LDCONFIG= yes
USE_PERL5= build
INSTALL_TARGET= install-strip
+BROKEN_armv6= fails to detect working compiler: undefined reference to _Unwind_GetIP@GCC_3.0
+
OPTIONS_DEFINE_i386= JAVA
OPTIONS_DEFINE_amd64= JAVA
OPTIONS_DEFINE= SMPD X11 DOCS
diff --git a/sysutils/showbeastie/Makefile b/sysutils/showbeastie/Makefile
index e82ed17cd9ee..aaba28da186f 100644
--- a/sysutils/showbeastie/Makefile
+++ b/sysutils/showbeastie/Makefile
@@ -25,6 +25,9 @@ PLIST_FILES= bin/${PORTNAME}
# Make sure building succeeds on HEAD
MAKE_ARGS+= -m ${SRC_BASE}/share/mk
+BROKEN_armv6= fails to link: testmain uses VFP register arguments, dict.o does not
+BROKEN_mips64= fails to link: relocation truncated to fit: R_MIPS_26 against `__assert@@FBSD_1.0'
+
WRKSRC_SUBDIR= ficl
pre-patch: