aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-03-30 08:48:55 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-03-30 08:48:55 +0800
commitedddab90352ddd53f814972160780839cb2263d4 (patch)
treec9a0e71782565283f233309be28a67d1d21e4799
parenteb0a019a2b46e3eeb5bfff438ae915517ab682e2 (diff)
downloadfreebsd-ports-gnome-edddab90352ddd53f814972160780839cb2263d4.tar.gz
freebsd-ports-gnome-edddab90352ddd53f814972160780839cb2263d4.tar.zst
freebsd-ports-gnome-edddab90352ddd53f814972160780839cb2263d4.zip
- Add LICENSE
- Switch to options helpers - Regenerate patches with `make makepatch`
-rw-r--r--devel/zthread/Makefile13
-rw-r--r--devel/zthread/files/patch-include__zthread__Barrier.h8
-rw-r--r--devel/zthread/files/patch-include__zthread__BlockingQueue.h6
-rw-r--r--devel/zthread/files/patch-include__zthread__Guard.h12
-rw-r--r--devel/zthread/files/patch-src__MutexImpl.h22
-rw-r--r--devel/zthread/files/patch-src__ThreadQueue.cxx6
6 files changed, 36 insertions, 31 deletions
diff --git a/devel/zthread/Makefile b/devel/zthread/Makefile
index e7ab08f1f30f..28e656876797 100644
--- a/devel/zthread/Makefile
+++ b/devel/zthread/Makefile
@@ -11,16 +11,19 @@ DISTNAME= ZThread-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Platform-independent object-oriented C++ threading library
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= gmake libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-ftime --disable-static
-MAKE_ARGS+= INSTALL_PROGRAM="${INSTALL_SCRIPT}"
+MAKE_ARGS= INSTALL_PROGRAM="${INSTALL_SCRIPT}"
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOCS
-
PORTDOCS= AUTHORS ChangeLog NEWS README TODO
+OPTIONS_DEFINE= DOCS
+
post-extract:
@${FIND} ${WRKSRC} -name CVS -type d -delete
@@ -30,8 +33,10 @@ post-patch:
${WRKSRC}/Makefile.in
post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libZThread.so
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libZThread.so
.include <bsd.port.mk>
diff --git a/devel/zthread/files/patch-include__zthread__Barrier.h b/devel/zthread/files/patch-include__zthread__Barrier.h
index fc575162096b..b11590a22c63 100644
--- a/devel/zthread/files/patch-include__zthread__Barrier.h
+++ b/devel/zthread/files/patch-include__zthread__Barrier.h
@@ -1,6 +1,6 @@
---- ./include/zthread/Barrier.h.orig 2005-03-13 00:23:00.000000000 -0500
-+++ ./include/zthread/Barrier.h 2009-04-23 15:03:09.000000000 -0400
-@@ -150,7 +150,7 @@
+--- include/zthread/Barrier.h.orig 2005-03-13 05:23:00 UTC
++++ include/zthread/Barrier.h
+@@ -150,7 +150,7 @@ namespace ZThread {
} else {
@@ -9,7 +9,7 @@
try {
-@@ -251,7 +251,7 @@
+@@ -251,7 +251,7 @@ namespace ZThread {
} else {
diff --git a/devel/zthread/files/patch-include__zthread__BlockingQueue.h b/devel/zthread/files/patch-include__zthread__BlockingQueue.h
index 39fa120745e1..c620bb292886 100644
--- a/devel/zthread/files/patch-include__zthread__BlockingQueue.h
+++ b/devel/zthread/files/patch-include__zthread__BlockingQueue.h
@@ -1,6 +1,6 @@
---- ./include/zthread/BlockingQueue.h.orig 2005-03-12 21:04:18.000000000 -0500
-+++ ./include/zthread/BlockingQueue.h 2009-04-23 15:03:09.000000000 -0400
-@@ -83,7 +83,7 @@
+--- include/zthread/BlockingQueue.h.orig 2005-03-13 02:04:18 UTC
++++ include/zthread/BlockingQueue.h
+@@ -83,7 +83,7 @@ namespace ZThread {
/**
* @see Queue::add(const T& item, unsigned long timeout)
*/
diff --git a/devel/zthread/files/patch-include__zthread__Guard.h b/devel/zthread/files/patch-include__zthread__Guard.h
index 72fc2231a717..b26fead5eae1 100644
--- a/devel/zthread/files/patch-include__zthread__Guard.h
+++ b/devel/zthread/files/patch-include__zthread__Guard.h
@@ -1,6 +1,6 @@
---- ./include/zthread/Guard.h.orig 2005-03-12 21:10:09.000000000 -0500
-+++ ./include/zthread/Guard.h 2013-01-17 13:50:40.000000000 -0500
-@@ -108,7 +108,7 @@
+--- include/zthread/Guard.h.orig 2005-03-13 02:10:09 UTC
++++ include/zthread/Guard.h
+@@ -108,7 +108,7 @@ class CompoundScope {
}
template <class LockType>
@@ -9,7 +9,7 @@
if(Scope1::createScope(l, ms))
if(!Scope2::createScope(l, ms)) {
-@@ -428,7 +428,7 @@
+@@ -428,7 +428,7 @@ public:
template <class U, class V>
Guard(Guard<U, V>& g) : LockHolder<LockType>(g) {
@@ -18,7 +18,7 @@
}
-@@ -458,7 +458,7 @@
+@@ -458,7 +458,7 @@ public:
template <class U, class V>
Guard(Guard<U, V>& g, LockType& lock) : LockHolder<LockType>(lock) {
@@ -27,7 +27,7 @@
}
-@@ -491,7 +491,7 @@
+@@ -491,7 +491,7 @@ Guard<LockType, LockingPolicy>::~Guard()
try {
diff --git a/devel/zthread/files/patch-src__MutexImpl.h b/devel/zthread/files/patch-src__MutexImpl.h
index 3f4de57d0a62..ca268437524e 100644
--- a/devel/zthread/files/patch-src__MutexImpl.h
+++ b/devel/zthread/files/patch-src__MutexImpl.h
@@ -1,6 +1,6 @@
---- ./src/MutexImpl.h.orig 2005-03-12 22:59:15.000000000 -0500
-+++ ./src/MutexImpl.h 2009-04-23 15:03:09.000000000 -0400
-@@ -153,7 +153,7 @@
+--- src/MutexImpl.h.orig 2005-03-13 03:59:15 UTC
++++ src/MutexImpl.h
+@@ -153,7 +153,7 @@ void MutexImpl<List, Behavior>::acquire(
_owner = self;
@@ -9,7 +9,7 @@
}
-@@ -164,7 +164,7 @@
+@@ -164,7 +164,7 @@ void MutexImpl<List, Behavior>::acquire(
_waiters.insert(self);
m.acquire();
@@ -18,7 +18,7 @@
{
-@@ -173,7 +173,7 @@
+@@ -173,7 +173,7 @@ void MutexImpl<List, Behavior>::acquire(
}
@@ -27,7 +27,7 @@
m.release();
-@@ -192,7 +192,7 @@
+@@ -192,7 +192,7 @@ void MutexImpl<List, Behavior>::acquire(
assert(_owner == 0);
_owner = self;
@@ -36,7 +36,7 @@
break;
-@@ -236,7 +236,7 @@
+@@ -236,7 +236,7 @@ bool MutexImpl<List, Behavior>::tryAcqui
_owner = self;
@@ -45,7 +45,7 @@
}
-@@ -253,7 +253,7 @@
+@@ -253,7 +253,7 @@ bool MutexImpl<List, Behavior>::tryAcqui
m.acquire();
@@ -54,7 +54,7 @@
{
-@@ -262,7 +262,7 @@
+@@ -262,7 +262,7 @@ bool MutexImpl<List, Behavior>::tryAcqui
}
@@ -63,7 +63,7 @@
m.release();
-@@ -284,7 +284,7 @@
+@@ -284,7 +284,7 @@ bool MutexImpl<List, Behavior>::tryAcqui
assert(0 == _owner);
_owner = self;
@@ -72,7 +72,7 @@
break;
-@@ -326,7 +326,7 @@
+@@ -326,7 +326,7 @@ void MutexImpl<List, Behavior>::release(
_owner = 0;
diff --git a/devel/zthread/files/patch-src__ThreadQueue.cxx b/devel/zthread/files/patch-src__ThreadQueue.cxx
index e13f2c64fc28..b215d159fa78 100644
--- a/devel/zthread/files/patch-src__ThreadQueue.cxx
+++ b/devel/zthread/files/patch-src__ThreadQueue.cxx
@@ -1,6 +1,6 @@
---- ./src/ThreadQueue.cxx.orig 2005-03-12 22:55:23.000000000 -0500
-+++ ./src/ThreadQueue.cxx 2013-01-17 13:48:32.000000000 -0500
-@@ -139,11 +139,12 @@
+--- src/ThreadQueue.cxx.orig 2005-03-13 03:55:23 UTC
++++ src/ThreadQueue.cxx
+@@ -139,11 +139,12 @@ namespace ZThread {
// Wake the main thread,if its waiting, when the last pending-thread becomes available;
// Otherwise, take note that no wait for pending threads to finish is needed