aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2011-08-30 22:47:15 +0800
committerolgeni <olgeni@FreeBSD.org>2011-08-30 22:47:15 +0800
commit000fe6ea8e511fb2e0684bddc1cf18e6428d00ed (patch)
tree0deff1ecee19a120a76b6664e2f91ee7a17b290c
parent29d66dbf566e664781adee13749ed9bf289d029b (diff)
downloadfreebsd-ports-gnome-000fe6ea8e511fb2e0684bddc1cf18e6428d00ed.tar.gz
freebsd-ports-gnome-000fe6ea8e511fb2e0684bddc1cf18e6428d00ed.tar.zst
freebsd-ports-gnome-000fe6ea8e511fb2e0684bddc1cf18e6428d00ed.zip
Add markdown-mode.el: an Emacs major mode for editing Markdown-formatted
text files.
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/markdown-mode.el/Makefile35
-rw-r--r--textproc/markdown-mode.el/distinfo2
-rw-r--r--textproc/markdown-mode.el/pkg-descr4
-rw-r--r--textproc/markdown-mode.el/pkg-message12
-rw-r--r--textproc/markdown-mode.el/pkg-plist2
6 files changed, 56 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e4a51791332b..970f2062f27b 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -412,6 +412,7 @@
SUBDIR += man2html
SUBDIR += manued.el
SUBDIR += markdown
+ SUBDIR += markdown-mode.el
SUBDIR += mathml-xsd
SUBDIR += mdocml
SUBDIR += meld
diff --git a/textproc/markdown-mode.el/Makefile b/textproc/markdown-mode.el/Makefile
new file mode 100644
index 000000000000..e8fded987a3b
--- /dev/null
+++ b/textproc/markdown-mode.el/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: markdown-mode.el
+# Date created: 30 Ago 2011
+# Whom: olgeni@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= markdown-mode.el
+PORTVERSION= 1.8.1
+CATEGORIES= textproc
+MASTER_SITES= http://jblevins.org/projects/markdown-mode/
+DISTNAME= markdown-mode.el
+EXTRACT_SUFX= # empty
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+EXTRACT_ONLY= # empty
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Emacs/XEmacs major mode for editing Markdown-formatted text
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
+
+do-install:
+ @${MKDIR} ${EMACSLISPDIR}
+ @${MKDIR} ${XEMACSLISPDIR}
+ @${INSTALL_DATA} ${_DISTDIR}/${DISTNAME} ${EMACSLISPDIR}/markdown-mode.el
+ @${LN} -sf ${EMACSLISPDIR}/markdown-mode.el ${XEMACSLISPDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/textproc/markdown-mode.el/distinfo b/textproc/markdown-mode.el/distinfo
new file mode 100644
index 000000000000..97dc3af51183
--- /dev/null
+++ b/textproc/markdown-mode.el/distinfo
@@ -0,0 +1,2 @@
+SHA256 (markdown-mode.el-1.8.1/markdown-mode.el) = ea606dff279df0f804ac6cc849248ca85c41065bbac728b7976b9f4279289f33
+SIZE (markdown-mode.el-1.8.1/markdown-mode.el) = 75777
diff --git a/textproc/markdown-mode.el/pkg-descr b/textproc/markdown-mode.el/pkg-descr
new file mode 100644
index 000000000000..90752f6ce0ce
--- /dev/null
+++ b/textproc/markdown-mode.el/pkg-descr
@@ -0,0 +1,4 @@
+markdown-mode is a major mode for editing Markdown-formatted
+text files in GNU Emacs.
+
+WWW: http://jblevins.org/projects/markdown-mode/
diff --git a/textproc/markdown-mode.el/pkg-message b/textproc/markdown-mode.el/pkg-message
new file mode 100644
index 000000000000..a8330d28466f
--- /dev/null
+++ b/textproc/markdown-mode.el/pkg-message
@@ -0,0 +1,12 @@
+========================================================================
+
+To use markdown-mode in Emacs/XEmacs, add the following lines to
+your ~/.emacs replacing "text" with your preferred markdown extension.
+
+(autoload 'markdown-mode "markdown-mode.el"
+ "Major mode for editing Markdown files" t)
+
+(setq auto-mode-alist
+ (cons '("\\.text" . markdown-mode) auto-mode-alist))
+
+========================================================================
diff --git a/textproc/markdown-mode.el/pkg-plist b/textproc/markdown-mode.el/pkg-plist
new file mode 100644
index 000000000000..72a0a78d874e
--- /dev/null
+++ b/textproc/markdown-mode.el/pkg-plist
@@ -0,0 +1,2 @@
+%%LIB32DIR%%/xemacs/site-lisp/markdown-mode.el
+share/emacs/site-lisp/markdown-mode.el