aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwollman <wollman@FreeBSD.org>2001-03-15 03:10:51 +0800
committerwollman <wollman@FreeBSD.org>2001-03-15 03:10:51 +0800
commit00f25100d75012ba0a3cf95da6bc8b77067ad076 (patch)
tree1b9b31c3dc6e54e0b317a779d1e00ace8f595e34
parent3281af9b2c51b4d670231dab945f29c061eafd5b (diff)
downloadfreebsd-ports-gnome-00f25100d75012ba0a3cf95da6bc8b77067ad076.tar.gz
freebsd-ports-gnome-00f25100d75012ba0a3cf95da6bc8b77067ad076.tar.zst
freebsd-ports-gnome-00f25100d75012ba0a3cf95da6bc8b77067ad076.zip
With great trepidation, stick my neck into the MAINTAINERship noose
by introducing a port of the FreeRADIUS project's RADIUS server, currently labeled ``alpha''. The distfile is locally hosted so I don't have to go chasing snapshots. (N.B.: I don't know whether this actually works yet -- but it does compile and package!)
-rw-r--r--net/Makefile1
-rw-r--r--net/freeradius-devel/Makefile75
-rw-r--r--net/freeradius-devel/distinfo1
-rw-r--r--net/freeradius-devel/files/patch-aa13
-rw-r--r--net/freeradius-devel/files/patch-ab10
-rw-r--r--net/freeradius-devel/pkg-comment1
-rw-r--r--net/freeradius-devel/pkg-descr6
-rw-r--r--net/freeradius-devel/pkg-plist46
8 files changed, 153 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 9ec076bcd86f..1c8ba75e7326 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -87,6 +87,7 @@
SUBDIR += flow-tools
SUBDIR += flowscan
SUBDIR += fping
+ SUBDIR += freeradius-devel
SUBDIR += freewais-sf
SUBDIR += fspclient
SUBDIR += fugu
diff --git a/net/freeradius-devel/Makefile b/net/freeradius-devel/Makefile
new file mode 100644
index 000000000000..5bcfe1f5624d
--- /dev/null
+++ b/net/freeradius-devel/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: freeradius-devel
+# Date created: 2001-03-13
+# Whom: wollman@lcs.mit.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= freeradius-devel
+PORTVERSION= 20010310
+CATEGORIES= net
+# Copied from ftp://ftp.freeradius.org/pub/radius/CVS-snapshots/
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR=wollman
+DISTNAME= freeradius-alpha-snapshot-${PORTVERSION}
+
+MAINTAINER= wollman@lcs.mit.edu
+
+WRKSRC= ${WRKDIR}/freeradius-alpha-snapshot-${PORTVERSION}
+
+USE_AUTOCONF= YES
+USE_LIBTOOL= YES
+USE_GMAKE= YES
+
+MAN1= radlast.1 radtest.1 raduse.1 radwho.1 radzap.1
+MAN5= acct_users.5 clients.5 dictionary.5 naslist.5 radiusd.conf.5 users.5
+MAN8= builddbm.8 radiusd.8 radwatch.8
+
+#
+# Figure most users will want these. N.B.: if you change these,
+# the packing list will be wrong.
+#
+STATIC_MODULES= acct_unique always attr_filter detail dictionary \
+ files mschap ns_mta_md5 pam preprocess radutmp realm unix
+
+# Modules that still need work: counter ldap sql
+
+CONFIGURE_ARGS= --without-snmp --without-threads --localstatedir=/var \
+ --with-static-modules="${STATIC_MODULES}" \
+ --disable-ltdl-install
+
+KRB5_MOD= ${WRKSRC}/src/modules/rlm_krb5
+
+post-patch:
+.if defined(WANT_KRB5) && defined(KRB5_HOME)
+ @${MV} ${KRB5_MOD}/Makefile ${KRB5_MOD}/Makefile.orig
+ @${SED} -e 's;^KRB5_LOCATION=.*$$;KRB5_LOCATION=${KRB5_HOME};' \
+ < ${KRB5_MOD}/Makefile.orig > ${KRB5_MOD}/Makefile
+.endif
+
+#
+# Installing these libraries is pointless since they are statically
+# linked into the executable we installed. It's easier to just
+# delete them here rather than hacking the build system to not
+# install them.
+#
+UNWANTED_LIBS=${STATIC_MODULES:S/^/lib\/rlm_/:S/$/.a/} \
+ lib/rlm_example.a lib/rlm_fastusers.a lib/rlm_sql.a
+
+post-install:
+.if defined(WANT_KRB5) && defined(KRB5_HOME)
+ @${RM} ${PREFIX}/lib/rlm_krb5.a
+ @${ECHO} 'lib/rlm_krb5.so' >> ${TMPPLIST}
+ @${ECHO} 'lib/rlm_krb5.so.0' >> ${TMPPLIST}
+.endif
+ @cd ${PREFIX} && ${RM} ${UNWANTED_LIBS}
+.for f in acct_users attrs clients clients.conf hints huntgroups ldap.attrmap \
+ naslist naspasswd proxy.conf radiusd.conf realms snmp.conf sql.conf \
+ users
+ @${MV} ${PREFIX}/etc/raddb/${f} ${PREFIX}/etc/raddb/${f}.sample
+.endfor
+
+# XXX should install an rc.d script.
+# XXX should install some documentation.
+
+.include <bsd.port.mk>
diff --git a/net/freeradius-devel/distinfo b/net/freeradius-devel/distinfo
new file mode 100644
index 000000000000..115287e31bda
--- /dev/null
+++ b/net/freeradius-devel/distinfo
@@ -0,0 +1 @@
+MD5 (freeradius-alpha-snapshot-20010310.tar.gz) = 4a76f0a7c94056f7aa936c76c04202a1
diff --git a/net/freeradius-devel/files/patch-aa b/net/freeradius-devel/files/patch-aa
new file mode 100644
index 000000000000..0d75341224a5
--- /dev/null
+++ b/net/freeradius-devel/files/patch-aa
@@ -0,0 +1,13 @@
+--- configure.in~ Fri Mar 9 13:30:09 2001
++++ configure.in Wed Mar 14 12:58:01 2001
+@@ -52,8 +52,8 @@
+ from ftp://prep.ai.mit.edu/pub/gnu/make/ before continuing.)
+ fi
+
+-dnl libltdl is installable
+-AC_LIBLTDL_INSTALLABLE
++dnl libltdl is not installable
++AC_LIBLTDL_CONVENIENCE
+
+ dnl ensure that we're looking for dlopen
+ AC_LIBTOOL_DLOPEN
diff --git a/net/freeradius-devel/files/patch-ab b/net/freeradius-devel/files/patch-ab
new file mode 100644
index 000000000000..68f0762d6c2c
--- /dev/null
+++ b/net/freeradius-devel/files/patch-ab
@@ -0,0 +1,10 @@
+--- scripts/Makefile~ Fri Nov 24 09:43:36 2000
++++ scripts/Makefile Wed Mar 14 13:24:59 2001
+@@ -4,7 +4,6 @@
+ all:
+
+ install:
+- $(INSTALL) -m 755 rc.radiusd $(R)$(sbindir)
+ $(INSTALL) -m 755 radwatch $(R)$(sbindir)
+ $(INSTALL) -m 755 check-radiusd-config $(R)$(sbindir)
+
diff --git a/net/freeradius-devel/pkg-comment b/net/freeradius-devel/pkg-comment
new file mode 100644
index 000000000000..a95ea2423b0e
--- /dev/null
+++ b/net/freeradius-devel/pkg-comment
@@ -0,0 +1 @@
+A new RADIUS authentication and accounting server with loadable modules
diff --git a/net/freeradius-devel/pkg-descr b/net/freeradius-devel/pkg-descr
new file mode 100644
index 000000000000..69f3c4bc2d2d
--- /dev/null
+++ b/net/freeradius-devel/pkg-descr
@@ -0,0 +1,6 @@
+RADIUS is a protocol which allows network hardware such as remote-access
+concentrators and routers to authenticate and log accounting records
+for logins. The FreeRADIUS project is developing an Open Source
+alternative to the semi-proprietary Lucent and MERIT servers; it is an
+indirect followon to the Cistron RADIUS server. This server is
+presently considered ``alpha-quality'' code by its developers.
diff --git a/net/freeradius-devel/pkg-plist b/net/freeradius-devel/pkg-plist
new file mode 100644
index 000000000000..6565adb3daa0
--- /dev/null
+++ b/net/freeradius-devel/pkg-plist
@@ -0,0 +1,46 @@
+bin/radclient
+bin/radlast
+bin/radtest
+bin/raduse
+bin/radwho
+bin/radzap
+etc/raddb/acct_users.sample
+etc/raddb/attrs.sample
+etc/raddb/clients.sample
+etc/raddb/clients.conf.sample
+etc/raddb/dictionary
+etc/raddb/dictionary.acc
+etc/raddb/dictionary.ascend
+etc/raddb/dictionary.bay
+etc/raddb/dictionary.cisco
+etc/raddb/dictionary.compat
+etc/raddb/dictionary.livingston
+etc/raddb/dictionary.microsoft
+etc/raddb/dictionary.redback
+etc/raddb/dictionary.shasta
+etc/raddb/dictionary.shiva
+etc/raddb/dictionary.tunnel
+etc/raddb/dictionary.usr
+etc/raddb/dictionary.versanet
+etc/raddb/hints.sample
+etc/raddb/huntgroups.sample
+etc/raddb/ldap.attrmap.sample
+etc/raddb/naslist.sample
+etc/raddb/naspasswd.sample
+etc/raddb/proxy.conf.sample
+etc/raddb/radiusd.conf.sample
+etc/raddb/realms.sample
+etc/raddb/snmp.conf.sample
+etc/raddb/sql.conf.sample
+etc/raddb/users.sample
+lib/rlm_example.so
+lib/rlm_example.so.0
+lib/rlm_fastusers.so
+lib/rlm_fastusers.so.0
+lib/rlm_sql.so
+lib/rlm_sql.so.0
+sbin/check-radiusd-config
+sbin/checkrad
+sbin/radiusd
+sbin/radwatch
+@dirrm etc/raddb