aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-01-09 08:08:40 +0800
committermakc <makc@FreeBSD.org>2013-01-09 08:08:40 +0800
commit01ed6bfb2dc7e12fdfdb83cadf514330d350ef7d (patch)
tree912ce6caf899ca4b8a9399107c5468e703e1edc0
parent04e95190c113196fe713cd1684e16ae01cea297e (diff)
downloadfreebsd-ports-gnome-01ed6bfb2dc7e12fdfdb83cadf514330d350ef7d.tar.gz
freebsd-ports-gnome-01ed6bfb2dc7e12fdfdb83cadf514330d350ef7d.tar.zst
freebsd-ports-gnome-01ed6bfb2dc7e12fdfdb83cadf514330d350ef7d.zip
Add new port devel/libregf:
Library and tools to support the Windows NT Registry File (REGF) format. WWW: http://code.google.com/p/libregf/ PR: ports/174614 Submitted by: antoine@
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libregf/Makefile41
-rw-r--r--devel/libregf/distinfo2
-rw-r--r--devel/libregf/pkg-descr3
-rw-r--r--devel/libregf/pkg-plist20
5 files changed, 67 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8d5587c08fff..b7933bf0e26d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1047,6 +1047,7 @@
SUBDIR += librcd
SUBDIR += libreadline-java
SUBDIR += libredblack
+ SUBDIR += libregf
SUBDIR += librelp
SUBDIR += libruin
SUBDIR += libs11n
diff --git a/devel/libregf/Makefile b/devel/libregf/Makefile
new file mode 100644
index 000000000000..8add73b45cad
--- /dev/null
+++ b/devel/libregf/Makefile
@@ -0,0 +1,41 @@
+# Created by: antoine@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= libregf
+DISTVERSION= alpha-20121112
+CATEGORIES= devel
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Library and tools to support the Windows NT Registry File format
+
+LICENSE= LGPL3
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-python
+USE_FUSE= yes
+USE_GETTEXT= yes
+USE_GNOME= gnomehack
+USE_ICONV= yes
+USE_PYTHON= yes
+USE_LDCONFIG= yes
+
+LDFLAGS+= -L${LOCALBASE}/lib
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
+
+MAN1= regfinfo.1
+MAN3= libregf.3
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= AUTHORS ChangeLog
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/libregf/distinfo b/devel/libregf/distinfo
new file mode 100644
index 000000000000..d31e27c77aeb
--- /dev/null
+++ b/devel/libregf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libregf-alpha-20121112.tar.gz) = 7b348c3c10bce727c3ed3b2a21a246ec5ea7f7492f27732076db2e4a12996d7f
+SIZE (libregf-alpha-20121112.tar.gz) = 1356588
diff --git a/devel/libregf/pkg-descr b/devel/libregf/pkg-descr
new file mode 100644
index 000000000000..828edef79780
--- /dev/null
+++ b/devel/libregf/pkg-descr
@@ -0,0 +1,3 @@
+Library and tools to support the Windows NT Registry File (REGF) format.
+
+WWW: http://code.google.com/p/libregf/
diff --git a/devel/libregf/pkg-plist b/devel/libregf/pkg-plist
new file mode 100644
index 000000000000..521a75bcd82f
--- /dev/null
+++ b/devel/libregf/pkg-plist
@@ -0,0 +1,20 @@
+bin/regfexport
+bin/regfinfo
+bin/regfmount
+bin/regfreport
+include/libregf.h
+include/libregf/codepage.h
+include/libregf/definitions.h
+include/libregf/error.h
+include/libregf/extern.h
+include/libregf/features.h
+include/libregf/types.h
+lib/libregf.a
+lib/libregf.la
+lib/libregf.so
+lib/libregf.so.1
+%%PYTHON_SITELIBDIR%%/pyregf.a
+%%PYTHON_SITELIBDIR%%/pyregf.la
+%%PYTHON_SITELIBDIR%%/pyregf.so
+libdata/pkgconfig/libregf.pc
+@dirrm include/libregf