aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2015-04-04 21:30:20 +0800
committerdemon <demon@FreeBSD.org>2015-04-04 21:30:20 +0800
commit0266b3d31dd6e38dd18a92e0cee85573ec00c3f2 (patch)
tree9b6d5bd43e093e2df164b5f2374b7d09550221fa
parentadd2ba1224f114f96d91fd16f0ac9ffdc8c8fee8 (diff)
downloadfreebsd-ports-gnome-0266b3d31dd6e38dd18a92e0cee85573ec00c3f2.tar.gz
freebsd-ports-gnome-0266b3d31dd6e38dd18a92e0cee85573ec00c3f2.tar.zst
freebsd-ports-gnome-0266b3d31dd6e38dd18a92e0cee85573ec00c3f2.zip
As noted by thierry@ in D2086, scipy inherits blas library to use from numpy
(via site.cfg). So remove unused OPTIONs from here. Remove check for static ATLAS lib because now ATLAS always builds static version. Remove obsoleted malloc.h --> stdlib.h conversion.
-rw-r--r--science/py-scipy/Makefile23
1 files changed, 3 insertions, 20 deletions
diff --git a/science/py-scipy/Makefile b/science/py-scipy/Makefile
index bcb721212022..1f7b9156c5cd 100644
--- a/science/py-scipy/Makefile
+++ b/science/py-scipy/Makefile
@@ -17,7 +17,8 @@ COMMENT= Scientific tools for Python
LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${PYNUMPY}
-RUN_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} \
+ swig:${PORTSDIR}/devel/swig13
USES= fortran python
USE_PYTHON= distutils autoplist concurrent
@@ -27,33 +28,15 @@ PYDISTUTILS_BUILDARGS+= --fcompiler=gnu95
LDFLAGS+= -shared
-OPTIONS_DEFINE= ATLAS DOCS SUITESPARSE
-OPTIONS_DEFAULT=SUITESPARSE
-ATLAS_DESC= Use optimized blas library
-SUITESPARSE_DESC= Use AMD and UMFPACK in SuiteSparse
-
-ATLAS_USES= blaslapack:atlas
-ATLAS_USES_OFF= blaslapack:netlib
-SUITESPARSE_LIB_DEPENDS= libumfpack.so:${PORTSDIR}/math/suitesparse
-SUITESPARSE_BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
+OPTIONS_DEFINE= DOCS
PORTDOCS= scipy-ref-${PORTVERSION}.pdf
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MATLAS}
-.if !exists(${LOCALBASE}/lib/libalapack.a)
-IGNORE= atlas needs to be built with WITH_STATIC for scipy to function properly
-.endif
-.endif
-
post-extract:
@${CP} ${DISTDIR}/scipy-ref-${PORTVERSION}.pdf ${WRKDIR}
-post-patch:
- @${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
- -e "s@malloc\.h@stdlib.h@"
-
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}