aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-08-26 20:56:54 +0800
committerbapt <bapt@FreeBSD.org>2013-08-26 20:56:54 +0800
commit042ed3d7a2e79b36218108c3dddc075b2743c414 (patch)
tree035e5c282836e41c14c1c0027ef58210375cbd13
parent31b36415cd9bc47352b0484a60468b84578bc529 (diff)
downloadfreebsd-ports-gnome-042ed3d7a2e79b36218108c3dddc075b2743c414.tar.gz
freebsd-ports-gnome-042ed3d7a2e79b36218108c3dddc075b2743c414.tar.zst
freebsd-ports-gnome-042ed3d7a2e79b36218108c3dddc075b2743c414.zip
Remove -Werror to allow building with clang
-rw-r--r--security/razorback-api/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/security/razorback-api/Makefile b/security/razorback-api/Makefile
index 9aa7fb73cda0..758da4fd24df 100644
--- a/security/razorback-api/Makefile
+++ b/security/razorback-api/Makefile
@@ -31,7 +31,6 @@ USES= pathfix
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CFLAGS+= -Wno-cast-align
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -61,6 +60,10 @@ BROKEN= does not build when compiled with clang
BROKEN= Does not compile on sparc64
.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s/-Werror//g" \
+ ${WRKSRC}/configure
+
post-install:
@if [ ! -f ${PREFIX}/etc/razorback/api.conf ]; then \
${CP} -p ${PREFIX}/etc/razorback/api.conf.sample ${PREFIX}/etc/razorback/api.conf ; \