aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-05-15 19:29:37 +0800
committerkrion <krion@FreeBSD.org>2004-05-15 19:29:37 +0800
commit053d0bd91564ffcb2975ef468ea31049e07c4be1 (patch)
tree7edb057fb3a8056e50f007212d5eee2be3cb9380
parent39d8b60c002d47913ccddc10f911ab0aaffe1f0c (diff)
downloadfreebsd-ports-gnome-053d0bd91564ffcb2975ef468ea31049e07c4be1.tar.gz
freebsd-ports-gnome-053d0bd91564ffcb2975ef468ea31049e07c4be1.tar.zst
freebsd-ports-gnome-053d0bd91564ffcb2975ef468ea31049e07c4be1.zip
Add lep 0.30,
LEP is my attempt to provide a simple yet effective crypto system that focuses largely on streamlining tasks and less on elaborate inclusion of algorithms (MD5 and Blowfish are the only official algorithms used, both of which are linked in from -lcrypto), and also has some simple implementations of classic cipher design (transposition, byte swapping, caesar, XOR, hex encoding, etc) which can fit into the same operation chain, relieving the need for OS overhead with process spawning and piping. PR: ports/66659 Submitted by: Dmitri Nikulin <setagllib@optusnet.com.au>
-rw-r--r--security/Makefile1
-rw-r--r--security/lep/Makefile26
-rw-r--r--security/lep/distinfo2
-rw-r--r--security/lep/pkg-descr7
4 files changed, 36 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4d5cec4815af..d382db2b8646 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -151,6 +151,7 @@
SUBDIR += labrea
SUBDIR += lcrzo
SUBDIR += lcrzoex
+ SUBDIR += lep
SUBDIR += libassuan
SUBDIR += libbf
SUBDIR += libecc
diff --git a/security/lep/Makefile b/security/lep/Makefile
new file mode 100644
index 000000000000..35378c8c0a1a
--- /dev/null
+++ b/security/lep/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: lep
+# Date created: 15 May 2004
+# Whom: Dmitri Nikulin <setagllib@optusnet.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lep
+PORTVERSION= 0.30
+CATEGORIES= security
+MASTER_SITES= http://members.optusnet.com.au/setagllib/
+
+MAINTAINER= setagllib@optusnet.com.au
+COMMENT= Lesser Encryption Project
+
+USE_BZIP2= yes
+USE_OPENSSL= yes
+
+MAN1= lep.1
+PLIST_FILES= bin/lep
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lep ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/lep.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/security/lep/distinfo b/security/lep/distinfo
new file mode 100644
index 000000000000..5bf9119603af
--- /dev/null
+++ b/security/lep/distinfo
@@ -0,0 +1,2 @@
+MD5 (lep-0.30.tar.bz2) = e92500ba80dca6cdc5a69674770443b0
+SIZE (lep-0.30.tar.bz2) = 5551
diff --git a/security/lep/pkg-descr b/security/lep/pkg-descr
new file mode 100644
index 000000000000..04078050007b
--- /dev/null
+++ b/security/lep/pkg-descr
@@ -0,0 +1,7 @@
+LEP - Lesser Encryption Project
+
+Provides flexible chaining of simple encryption tasks in a
+lightweight software package.
+
+WWW: None yet
+setagllib@optusnet.com.au