aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2005-10-30 15:13:12 +0800
committerobrien <obrien@FreeBSD.org>2005-10-30 15:13:12 +0800
commit0777c6451bbc918851955f3c96c521869b579ebb (patch)
tree807b1878293d4e1cd5f5feec8928e43b38afb3ba
parent1410b013d38c1eca09da3cdefc6e5189d59871ea (diff)
downloadfreebsd-ports-gnome-0777c6451bbc918851955f3c96c521869b579ebb.tar.gz
freebsd-ports-gnome-0777c6451bbc918851955f3c96c521869b579ebb.tar.zst
freebsd-ports-gnome-0777c6451bbc918851955f3c96c521869b579ebb.zip
Update to use tcl 8.4.
-rw-r--r--editors/vim5/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/editors/vim5/Makefile b/editors/vim5/Makefile
index 61611adfe548..2cffb909447f 100644
--- a/editors/vim5/Makefile
+++ b/editors/vim5/Makefile
@@ -22,8 +22,7 @@ MAINTAINER?= obrien@FreeBSD.org
COMMENT= Vi "workalike", with many additional features
.if defined(PACKAGE_BUILDING) && !defined(LITE)
-BUILD_DEPENDS= tclsh8.0:${PORTSDIR}/lang/tcl80
-LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80
+WITH_TCL= yes
#USE_PERL5= yes
.endif
@@ -71,6 +70,12 @@ MAKE_ARGS+= CONF_OPT_GUI="--enable-gui=no --without-x --enable-multibyte"
MAKE_ARGS+= CONF_OPT_PERL="--disable-perlinterp --disable-pythoninterp --disable-tclinterp"
.endif # LITE
+.if defined(WITH_TCL)
+BUILD_DEPENDS= tclsh8.4:${PORTSDIR}/lang/tcl84
+LIB_DEPENDS= tcl84.1:${PORTSDIR}/lang/tcl84
+MAKE_ARGS+= CONF_OPT_TCL="--enable-tclinterp --with-tclsh=${LOCALBASE}/bin/tclsh8.4"
+.endif
+
.include <bsd.port.pre.mk>
pre-build: