aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-03-22 03:56:42 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-03-22 03:56:42 +0800
commit09acfc8a00a01b55d1aef0c82d9f7b871269c376 (patch)
tree497d4d093d102dc3282a77dcd98b11aaa024d3b2
parentb5ce1c2d949e4933f3b44d24ff29ea6347c22667 (diff)
downloadfreebsd-ports-gnome-09acfc8a00a01b55d1aef0c82d9f7b871269c376.tar.gz
freebsd-ports-gnome-09acfc8a00a01b55d1aef0c82d9f7b871269c376.tar.zst
freebsd-ports-gnome-09acfc8a00a01b55d1aef0c82d9f7b871269c376.zip
- Fix *_DEPENDS: version is already in all supported Perl releases
- Add LICENSE - Use bsd.port.mk instead of bsd.port.pre.mk + bsd.port.post.mk - Remove regression-test: - Use ECHO_MSG - Bump PORTREVISION for dependency change
-rw-r--r--devel/svk/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/devel/svk/Makefile b/devel/svk/Makefile
index 9a36bdb7a397..d695f9a7b347 100644
--- a/devel/svk/Makefile
+++ b/devel/svk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= svk
PORTVERSION= 2.2.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:CLKAO
@@ -12,6 +12,9 @@ DISTNAME= SVK-v${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Distributed Version Control System
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
BUILD_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
@@ -45,22 +48,16 @@ BUILD_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-SVN-Mirror>=0.71:${PORTSDIR}/devel/p5-SVN-Mirror \
p5-Time-Progress>=0:${PORTSDIR}/devel/p5-Time-Progress \
p5-YAML-Syck>=0.60:${PORTSDIR}/textproc/p5-YAML-Syck \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
- p5-version>=0.68:${PORTSDIR}/devel/p5-version
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
pre-everything::
- @${ECHO} ""
- @${ECHO} "If you see some missing dependency, please update your"
- @${ECHO} "ports tree and upgrade it with 'portupgrade -R svk'."
- @${ECHO} ""
-
-regression-test:
- cd ${WRKSRC} && ${MAKE} test
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "If you see some missing dependency, please update your"
+ @${ECHO_MSG} "ports tree and upgrade it with 'portupgrade -R svk'."
+ @${ECHO_MSG} ""
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>