aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-02-10 19:27:57 +0800
committermiwi <miwi@FreeBSD.org>2009-02-10 19:27:57 +0800
commit0e33bb166cb910522e1cd83b4affe971b14f8183 (patch)
treec03e5bcec0ec014c41b2da1e9bfe9b7f9c0b6c0d
parent999585c343731dfcde0983e7c46d303e6f7a7b46 (diff)
downloadfreebsd-ports-gnome-0e33bb166cb910522e1cd83b4affe971b14f8183.tar.gz
freebsd-ports-gnome-0e33bb166cb910522e1cd83b4affe971b14f8183.tar.zst
freebsd-ports-gnome-0e33bb166cb910522e1cd83b4affe971b14f8183.zip
The OpenPGP SDK project provides an open source library, written in C,
which implements the OpenPGP specification. WWW: http://openpgp.nominet.org.uk/
-rw-r--r--security/Makefile1
-rw-r--r--security/openpgpsdk/Makefile36
-rw-r--r--security/openpgpsdk/distinfo3
-rw-r--r--security/openpgpsdk/pkg-descr4
4 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 5062ffba885b..8ed9b3f0469f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -308,6 +308,7 @@
SUBDIR += opencdk
SUBDIR += openct
SUBDIR += openfwtk
+ SUBDIR += openpgpsdk
SUBDIR += opensaml
SUBDIR += opensaml2
SUBDIR += opensc
diff --git a/security/openpgpsdk/Makefile b/security/openpgpsdk/Makefile
new file mode 100644
index 000000000000..40bc914256d3
--- /dev/null
+++ b/security/openpgpsdk/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: openpgpsdk
+# Date created: 2009-02-10
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openpgpsdk
+PORTVERSION= 0.9
+CATEGORIES= security
+MASTER_SITES= http://openpgp.nominet.org.uk/downloads/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= OpenPGP SDK
+
+BUILD_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
+LIB_DEPENDS= cunit.1:${PORTSDIR}/devel/cunit
+
+USE_PERL5= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --without-idea --with-cunit=${LOCALBASE}
+
+PLIST_FILES= bin/openpgp lib/libops.a
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700042
+BROKEN= does not build on 6.x.
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/openpgp ${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/lib/libops.a ${PREFIX}/lib/
+
+.include <bsd.port.post.mk>
diff --git a/security/openpgpsdk/distinfo b/security/openpgpsdk/distinfo
new file mode 100644
index 000000000000..29f1a9cd4518
--- /dev/null
+++ b/security/openpgpsdk/distinfo
@@ -0,0 +1,3 @@
+MD5 (openpgpsdk-0.9.tgz) = a2fe87ee864e6bcc0d5ea3db20e0f57a
+SHA256 (openpgpsdk-0.9.tgz) = 96ad3196205d323818f7175e24f7e3a227c90f76eb308c0ebaae0de26b7c2376
+SIZE (openpgpsdk-0.9.tgz) = 1903992
diff --git a/security/openpgpsdk/pkg-descr b/security/openpgpsdk/pkg-descr
new file mode 100644
index 000000000000..6b514041fc10
--- /dev/null
+++ b/security/openpgpsdk/pkg-descr
@@ -0,0 +1,4 @@
+The OpenPGP SDK project provides an open source library, written in C,
+which implements the OpenPGP specification.
+
+WWW: http://openpgp.nominet.org.uk/