aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-10-31 23:37:17 +0800
committerleeym <leeym@FreeBSD.org>2004-10-31 23:37:17 +0800
commit100fe5050b6a75fd7fd00f8d3f3a8c861c730406 (patch)
tree5647bdacca5aa6ef75b4af47fb4d64f3c2529fe9
parent9a1cdcf831c8759931ae0cce896c4463e065b2f6 (diff)
downloadfreebsd-ports-gnome-100fe5050b6a75fd7fd00f8d3f3a8c861c730406.tar.gz
freebsd-ports-gnome-100fe5050b6a75fd7fd00f8d3f3a8c861c730406.tar.zst
freebsd-ports-gnome-100fe5050b6a75fd7fd00f8d3f3a8c861c730406.zip
- add USE_GCC=3.3 when gcc is 3.4 by default
- replace pkg-plist with PLIST_FILES and PORTDOCS - update the URL in pkg-descr
-rw-r--r--devel/libformat/Makefile9
-rw-r--r--devel/libformat/pkg-descr2
-rw-r--r--devel/libformat/pkg-plist8
3 files changed, 6 insertions, 13 deletions
diff --git a/devel/libformat/Makefile b/devel/libformat/Makefile
index c6d62db989ea..f9e002770ee1 100644
--- a/devel/libformat/Makefile
+++ b/devel/libformat/Makefile
@@ -18,18 +18,19 @@ COMMENT= C++ library that supports printf style like format printing
MAKEFILE= ${FILESDIR}/Makefile.lib
INSTALLS_SHLIB= yes
+PORTDOCS= ChangeLog README testformat.cpp
+PLIST_FILES= include/format.h lib/libformat.a lib/libformat.so lib/libformat.so.1
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
+USE_GCC= 3.3
.endif
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ChangeLog README testformat.cpp
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/devel/libformat/pkg-descr b/devel/libformat/pkg-descr
index f40ccc81555c..66d7cfa9a24a 100644
--- a/devel/libformat/pkg-descr
+++ b/devel/libformat/pkg-descr
@@ -1,3 +1,3 @@
C++ library that supports printf style like format printing
-WWW: http://home.pages.at/kingleo/development/cpp-en.html#format
+WWW: http://kingleo.home.pages.at/index.php?language=EN&show=/development/cpp
diff --git a/devel/libformat/pkg-plist b/devel/libformat/pkg-plist
deleted file mode 100644
index f252472f6c75..000000000000
--- a/devel/libformat/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-include/format.h
-lib/libformat.a
-lib/libformat.so
-lib/libformat.so.1
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/testformat.cpp
-%%PORTDOCS%%@dirrm %%DOCSDIR%%