aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-06-21 19:07:55 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-06-21 19:07:55 +0800
commit1069731f67d0fc0a6e92868c517366ba3f89735e (patch)
tree6353d5542bb342a6d14ba9f089a7bfd301e63944
parent72d0d3bf160f3265f506639d7efd7d73095ed141 (diff)
downloadfreebsd-ports-gnome-1069731f67d0fc0a6e92868c517366ba3f89735e.tar.gz
freebsd-ports-gnome-1069731f67d0fc0a6e92868c517366ba3f89735e.tar.zst
freebsd-ports-gnome-1069731f67d0fc0a6e92868c517366ba3f89735e.zip
- Fix build with clang
- Use USE_DOS2UNIX instead of self-cooked regex
-rw-r--r--audio/penguinsap/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/audio/penguinsap/Makefile b/audio/penguinsap/Makefile
index 69d33c9abd0f..061057824b24 100644
--- a/audio/penguinsap/Makefile
+++ b/audio/penguinsap/Makefile
@@ -13,10 +13,11 @@ MASTER_SITES= CRITICAL
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A command line Atari(TM) .sap player
+USE_DOS2UNIX= yes
+
MAKE_JOBS_SAFE= yes
SOURCES= sapPokey pokey1 sapCpu sapEngine main pokey0
-CXXFLAGS+= --no-exceptions
.if defined(WITH_OPTIMIZED_CFLAGS)
EXTRAFLAGS= -ffast-math -malign-double -finline-limit-1000000 \
@@ -25,12 +26,16 @@ EXTRAFLAGS= -ffast-math -malign-double -finline-limit-1000000 \
PLIST_FILES= bin/sap
+.include <bsd.port.pre.mk>
+
+.if ${CXX:T} != "clang++"
+CXXFLAGS+= --no-exceptions
+.endif
+
post-patch:
-# gcc 2.95.4 does not like CR/LFs
- @${FIND} ${WRKSRC} -type f -exec \
- ${REINPLACE_CMD} -E -e 's| ||' {} \;
@${REINPLACE_CMD} -e 's|linux/soundcard\.h|sys/soundcard\.h|' \
${WRKSRC}/main.cpp
+ @${REINPLACE_CMD} -e 's|--no-exceptions||' ${WRKSRC}/build.inc
do-build:
.for f in ${SOURCES}
@@ -46,4 +51,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>