aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2017-04-03 19:37:39 +0800
committerbapt <bapt@FreeBSD.org>2017-04-03 19:37:39 +0800
commit1440afb0ffe01b6f1c1fe7165901328073849084 (patch)
tree40ec4058303ed13b129582647ac4dc10170e997a
parent44d338e4b9e2280e26f100f169742cb06f176eaa (diff)
downloadfreebsd-ports-gnome-1440afb0ffe01b6f1c1fe7165901328073849084.tar.gz
freebsd-ports-gnome-1440afb0ffe01b6f1c1fe7165901328073849084.tar.zst
freebsd-ports-gnome-1440afb0ffe01b6f1c1fe7165901328073849084.zip
Fix build with newer sigc++20
-rw-r--r--audio/paprefs/Makefile5
-rw-r--r--japanese/xdtp/Makefile3
-rw-r--r--textproc/stardict3/Makefile6
3 files changed, 7 insertions, 7 deletions
diff --git a/audio/paprefs/Makefile b/audio/paprefs/Makefile
index 1442cc99540a..33b184b1edda 100644
--- a/audio/paprefs/Makefile
+++ b/audio/paprefs/Makefile
@@ -13,9 +13,8 @@ LIB_DEPENDS= libglademm-2.4.so:devel/libglademm24 \
libpulse.so:audio/pulseaudio
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-USES= gmake pkgconfig
+USES= compiler:c++11-lang localbase gmake pkgconfig
+USE_CXXSTD= c++11
USE_GNOME= gconfmm26 gnomeprefix intltool
CONFIGURE_ARGS= --disable-lynx
diff --git a/japanese/xdtp/Makefile b/japanese/xdtp/Makefile
index 3238deec4a70..50bc254f5d64 100644
--- a/japanese/xdtp/Makefile
+++ b/japanese/xdtp/Makefile
@@ -13,7 +13,8 @@ COMMENT= XML document transfer program
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= pkgconfig tar:tgz
+USES= compiler:c++11-lang pkgconfig tar:tgz
+USE_CXXSTD= c++11
USE_GNOME= glibmm libxml2 libxslt
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index 77ec09e7626e..e35ca8f2e54d 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -22,9 +22,9 @@ CONFIGURE_ARGS= --disable-festival \
--disable-updateinfo \
--disable-advertisement
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
+USES= compiler:c++11-lang gettext gmake libtool localbase pathfix \
+ pkgconfig tar:bzip2
+USE_CXXSTD= c++11
USE_GNOME= intltool
OPTIONS_DEFINE= GNOME