aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-11-30 05:14:00 +0800
committeradamw <adamw@FreeBSD.org>2015-11-30 05:14:00 +0800
commit16e963ce719e053851cd0255f998499986104a8f (patch)
tree0e93c7392c0be470def18033a3bf4a9b3b250a0d
parent8ecd960a273d3873765a9f54da0c978a2dde64dc (diff)
downloadfreebsd-ports-gnome-16e963ce719e053851cd0255f998499986104a8f.tar.gz
freebsd-ports-gnome-16e963ce719e053851cd0255f998499986104a8f.tar.zst
freebsd-ports-gnome-16e963ce719e053851cd0255f998499986104a8f.zip
Update to 4.00. Sort plist. Remove patches that are now part of upstream.
Changes: https://metacpan.org/changes/distribution/podlators
-rw-r--r--textproc/p5-podlators/Makefile5
-rw-r--r--textproc/p5-podlators/distinfo4
-rw-r--r--textproc/p5-podlators/files/patch-lib_Pod_Man.pm107
-rw-r--r--textproc/p5-podlators/files/patch-t_devise-date.t39
-rw-r--r--textproc/p5-podlators/pkg-plist12
5 files changed, 10 insertions, 157 deletions
diff --git a/textproc/p5-podlators/Makefile b/textproc/p5-podlators/Makefile
index bf01fab2a452..f3c2cc453746 100644
--- a/textproc/p5-podlators/Makefile
+++ b/textproc/p5-podlators/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= podlators
-PORTVERSION= 2.5.3
-PORTREVISION= 2
+PORTVERSION= 4.00
CATEGORIES= textproc perl5
MASTER_SITES= CPAN/Pod
PKGNAMEPREFIX= p5-
@@ -18,6 +17,6 @@ USES= perl5
USE_PERL5= configure
post-patch:
- @${REINPLACE_CMD} -e "/man1pod (/d; /EXE_FILES/d" ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -e "/man1pod(/d; /EXE_FILES/d" ${WRKSRC}/Makefile.PL
.include <bsd.port.mk>
diff --git a/textproc/p5-podlators/distinfo b/textproc/p5-podlators/distinfo
index a446d279425a..631b3839533f 100644
--- a/textproc/p5-podlators/distinfo
+++ b/textproc/p5-podlators/distinfo
@@ -1,2 +1,2 @@
-SHA256 (podlators-2.5.3.tar.gz) = c80d6d65a8694720deff1c6b2067d7564727db713b6d6b536afbad70299647d1
-SIZE (podlators-2.5.3.tar.gz) = 104823
+SHA256 (podlators-4.00.tar.gz) = 89773a6e427b29ed86e847d2fb8d386c1ba329dd5e433a7e592c4a3055288c14
+SIZE (podlators-4.00.tar.gz) = 138853
diff --git a/textproc/p5-podlators/files/patch-lib_Pod_Man.pm b/textproc/p5-podlators/files/patch-lib_Pod_Man.pm
deleted file mode 100644
index 84b183e9a4cc..000000000000
--- a/textproc/p5-podlators/files/patch-lib_Pod_Man.pm
+++ /dev/null
@@ -1,107 +0,0 @@
---- lib/Pod/Man.pm.orig 2013-10-06 06:09:56 UTC
-+++ lib/Pod/Man.pm
-@@ -876,25 +876,42 @@ sub devise_title {
- }
-
- # Determine the modification date and return that, properly formatted in ISO
--# format. If we can't get the modification date of the input, instead use the
--# current time. Pod::Simple returns a completely unuseful stringified file
--# handle as the source_filename for input from a file handle, so we have to
--# deal with that as well.
-+# format.
-+#
-+# If POD_MAN_DATE is set, that overrides anything else. This can be used for
-+# reproducible generation of the same file even if the input file timestamps
-+# are unpredictable or the POD coms from standard input.
-+#
-+# Otherwise, use the modification date of the input if we can stat it. Be
-+# aware that Pod::Simple returns the stringification of the file handle as
-+# source_filename for input from a file handle, so we'll stat some random ref
-+# string in that case. If that fails, instead use the current time.
-+#
-+# $self - Pod::Man object, used to get the source file
-+#
-+# Returns: YYYY-MM-DD date suitable for the left-hand footer
- sub devise_date {
- my ($self) = @_;
-+
-+ # If POD_MAN_DATE is set, always use it.
-+ if ($ENV{POD_MAN_DATE}) {
-+ return $ENV{POD_MAN_DATE};
-+ }
-+
-+ # Otherwise, get the input filename and try to stat it. If that fails,
-+ # use the current time.
- my $input = $self->source_filename;
- my $time;
- if ($input) {
-- $time = (stat $input)[9] || time;
-+ $time = (stat($input))[9] || time();
- } else {
-- $time = time;
-+ $time = time();
- }
-
-- # Can't use POSIX::strftime(), which uses Fcntl, because MakeMaker
-- # uses this and it has to work in the core which can't load dynamic
-- # libraries.
-- my ($year, $month, $day) = (localtime $time)[5,4,3];
-- return sprintf ("%04d-%02d-%02d", $year + 1900, $month + 1, $day);
-+ # Can't use POSIX::strftime(), which uses Fcntl, because MakeMaker uses
-+ # this and it has to work in the core which can't load dynamic libraries.
-+ my ($year, $month, $day) = (localtime($time))[5,4,3];
-+ return sprintf("%04d-%02d-%02d", $year + 1900, $month + 1, $day);
- }
-
- # Print out the preamble and the title. The meaning of the arguments to .TH
-@@ -1632,6 +1649,15 @@ argument.
- Sets the centered page header to use instead of "User Contributed Perl
- Documentation".
-
-+=item date
-+
-+Sets the left-hand footer. If this option is not set, the contents of the
-+environment variable POD_MAN_DATE, if set, will be used. Failing that,
-+the modification date of the input file will be used, or the current time
-+if stat() can't find that file (which will be the case if the input is
-+from C<STDIN>). If obtained from the file modification date or the
-+current time, he date will be formatted as C<YYYY-MM-DD>.
-+
- =item errors
-
- How to report errors. C<die> says to throw an exception on any POD
-@@ -1642,13 +1668,6 @@ POD errors entirely, as much as possible
-
- The default is C<pod>.
-
--=item date
--
--Sets the left-hand footer. By default, the modification date of the input
--file will be used, or the current date if stat() can't find that file (the
--case if the input is from C<STDIN>), and the date will be formatted as
--C<YYYY-MM-DD>.
--
- =item fixed
-
- The fixed-width font to use for verbatim text and code. Defaults to
-@@ -1810,6 +1829,20 @@ option was set to C<die>.
-
- =back
-
-+=head1 ENVIRONMENT
-+
-+=over 4
-+
-+=item POD_MAN_DATE
-+
-+If set, this will be used as the value of the left-hand footer unless the
-+C<date> option is explicitly set, overriding the timestamp of the input
-+file or the current time. This is primarily useful to ensure reproducible
-+builds of the same output file given the same souce and Pod::Man version,
-+even when file timestamps may not be consistent.
-+
-+=back
-+
- =head1 BUGS
-
- Encoding handling assumes that PerlIO is available and does not work
diff --git a/textproc/p5-podlators/files/patch-t_devise-date.t b/textproc/p5-podlators/files/patch-t_devise-date.t
deleted file mode 100644
index fb9024a309d4..000000000000
--- a/textproc/p5-podlators/files/patch-t_devise-date.t
+++ /dev/null
@@ -1,39 +0,0 @@
---- t/devise-date.t.orig 2013-10-06 06:09:56 UTC
-+++ t/devise-date.t
-@@ -1,15 +1,28 @@
--#!/usr/bin/perl -w
--
--# In order for MakeMaker to build in the core, nothing can use
--# Fcntl which includes POSIX. devise_date()'s use of strftime()
--# was replaced. This tests that it's identical.
-+#!/usr/bin/perl
-+#
-+# In order for MakeMaker to build in the core, nothing can use Fcntl which
-+# includes POSIX. devise_date()'s use of strftime() was replaced. This tests
-+# that it's identical. It also tests special handling of the POD_MAN_DATE
-+# environment variable.
-
-+use 5.006;
- use strict;
--
--use Test::More tests => 1;
-+use warnings;
-
- use Pod::Man;
- use POSIX qw(strftime);
-
-+use Test::More tests => 2;
-+
-+# Check that the results of device_date matches strftime. There is no input
-+# file name, so this will use the current time.
- my $parser = Pod::Man->new;
--is $parser->devise_date, strftime("%Y-%m-%d", localtime);
-+is(
-+ $parser->devise_date,
-+ strftime('%Y-%m-%d', localtime()),
-+ 'devise_date matches strftime'
-+);
-+
-+# Set the override environment variable and ensure that it's honored.
-+local $ENV{POD_MAN_DATE} = '2014-01-01';
-+is($parser->devise_date, '2014-01-01', 'devise_date honors POD_MAN_DATE');
diff --git a/textproc/p5-podlators/pkg-plist b/textproc/p5-podlators/pkg-plist
index 032f31757d1e..73f65e235571 100644
--- a/textproc/p5-podlators/pkg-plist
+++ b/textproc/p5-podlators/pkg-plist
@@ -1,12 +1,12 @@
-%%PERL5_MAN3%%/Pod::Man.3.gz
-%%PERL5_MAN3%%/Pod::ParseLink.3.gz
-%%PERL5_MAN3%%/Pod::Text.3.gz
-%%PERL5_MAN3%%/Pod::Text::Color.3.gz
-%%PERL5_MAN3%%/Pod::Text::Overstrike.3.gz
-%%PERL5_MAN3%%/Pod::Text::Termcap.3.gz
%%SITE_PERL%%/Pod/Man.pm
%%SITE_PERL%%/Pod/ParseLink.pm
%%SITE_PERL%%/Pod/Text.pm
%%SITE_PERL%%/Pod/Text/Color.pm
%%SITE_PERL%%/Pod/Text/Overstrike.pm
%%SITE_PERL%%/Pod/Text/Termcap.pm
+%%PERL5_MAN3%%/Pod::Man.3.gz
+%%PERL5_MAN3%%/Pod::ParseLink.3.gz
+%%PERL5_MAN3%%/Pod::Text.3.gz
+%%PERL5_MAN3%%/Pod::Text::Color.3.gz
+%%PERL5_MAN3%%/Pod::Text::Overstrike.3.gz
+%%PERL5_MAN3%%/Pod::Text::Termcap.3.gz