aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2017-02-02 05:47:47 +0800
committerolgeni <olgeni@FreeBSD.org>2017-02-02 05:47:47 +0800
commit180da8c55bf04a99d40f370340ef528da81156bf (patch)
tree6d31c00686d2de1c28b0d6da6178e20376b8e67c
parentf2ae892178a978427956b9802cec6b5802d1d4d6 (diff)
downloadfreebsd-ports-gnome-180da8c55bf04a99d40f370340ef528da81156bf.tar.gz
freebsd-ports-gnome-180da8c55bf04a99d40f370340ef528da81156bf.tar.zst
freebsd-ports-gnome-180da8c55bf04a99d40f370340ef528da81156bf.zip
Update lang/erlang-runtime19 to 19.2.2 and fix build with clang 4.0[1].
PR: 216615 [1] Submitted by: Jan Beich
-rw-r--r--lang/erlang-runtime19/Makefile8
-rw-r--r--lang/erlang-runtime19/distinfo4
-rw-r--r--lang/erlang-runtime19/files/patch-lib_wx_c__src_wxe__impl.cpp20
3 files changed, 29 insertions, 3 deletions
diff --git a/lang/erlang-runtime19/Makefile b/lang/erlang-runtime19/Makefile
index 0c9dde744157..49e8742d6e73 100644
--- a/lang/erlang-runtime19/Makefile
+++ b/lang/erlang-runtime19/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= erlang
-PORTVERSION= 19.2.1
+PORTVERSION= 19.2.2
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://erlang.stacken.kth.se/download/:erlangorg \
@@ -16,7 +16,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
PATCH_SITES= http://olgeni.olgeni.com/~olgeni/distfiles/ \
LOCAL/olgeni
-PATCHFILES= patch-otp-19.2.1
+PATCHFILES= patch-otp-19.2.1 patch-otp-19.2.2
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Functional programming language from Ericsson
@@ -217,6 +217,10 @@ post-install:
${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/erts-8.2.1
${RMDIR} ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/erts-8.2
+ ${MV} ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/lib/mnesia-4.14.2/* \
+ ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/lib/mnesia-4.14.3
+ ${RMDIR} ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/lib/mnesia-4.14.2
+
${INSTALL_DATA} ${WRKSRC}/lib/dialyzer/doc/*.txt \
${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/lib/dialyzer-*/doc/
.endif
diff --git a/lang/erlang-runtime19/distinfo b/lang/erlang-runtime19/distinfo
index 6c897fc81914..fdfb5515a82a 100644
--- a/lang/erlang-runtime19/distinfo
+++ b/lang/erlang-runtime19/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1484642442
+TIMESTAMP = 1485948940
SHA256 (erlang/otp_src_19.2.tar.gz) = a016b3ef5dac1e532972617b2715ef187ecb616f7cd7ddcfe0f1d502f5d24870
SIZE (erlang/otp_src_19.2.tar.gz) = 68395949
SHA256 (erlang/otp_doc_man_19.2.tar.gz) = 8a76ff3bb40a6d6a1552fa5a4204c8a3c7d99d2ea6f12684f02d038b23ad25cb
@@ -7,3 +7,5 @@ SHA256 (erlang/otp_doc_html_19.2.tar.gz) = c373c8c1a9fe7433825088684932f3ded76f5
SIZE (erlang/otp_doc_html_19.2.tar.gz) = 34761971
SHA256 (erlang/patch-otp-19.2.1) = 5fe07da09c914e1145c3e15e2f459fdb7cceedec0213a289ad238dada9645d2c
SIZE (erlang/patch-otp-19.2.1) = 9287
+SHA256 (erlang/patch-otp-19.2.2) = a64cac32675fe57cb749461eba9458bbc4d7abddf58996c897e2528a41f2e33c
+SIZE (erlang/patch-otp-19.2.2) = 9412
diff --git a/lang/erlang-runtime19/files/patch-lib_wx_c__src_wxe__impl.cpp b/lang/erlang-runtime19/files/patch-lib_wx_c__src_wxe__impl.cpp
new file mode 100644
index 000000000000..5b1e66586f2f
--- /dev/null
+++ b/lang/erlang-runtime19/files/patch-lib_wx_c__src_wxe__impl.cpp
@@ -0,0 +1,20 @@
+--- lib/wx/c_src/wxe_impl.cpp.orig 2017-01-30 23:13:25 UTC
++++ lib/wx/c_src/wxe_impl.cpp
+@@ -666,7 +666,7 @@ void * WxeApp::getPtr(char * bp, wxeMemE
+ throw wxe_badarg(index);
+ }
+ void * temp = memenv->ref2ptr[index];
+- if((index < memenv->next) && ((index == 0) || (temp > NULL)))
++ if((index < memenv->next) && ((index == 0) || (temp != NULL)))
+ return temp;
+ else {
+ throw wxe_badarg(index);
+@@ -678,7 +678,7 @@ void WxeApp::registerPid(char * bp, ErlD
+ if(!memenv)
+ throw wxe_badarg(index);
+ void * temp = memenv->ref2ptr[index];
+- if((index < memenv->next) && ((index == 0) || (temp > NULL))) {
++ if((index < memenv->next) && ((index == 0) || (temp != NULL))) {
+ ptrMap::iterator it;
+ it = ptr2ref.find(temp);
+ if(it != ptr2ref.end()) {